Contenido del campo Memo puede aparecer como caracteres de control cuando se utiliza la cláusula GROUP BY en el campo Memo en una consulta en Microsoft Access


Nº de error: 29350 (Mantenimiento de contenido) este artículo sólo se aplica a una base de datos de Microsoft Access (.mdb).

Principiante: Se requieren conocimientos de la interfaz de usuario en equipos de usuario único.

Síntomas


Cuando se utiliza la cláusula GROUP BY en un campo Memo, o Texto Largo, en una consulta en Microsoft Access, el contenido del campo Memo puede aparecer como caracteres de control son similares a los siguientes: "[]".

Solución alternativa


Para evitar este problema, utilice uno de los métodos siguientes.
  • En la vista Diseño de la consulta, cambiar AGRUPAR POR a PRIMERO en la fila Total de la columna del campo MEMO o TEXTO LARGO.
  • En la vista Diseño de la consulta, cree una expresión en una columna en blanco y utilice la función Left en el campo Memo. Por ejemplo, escriba lo siguiente en la fila campo en la primera columna en blanco de la consulta:

    MyMemo: Izquierda (notas, 10000).

    Nota: Al ordenar o agrupar en un campo de texto o en un campo Memo en Access, sólo los primeros 255 caracteres se utilizan para ordenar en o al grupo.

Estado


Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información


Puede utilizar la cláusula GROUP BY en un campo memo y se devuelven sólo los primeros 255 caracteres de la consulta. Se recomienda que no utilice la cláusula GROUP BY en campos Memo en las consultas de selección.

Pasos para reproducir el comportamiento

Access 2000, Access 2002 o Access 2003

  1. Inicie Microsoft Access y, a continuación, abra la base de datos de ejemplo Neptuno.mdb.
  2. En el panel objetos , haga clic en
    Consultas, haga clic en nuevo, haga clic en Vista Diseñoy, a continuación, haga clic en Aceptar.
  3. En el cuadro de diálogo Mostrar tabla , haga doble clic en los nombres de la tabla siguiente:
    • Empleados
    • Pedidos
    • Detalles del pedido
    • Clientes
  4. Haga clic en Cerrar.
  5. En la tabla empleados, haga doble clic en los nombres de campo siguientes:
    • Id. de empleado
    • Notas:
  6. En el menú Ver , haga clic en
    Totales.
  7. En el menú consulta , haga clic en
    Ejecutar.
Nota: Si agrega la tabla Shippers a la consulta o volver a organizar el orden en que se agregan las tablas a la consulta, la columna Notes devolverá como se esperaba.

Access 2007

  1. Inicie Microsoft Access y, a continuación, abra la base de datos de ejemplo Northwind.accdb.
  2. En la ficha crear , haga clic en Diseño de la consulta , en el grupo otros .
  3. En el cuadro de diálogo Mostrar tabla , haga doble clic en los nombres de la tabla siguiente:
    • Empleados
    • Pedidos
    • Detalles del pedido
    • Clientes
  4. Haga clic en Cerrar.
  5. En la tabla empleados, haga doble clic en los nombres de campo siguientes:
    • ID.
    • Notas:
  6. En la ficha Diseño , haga clic en totales en el grupo Mostrar u ocultar .
  7. En la ficha Diseño , haga clic en Ejecutar en el grupo de resultados .
Nota: Si agrega la tabla Shippers a la consulta o volver a organizar el orden en que se agregan las tablas a la consulta, la columna Notes devolverá como se esperaba.