Es posible que reciba un mensaje de error "El sistema no puede encontrar la ruta especificada" al intentar abrir el Administrador de servicios Internet o un complemento MMC en un equipo que ejecuta IIS 5.0


Síntomas


Cuando intenta abrir el Administrador de servicios Internet (ISM) o un complemento Microsoft Management Console (MMC) en un equipo que ejecuta Microsoft Internet Information Services 5.0 (IIS), podría recibir un mensaje de error similar al siguiente:
Error al conectarse a NombreServidor:
el sistema no puede encontrar la ruta especificada.
¿Desea seguir intentando establecer la conexión a este servidor en el futuro?
NotaNombreServidor es el nombre del servidor que ejecuta IIS.

Si hace clic en , el nombre del servidor no aparece en ISM ni en MMC y no puede configurar ningún sitio web. Asimismo, es posible que las extensiones del servidor Microsoft FrontPage y la publicación web no funcionen del modo esperado.

Experimenta estos síntomas aunque todos los sitios web existentes se inicien y funcionen del modo esperado.

Causa


Este problema se produce si la información de configuración en la metabase de IIS no coincide con los servicios que están instalados en el equipo. Este problema se produce cuando se cumplen las condiciones siguientes:
  • El servicio de publicación FTP está instalado en el equipo.
  • La metabase de IIS no contiene información de configuración para el servicio de publicación FTP.

Solución


Para resolver este problema, utilice uno de los métodos siguientes.

Método 1: usar la utilidad Adsutil.vbs para determinar los servicios que están configurados en la metabase

Para usar la utilidad Adsutil.vbs para determinar los servicios que están configurados en la metabase, realice estos pasos:
  1. Haga clic en Inicio y en Ejecutar, escriba Services.msc y haga clic en Aceptar.
  2. En el complemento Servicios, bajo Nombre, compruebe los servicios de IIS instalados en el equipo.
  3. Haga clic en Inicio y en Ejecutar, escriba cmd y, por último, haga clic en Aceptar.
  4. En el símbolo del sistema, escriba el siguiente comando, donde DiscoDuro es el disco duro en el que está instalado IIS:
    cd DiscoDuro\inetpub\adminscripts
  5. Para comprobar que un servicio IIS está configurado en la metabase, escriba el siguiente comando en el símbolo del sistema, donde NombreServicio es el servicio IIS que desea comprobar en la metabase de IIS
    Adsutil.vbs enum NombreServicio
    Por ejemplo, para comprobar que la metabase de IIS contiene información de configuración para el servicio de publicación FTP, escriba Adsutil.vbs enum MSFTPSVC.

    Si recibe un mensaje de error similar al siguiente, es posible que el servicio IIS no esté instalado correctamente:
    No se pudo encontrar la ruta solicitada.
  6. Después de determinar las diferencias de configuración entre la información almacenada en la metabase y los servicios que se ejecutan en el equipo, instale o quite servicios en el equipo. Para ello, siga estos pasos:
    1. Haga clic en Inicio y en Ejecutar, escriba appwiz.cpl y haga clic en Aceptar.
    2. Haga doble clic en Agregar o quitar componentes de Windows.
    3. Haga doble clic en Internet Information Services (IIS).
    4. Haga clic para activar o desactivar las casillas de los servicios que desea configurar y luego haga clic en Siguiente.
    5. Siga las indicaciones que aparecen en pantalla para finalizar el Asistente para componentes de Windows.

Método 2: eliminar la clave del Registro para el servicio de publicación FTP

Para eliminar la clave del Registro para el servicio de publicación FTP, siga estos pasos:

Nota Siga estos pasos solamente si el servicio de publicación FTP está instalado en el equipo y si la metabase de IIS no contiene información de configuración para el servicio de publicación FTP.

Importante En esta sección, método o tarea se incluyen pasos para modificar el Registro. Sin embargo, se pueden producir problemas graves si modifica el Registro incorrectamente. Por tanto, asegúrese de que sigue estos pasos cuidadosamente. Para mayor protección, realice una copia de seguridad del Registro antes de modificarlo. De esta manera podrá restaurar el Registro en caso de que se produzca un problema. Para obtener más información sobre cómo realizar una copia de seguridad y restaurar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 Cómo realizar una copia de seguridad y restaurar el Registro en Windows
  1. Haga clic en Inicio y en Ejecutar, escriba cmd y, por último, haga clic en Aceptar.
  2. Busque la carpeta donde se encuentra el archivo Adsutil.vbs.
  3. Para enumerar la información de configuración del servicio de publicación FTP en la metabase de IIS, escriba el siguiente comando:
    Adsutil.vbs enum MSFTPSVC
    Si la metabase de IIS no contiene información de configuración para el servicio de publicación FTP o si recibe un mensaje de error, vaya al paso 4.
  4. Haga clic en Inicio y en Ejecutar, escriba regedit y haga clic en Aceptar.
  5. Busque y haga clic con el botón derecho en la siguiente clave del Registro:
    HKEY_LOCAL_MACHINE\Software\Microsoft\INetMgr\Parameters\AddOnServices\FTP
  6. En el panel derecho, haga clic con el botón derecho en FTP y luego haga clic en Eliminar.
  7. Cierre el Editor del Registro.

Más información


Para obtener más información sobre Adsutil.vbs, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

240225 Descripción de las utilidades Adsutil y MetaEdit que se usan para modificar la metabase