Un equipo basado en Windows 2000, basado en Windows Server 2003 o con Windows XP que se ha configurado mediante una imagen de Windows 2000, Windows Server 2003 o Windows XP no aparece en la consola de WSUS

Síntomas

Un equipo que ejecuta Windows 2000, Windows Server 2003 o Windows XP no aparecen en la consola de Windows Server Update Services (WSUS).

Este problema se produce si el equipo se ha configurado mediante una imagen de Windows 2000, una imagen de Windows Server 2003 o una imagen de Windows XP en el que el valor del registro para SusClientID se llena antes de que se implemente en los equipos cliente.

Cuando se utiliza Sysprep para generalizar una imagen de una máquina virtual, o cuando se utiliza una única tecnología de generación de SID para crear las imágenes, no se borra el valor de registro SusClientId si se rellena dentro de la imagen antes de implementa la imagen.

Nota: En WSUS 3.0, el cliente cambia su SusClientID si cambia la configuración de hardware. Para Windows Vista, Windows Server 2008 y versiones posteriores, Sysprep se cambia para restablecer la SusClientID. Por lo tanto, este problema afecta a sólo máquinas que ejecutan sistemas operativos de versiones anteriores a Windows Vista o que no se han creado mediante Sysprep.

Causa

Este problema se produce porque los clientes con imagen pueden tener un valor SusClientID duplicado en el registro.

Solución

Para resolver este problema, utilice uno de los métodos siguientes.

Método 1: Cambiar el registro

Importante: esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para una mayor protección, haga una copia de seguridad del registro antes de modificarlo. Entonces, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo hacer copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 cómo hacer copia de seguridad y restaurar el registro en Windows
  1. Haga clic en Inicio, haga clic en Ejecutar, escriba cmd en el cuadro Abrir y, a continuación, haga clic en Aceptar.
  2. En el símbolo del sistema, escriba net stop wuauservy, a continuación, presione ENTRAR.
  3. Haga clic en Inicio, haga clic en Ejecutar, escriba regedit en el cuadro Abrir y, a continuación, haga clic en Aceptar.
  4. Busque y, a continuación, haga clic en la subclave del registro siguiente:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate
  5. En el panel de detalles del Editor del registro, elimine las siguientes entradas del registro:
    • PingID
    • AccountDomainSid
    • SusClientId
    • SusClientIDValidation
    Nota: Agente de Windows Update 3.0 agrega el valor de SusClientIDValidation. Este valor se publicó en mayo de 2007. Las entradas del Registro existen en ambos Windows Update Agent 2.0 y en Windows Update Agent 3.0.
  6. Salga del Editor del Registro.
  7. En el símbolo del sistema, escriba net start wuauservy, a continuación, presione ENTRAR.
  8. En el símbolo del sistema, escriba wuauclt.exe/detectnow de /resetauthorizationy, a continuación, presione ENTRAR.
  9. Espere 10 minutos finalizar un ciclo de detección.
  10. Inicie la consola WSUS para asegurarse de que los clientes aparecen en la consola de WSUS.

Método 2: Utilizar el archivo Sysprep.inf

Si ya tiene un archivo que se denomina Sysprep.inf en la misma carpeta que Sysprep.exe, siga estos pasos.

Nota: Para resolver este problema, deben aplicar estos pasos antes de generalizar la imagen.
  1. Haga doble clic en el archivo Sysprep.inf para abrir el archivo en el Bloc de notas.
  2. Desplácese hasta para encontrar la sección [GuiRunOnce] .

    Nota: Si una sección [GuiRunOnce] no existe, créela escribiendo al final del archivo Sysprep.inf.
  3. Debajo de [GuiRunOnce], escriba el texto siguiente.

    Nota: Estos nuevos comandos se muestran como "Command0" a través de "Command3". Estas designaciones son correctas sólo si la sección [GuiRunOnce] no contiene actualmente ningún comando. Si ya hay comandos debajo de [GuiRunOnce], cambie las entradas de "comandox" en los nuevos comandos para que comience con el siguiente número secuencial. Por ejemplo, si la sección ya contiene cinco comandos que se muestran como "Command0" a través de "Command4", número de estos nuevos comandos como "Command5" por "Command8".
    • Command0="reg.exe eliminar HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v PingID /f"
    • Command1="reg.exe eliminar HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v AccountDomainSid /f"
    • Command2="reg.exe eliminar HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientId /f"
    • Command3="reg.exe eliminar HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientIDValidation /f"
  4. En el menú archivo , haga clic en Guardar.
  5. En el menú archivo, haga clic en Salir.

Método 3: Cree un archivo Sysprep.inf si no tiene el archivo

Si no tiene un archivo que se denomina Sysprep.inf en la misma carpeta que Sysprep.exe, siga estos pasos para crear el archivo.

Nota: Para resolver este problema, deben aplicar estos pasos antes de generalizar la imagen.
  1. Haga clic en Inicio, seleccione Todos los programas, haga clic en Accesoriosy, a continuación, haga clic en Bloc de notas.
  2. Escriba el texto siguiente:
    [GuiRunOnce]

    Command0="reg.exe eliminar HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v PingID /f"

    Command1="reg.exe eliminar HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v AccountDomainSid /f"

    Command2="reg.exe eliminar HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientId /f"

    Command3="reg.exe eliminar HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientIDValidation /f"
  3. En el menú archivo , haga clic en Guardar.
  4. Busque el directorio donde se encuentra el archivo Sysprep.exe.
  5. En el cuadro nombre de archivo , escriba Sysprep.inf .
  6. En el cuadro Guardar como tipo , seleccione Todos los archivos .
  7. Haga clic en Guardar.
  8. En el menú archivo, haga clic en Salir.

Más información

El primer equipo basado en Windows 2000, un equipo basado en Windows Server 2003 o un equipo basado en Windows XP que se configuró utilizando una imagen de Windows 2000, una imagen de Windows Server 2003 o una imagen de Windows XP aparece en la consola de WSUS. Sin embargo, no aparecen los equipos basados en Windows 2000, basado en Windows Server 2003 o con Windows XP a continuación que se configuran utilizando la misma imagen. Este problema se produce porque el primer equipo que se configuró utilizando una de estas imágenes está utilizando el mismo valor de SusClientID.

Después de seguir los pasos que se describen en la sección "Resolución", se crea un nuevo valor de SusClientID. Además, la siguiente equipos basados en Windows 2000, equipos basados en Windows Server 2003 o equipos basados en Windows XP que se configuran utilizando la misma imagen aparecen en la consola de WSUS.



Hemos agregado una característica automática para el agente de Windows Update que se instala en equipos cliente de WSUS. Esta característica puede ayudar a enfrentar este problema SusClientID de duplicado. La característica ofrece una solución que se agrega al agente de cliente Windows Update a partir de la versión 7.0.6000.374. (Esta versión es la versión del cliente que se incluyó con WSUS 3.0).

Esta solución utiliza una rutina de validación de hardware para determinar si el hardware del cliente actual ha cambiado desde que se creó el valor SUSClientID. (Este hardware incluye adaptadores de red y discos duros).

La rutina de validación de hardware se almacena como un objeto binario grande en la clave del registro Susclientidvalidation en la misma ubicación que el valor de registro Susclientid. Si la rutina de validación de hardware indica que ha cambiado todo el hardware, el cliente genera un nuevo valor de SusClientID.

Nota: La rutina de validación de hardware requiere que el cliente se conecte a un servidor que ejecuta Windows Software Update Services 3.0 o una versión posterior de WSUS y no a un servidor que ejecuta Windows Software Update Services 2.0.
Propiedades

Id. de artículo: 903262 - Última revisión: 17 ene. 2017 - Revisión: 1

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