No puede instalar a una impresora que utiliza un procesador de impresión personalizado en Windows Server 2003 o en Windows XP Professional

Síntomas

Cuando intenta utilizar al Asistente para agregar impresora para agregar más impresoras a un equipo que ejecuta Microsoft Windows Server 2003 o Microsoft Windows XP Professional, puede recibir un mensaje de error después de completar el Asistente para agregar impresoras. El mensaje de error que puede recibir es similar al siguiente:

No se ha podido instalar la impresora. El procesador de impresión no existe.
Por lo tanto, no se puede agregar la impresora.

Causa

Este problema se produce porque el controlador de impresión utiliza un procesador de impresión personalizado.

Solución

Información del Service pack

Para resolver este problema, obtenga el service pack más reciente para Windows Server 2003. Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:
889100 cómo obtener el service pack más reciente para Windows Server 2003

Información de la revisión de Windows XP

Esta revisión puede eliminar todos los puertos IP de la impresora en el equipo. Es aconsejable realizar una copia de la configuración del puerto antes de aplicar esta revisión.

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en el elemento de fecha y hora del Panel de Control.
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataformaRequisito de SPTipo de servicio
Updspapi.dll6.2.29.0371,42412-Oct-200523:12x86NingunoNo aplicable
Ntprint.dll5.1.2600.304391,13629-Nov-200615:08x86SP2SP2QFE


Información de hotfix de Windows Server 2003

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener Windows Server 2003 Service Pack 1 o una versión x64 de Windows Server 2003 instalado.

Requisito de reinicio

Debe reiniciar el servidor después de aplicar este hotfix.

Información de reemplazo de revisión

Este hotfix no sustituye a otras revisiones.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en el elemento de fecha y hora del Panel de Control.
Windows Server 2003, versiones basadas en x86
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataformaRequisito de SPTipo de servicio
Localspl.dll5.2.3790.2524348,16007-Sep-200502:30x86SP1SP1QFE
Ntprint.dll5.2.3790.252499.84007-Sep-200502:30x86SP1SP1QFE
Updspapi.dll6.1.22.4371,93605-Mar-200501:30x86NingunoNo aplicable
Windows Server 2003, versiones basadas en x 64
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataformaRequisito de SPTipo de servicio
Localspl.dll5.2.3790.2524749,56807-Sep-200515:24x64SP1SP1QFE
Ntprint.dll5.2.3790.2524158,72007-Sep-200515:24x64SP1SP1QFE
Wntprint.dll5.2.3790.252499.84007-Sep-200515:24x86SP1WOW
Updspapi.dll6.1.22.4462.56007-Sep-200515:24x64NingunoNo aplicable
Windows Server 2003, versiones basadas en Itanium
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataformaRequisito de SPTipo de servicio
Localspl.dll5.2.3790.2524968,19207-Sep-200515:23IA-64SP1SP1QFE
Ntprint.dll5.2.3790.2524275,45607-Sep-200515:23IA-64SP1SP1QFE
Wntprint.dll5.2.3790.252499.84007-Sep-200515:23x86SP1WOW
Updspapi.dll6.1.22.4639,71207-Sep-200515:23IA-64NingunoNo aplicable

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a". Este problema se corrigió primero en Windows Server 2003 Service Pack 2.

Más información

Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:
824684 Descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Soporte técnico para las versiones basadas en x 64 de Microsoft Windows

Si su hardware venía con una edición de Microsoft Windows x64 ya instalada, su fabricante de hardware proporciona soporte técnico y asistencia para la edición de Windows x64. En este caso, el fabricante del hardware proporciona soporte técnico porque un Windows x64 edition se incluyó con su hardware. Su fabricante de hardware podría haber personalizado la instalación de Windows x64 edition con componentes exclusivos. Componentes exclusivos podrían incluir controladores de dispositivo específicos o configuraciones opcionales para maximizar el rendimiento del hardware. Si necesita ayuda técnica para una edición de Windows x64, Microsoft ofrecerá asistencia de esfuerzo razonable. Sin embargo, tendrá que ponerse en contacto directamente con el fabricante. El fabricante es el mejor cualificado para admitir el software que instaló el fabricante del hardware. Si ha adquirido una edición de Windows x64, como Microsoft Windows Server 2003 x64 por separado, póngase en contacto con Microsoft para obtener soporte técnico.

Para obtener información sobre x64 de Microsoft Windows XP Professional Edition, visite el siguiente sitio Web de Microsoft:Para obtener información acerca de las versiones basadas en x64 de Microsoft Windows Server 2003, visite el siguiente sitio Web de Microsoft:
Propiedades

Id. de artículo: 906752 - Última revisión: 17 ene. 2017 - Revisión: 1

Comentarios