Mensaje de error cuando intenta instalar un control ActiveX o intentar completar el proceso de validación de WGA en Windows XP con Service Pack 2: "8024402C"

Importante: Este artículo contiene información acerca de cómo modificar el registro. Asegúrese de hacer copia de seguridad del registro antes de modificarlo. Asegúrese de que sabe cómo restaurarlo si ocurre algún problema. Para obtener más información acerca de cómo hacer copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

Síntomas

Después de actualizar un equipo a Microsoft Windows XP con Service Pack 2 (SP2), intenta instalar un control ActiveX. O bien, complete el proceso de validación de Microsoft Windows original (WGA). Sin embargo, recibirá el siguiente mensaje de error:
8024402c

Causa

Este problema se produce porque el cliente de servicio de transferencia inteligente en segundo plano (BITS) 2.0 envía credenciales implícitas al servidor proxy. Esto hace que el servidor proxy devolver un código de estado aleatorio. Por lo tanto, el equipo cliente no puede descargar actualizaciones desde el sitio Web Microsoft Windows Update.

Solución

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener instalado Windows XP Service Pack 2.

Requisito de reinicio

No es necesario que reinicie el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Este hotfix no sustituye a otras revisiones.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Qmgr.dll6.6.2600.2848381,95216-Feb-200605:29x86

Información de instalación de hotfix

Después de aplicar este hotfix, debe eliminar la carpeta softwaredistribution para habilitar la revisión. Para eliminar la carpeta softwaredistribution, escriba los comandos siguientes en un símbolo del sistema. Presione ENTRAR después de cada comando.
  • %windir%\system32\net.exe stop wuauserv
  • CD /d % windir %
  • RD /s softwaredistribution
  • CD system32
  • regsvr32 wuapi.dll
  • regsvr32 wuaueng1.dll
  • regsvr32 wuaueng.dll
  • regsvr32 wucltui.dll
  • regsvr32 wups.dll
  • NET.exe start wuauserv

Solución alternativa

Advertencia: pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o mediante cualquier otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar que estos problemas puedan resolverse. Modifique el registro bajo su propio riesgo.

Para evitar este problema, cambie el valor de la entrada del registro lmcompatibilitylevel en 0 o en 1. Para ello, siga estos pasos:

Nota: El valor predeterminado de esta entrada del registro es 2 o un valor mayor.
  1. Haga clic en Inicio, haga clic en Ejecutar, escriba Regedity, a continuación, haga clic en Aceptar.
  2. Busque y, a continuación, haga clic en la subclave del registro siguiente:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
  3. En el panel de detalles, haga doble clic en la entrada de registro lmcompatibilitylevel.
  4. En el cuadro información del valor , escriba 1 o 0, dependiendo de su entorno. A continuación, haga clic en Aceptar.
  5. Salga del Editor del registro y, a continuación, reinicie el equipo.
Para obtener más información acerca de la configuración de opción de seguridad de LMCompatibility, vea la tabla 4.6 en el siguiente sitio Web de Microsoft:

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Para obtener más información acerca de los términos que se utilizan para describir las actualizaciones de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft
Propiedades

Id. de artículo: 913460 - Última revisión: 17 ene. 2017 - Revisión: 1

Comentarios