Mensaje de error cuando intenta ponerse sin conexión en el cliente para equipo portátil de Microsoft Dynamics CRM para Outlook: "no se pudieron mover datos de entidad [EntityName] durante la acción saInsert, countRows = [resultadoCuenta]. Para obtener ayuda, póngase en contacto con el administrador del sistema"

Síntomas

Cuando intenta ponerse sin conexión en el cliente para equipo portátil de Microsoft Dynamics CRM para Microsoft Office Outlook, puede recibir el siguiente mensaje de error:
No se pudo mover datos de entidad EntityName durante la acción saInsert, countRows =resultadoCuenta. Para obtener ayuda, póngase en contacto con el administrador del sistema.
Nota: En este mensaje, EntityName es un marcador de posición para el nombre de una entidad real y resultadoCuenta es un marcador de posición para el número real de filas.

Un mensaje de error similar al siguiente mensaje de error se registra en el registro de sucesos:

Tipo de suceso: Error

Origen del evento: MSCRMOfflineSync

Categoría del suceso: ninguna

Id. de suceso: 6000

Descripción: Se ha producido un error durante la sincronización sin conexión. Intente ponerse sin conexión de nuevo o reinicie Microsoft Outlook. GetBCPFile() falló durante una acción Insert para la entidad < Case >, batchRows = 0 con la excepción System.Net.WebException: el servidor remoto devolvió un error: (401) no autorizado. ---> System.ComponentModel.Win32Exception: error en el intento de inicio de sesión en System.Net.NTAuthentication.GetOutgoingBlob (Byte [] incomingBlob, Boolean & handshakeComplete) en System.Net.NTAuthentication.GetOutgoingBlob (String incomingBlob, Boolean & handshakeComplete) en System.Net.NegotiateClient.DoAuthenticate (String challenge, WebRequest webRequest, ICredentials credenciales, Boolean preAuthenticate) en System.Net.NegotiateClient.DoAuthenticate (String challenge, WebRequest webRequest, ICredentials credenciales, Boolean preAuthenticate) en System.Net.NegotiateClient.Authenticate (desafío de cadena, WebRequest webRequest, ICredentials credenciales) en System.Net.AuthenticationManager.Authenticate (desafío de cadena, solicitud de WebRequest, ICredentials credenciales) en System.Net.AuthenticationState.AttemptAuthenticate (HttpWebRequest httpWebRequest, ICredentials authInfo)---fin del seguimiento de pila de excepción interna---en System.Net.HttpWebRequest.CheckFinalStatus() en System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) en System.Net.HttpWebRequest.GetResponse() en Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.GetBCPFile (String entityName, acción acción, Int32 batchSize).


Para obtener más información, consulte Centro de ayuda y soporte técnico en http://support.microsoft.com.
Un mensaje de advertencia similar al siguiente mensaje se registra en el registro de sucesos:
Tipo de suceso: advertencia

Origen del evento: MSCRMOfflineSync

Categoría del suceso: ninguna

Id. de suceso: 6001

Descripción: Se devolvió un resultado inesperado durante la sincronización sin conexión. recuento de #temp < baseEntidad > inserta 54! = 27 inserciones de recuento solicitado.


Para obtener más información, consulte Centro de ayuda y soporte técnico en http://support.microsoft.com.
Nota: En este mensaje, baseEntidad es un marcador de posición para un nombre de tabla real para la entidad.

Causa

Este problema se produce porque uno o más de las siguientes condiciones son verdaderas:
  • El Cliente para equipo portátil de Microsoft CRM para Outlook no tiene los permisos de acceso a la carpeta BCP.
  • La versión de Microsoft XML (MSXML) en el Cliente para equipo portátil de Microsoft CRM para Outlook es incorrecta.
  • Los filtros de datos sin conexión en el Cliente para equipo portátil de Microsoft CRM para Outlook son incorrectos.
  • La instalación de Microsoft CRM server está dañada.
  • La cuenta de usuario que se ejecuta el grupo de aplicaciones en el sitio Web de Microsoft CRM no puede tener acceso a la carpeta de datos sin conexión en el servidor de Microsoft CRM.
  • Las bases de datos de Microsoft SQL Server se mueven a un nuevo servidor. El origen de datos de Microsoft CRM sistema DSN de ODBC en el servidor de Microsoft CRM continúa señalando al servidor anterior que está ejecutando SQL Server.
  • El equipo que está ejecutando SQL Server y que contiene las bases de datos MSCRM está enviando más registros de lo habitual en la base de datos sin conexión.
  • Se ha agregado el modificador/3 GB al archivo Boot.ini en el servidor de Microsoft CRM. Este problema hace que el servidor se quede sin memoria cuando intenta realizar el proceso BCP.
  • No está instalado Microsoft Data Access Components (MDAC) 2.8 Service Pack 1 (SP1).

Solución

Para resolver este problema, utilice uno o varios de los métodos siguientes.

Método 1

Conceder permisos para la carpeta BCP para el Cliente para equipo portátil de Microsoft CRM para Outlook del usuario. Para ello, siga estos pasos:
  1. Inicie sesión en el Cliente para equipo portátil de Microsoft CRM para Outlook del equipo y, a continuación, busque la carpeta BCP. Normalmente, la carpeta BCP está ubicada en la ruta de acceso siguiente en el equipo cliente:
    C:\Documents and Settings\UserName\Application Data\Microsoft\MSCRM\BCP
    Notas:
    • En un equipo basado en Windows Vista, la carpeta BCP está ubicada en la ruta de acceso siguiente:
      C:\Users\UserName\AppData\Roaming\Microsoft\MSCRM\BCP
    • En este paso, el nombre de usuario es un marcador de posición para el nombre de usuario real.
  2. Busque y, a continuación, haga clic en la carpeta. A continuación, haga clic en Propiedades.
  3. Haga clic en la pestaña Seguridad .
  4. En la lista nombres de grupos o usuarios , seleccione al Cliente para equipo portátil de Microsoft CRM para Outlook del usuario.
  5. En la lista de permisos para el nombre de usuario , asegúrese de que está activada la casilla de verificación Permitir de la fila de Control total . Haga clic en Aceptar.

    Nota: En este paso, el nombre de usuario es un marcador de posición para el nombre de usuario real.

Método 2

Asegúrese de que la versión del archivo Msxml4.dll es al menos 4.20.9828 en el equipo cliente. Para ello, siga estos pasos:
  1. Busque la carpeta system32. Normalmente, esta carpeta se encuentra en la ruta de acceso siguiente:

    C:\WINDOWS\system32\
  2. Busque y haga clic en el archivo Msxml4.dll y, a continuación, haga clic en Propiedades. Haga clic en la ficha versión .
  3. Compruebe si el valor de versión del archivo es al menos 4.20.9828. Si el valor es anterior a esta versión, vaya al paso 4.
  4. Si la versión del archivo Msxml4.dll es anterior a 4.20.9828, el archivo debe actualizarse. Para obtener más información acerca de cómo obtener un archivo actualizado, visite el siguiente sitio Web de Microsoft:Notas:
    • También se puede obtener el archivo Msxml4.dll desde el CD de instalación de cliente. Normalmente, se encuentra el archivo Msxml4sp2-kb887606-x86-enu.exe en la ruta de acceso siguiente:

      \Client\MSXML\KB887606\
    • Esta revisión no requiere que reinicie el equipo.

Método 3

Quitar todos los filtros de datos sin conexión y agregar y sincronizar esos filtros uno por uno en el equipo cliente. Para quitar los filtros de datos sin conexión, siga estos pasos:

  1. En la del Cliente para equipo portátil de Microsoft CRM para Outlook, haga clic en Datos locales en el menú CRM .
  2. En el cuadro de diálogo Datos locales , resalte todos los filtros, haga clic en desactivary, a continuación, haga clic en Aceptar.
Para agregar y sincronizar estos filtros, siga estos pasos:
  1. En el menú CRM , haga clic en Datos locales.
  2. Haga clic en la ficha Grupos de datos inactivos .
  3. Seleccione uno de los filtros. A continuación, haga clic en Activar.
  4. Haga clic en Aceptar.
  5. Haga clic en Trabajar sin conexión para iniciar el proceso de sincronización. A continuación, haga clic en Iniciar sesión para completar el proceso de sincronización.
  6. Repita los pasos 3 a 5 por cada filtro desactivado.
  7. Si puede identificar un filtro específico que está causando el problema, asegúrese de que este filtro no utiliza el "primario descargados = True" instrucción. No recomendamos utilizar esta instrucion.

Método 4

Ejecutar el proceso de reparación en el servidor de Microsoft CRM. Para ello, siga estos pasos:
  1. Inicie sesión en el servidor de Microsoft CRM. Haga clic en Inicio, haga clic en Panel de Controly, a continuación, haga clic en Agregar o quitar programas.
  2. Haga clic en servidor de Microsoft CRM. A continuación, haga clic en Cambiar o quitar.
  3. Haga clic en la opción de reparación . A continuación, haga clic en siguiente para iniciar al Asistente de instalación de Microsoft CRM 3.0 Server.

Método 5

Asegúrese de que la cuenta de usuario que se ejecuta el grupo de aplicaciones en el sitio Web de Microsoft CRM puede tener acceso a la carpeta OfflineData. Esta carpeta almacena los archivos de datos BCP (Bulk Copy Process) que el cliente obtiene del servidor que está ejecutando SQL Server. Para asegurarse de que puede tener acceso a la carpeta OfflineData, siga estos pasos:
  1. Determine la cuenta que ejecuta el grupo de aplicaciones. Para ello, siga estos pasos:
    1. Inicie sesión en el servidor de Microsoft CRM.
    2. Haga clic en Inicio, haga clic en Herramientas administrativas y, a continuación, haga clic en Administrador de servicios de Internet Information Server (IIS).
    3. Expanda el nombre del equipo local, expanda Grupos de aplicaciones, haga CRMAppPooly, a continuación, haga clic en Propiedades.
    4. Haga clic en la ficha identidad .
    5. Compruebe los permisos de acuerdo con las directrices siguientes:

      Si está activada la opción predefinida , las cuentas de la NetworkService y LocalSystem están representadas por la DomainName\nombreEquipo$ cuenta. Por lo tanto, cuando debe verificar los permisos para la cuenta NetworkService o la cuenta LocalSystem, también debe comprobar los permisos para el DomainName\nombreEquipo$ cuenta.

      Si está seleccionada la opción Configurable , debe comprobar los permisos para la cuenta de usuario especificada.

      Nota: Si está activada la opción predefinida, utilice la cuenta configurable como el usuario en el paso 5. Si está seleccionada la opción Configurable, use la cuenta de usuario especificada como el usuario en el paso 5.
  2. En el servidor de Microsoft CRM, busque la carpeta siguiente:

    Drive:\Program Files\Microsoft CRM\Server\OfflineData\

    Nota: En este paso, la unidad es un marcador de posición para la unidad real en el que instaló Microsoft CRM.
  3. Haga clic en la carpeta. A continuación, haga clic en Propiedades.
  4. Haga clic en la pestaña Seguridad .
  5. En la lista nombres de grupos o usuarios , seleccione el usuario que identificó en el paso 1.
  6. En la lista de permisos para el nombre de usuario , asegúrese de que está activada la casilla de verificación Permitir de la fila de Control total . Haga clic en Aceptar.

    Nota: En este paso, el nombre de usuario es un marcador de posición para el nombre de usuario real.

Método 6

Nota: Método 6 sólo es válido para Microsoft Dynamics CRM 3.0. Este método no es válido para Microsoft Dynamics CRM 4.0.

Modificar el Microsoft CRM sistema DSN de origen de datos ODBC en el servidor de Microsoft CRM para que apunte al nuevo servidor que está ejecutando SQL Server. Para ello, siga estos pasos:
  1. Haga clic en Inicio, elija
    Herramientas administrativasy, a continuación, haga clic en Orígenes de datos (ODBC).
  2. En el cuadro de diálogo Administrador de orígenes de datos ODBC, haga clic en la ficha DSN de sistema , haga clic en la lista De Microsoft CRM en los orígenes de datos del sistema y, a continuación, haga clic en
    Configurar.
  3. En la primera ventana de configuración de DSN de Microsoft SQL Server, busque la lista de servidores que contiene los nombres de los equipos que ejecutan SQL Server. Haga clic en el servidor que desea conectar.
  4. Haga clic en siguiente tres veces para configurar el origen de datos.
  5. Haga clic en Finalizar.
  6. En la ventana Configuración de ODBC Microsoft SQL Server, haga clic en
    Origen de datos de prueba para validar la conexión con el servidor.
  7. Haga clic en Aceptar dos veces para completar la configuración.
  8. Haga clic en Aceptar para cerrar el cuadro de diálogo Administrador de orígenes de datos ODBC .

Método 7

  1. Salga de Microsoft Dynamics CRM 3.0.
  2. Haga clic en Inicio, haga clic en Ejecutar, escriba regedit y, a continuación, haga clic en Aceptar.
  3. Busque y, a continuación, haga clic en la subclave del registro siguiente:
    HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient
  4. Haga clic en el valor DWORD OfflineRowsBatchSize y, a continuación, haga clic en Modificar.
  5. En el cuadro información del valor , escriba un valor que es menor que el valor actual, como 10 ó 1. A continuación, haga clic en Aceptar.

    Nota: De forma predeterminada, se establece el valor DWORD OfflineRowsBatchSize a 100000.
  6. Salga del Editor del Registro.

Método 8

Quite el modificador/3 GB del archivo Boot.ini en el servidor de Microsoft CRM. Para que el cambio surta efecto, debe reiniciar el equipo después de quitar el conmutador.

Método 9

Instale MDAC 2.8 Service Pack 1. Para instalar el Service Pack 1 de MDAC 2.8, visite el siguiente sitio Web de Microsoft:

Método 10

Si se aplicaron las actualizaciones recientes para el sistema operativo Windows para el servidor de Microsoft Dynamics CRM o en el servidor que está ejecutando SQL Server, reinicie el servidor afectado.

Más información

Si sigue experimentando el problema que se describe en la sección "Síntomas", haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
918108 mensaje de error cuando intenta ponerse sin conexión en un equipo para cliente portátil que esté ejecutando Microsoft Dynamics CRM 3.0: "No se pudieron mover datos para la entidad"

Referencias

Para obtener más información acerca de cómo mover bases de datos de SQL de Microsoft Dynamics CRM 3.0 de un servidor a otro servidor, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

917948 cómo mover bases de datos de SQL de Microsoft Dynamics CRM 3.0 de un servidor a otro servidor que esté en el mismo dominio

Propiedades

Id. de artículo: 916165 - Última revisión: 14 ene. 2017 - Revisión: 2

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