El equipo puede reiniciarse cuando se agrega un manifiesto que tiene la extensión de Windows Vista a un archivo .exe o a un archivo .dll en Windows XP Service Pack 2 (SP2) o en WEPOS

Síntomas

Cuando se agrega un manifiesto que tiene la extensión de Microsoft Windows Vista a un archivo .exe o a un archivo .dll, el equipo puede reiniciarse. Este problema se produce en Windows XP Service Pack 2 (SP2)-basado en equipo y en un Windows Embedded para dispositivo Point of Service (WEPOS). Además, este problema se produce cuando se ejecuta el archivo .exe o cuando se carga el archivo .dll. El siguiente es un ejemplo de un segmento de manifiesto que tiene la extensión de Microsoft Windows Vista.
//The section between >>>>> and <<<< is the problematic section. 
<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0">
<assemblyIdentity version="1.0.0.0" processorArchitecture="X86" name="Synergex.Synergyde.lm" type="win32">
</assemblyIdentity>
<dependency>
<dependentAssembly>
<assemblyIdentity
type="win32" name="Microsoft.VC80.CRT" version="8.0.50608.0" processorArchitecture="x86" publicKeyToken="1fc8b3b9a1e18e3b">
</assemblyIdentity>
</dependentAssembly>
</dependency>

>>>>>>>>>>>

<ms_asmv3:trustInfo xmlns:ms_asmv3="urn:schemas-microsoft-com:asm.v3" xmlns="urn:schemas-microsoft-com:asm.v3">
<ms_asmv3:security xmlns:ms_asmv3="urn:schemas-microsoft-com:asm.v3">
<requestedPrivileges>
<requestedExecutionLevel level="requireAdministrator" uiAccess="false">
</requestedExecutionLevel>
</requestedPrivileges>
</ms_asmv3:security>
</ms_asmv3:trustInfo>

<<<<<<<<<<<

</assembly>

Causa

Este problema se produce cuando Csrss.exe está cargando un archivo .exe o un archivo .dll que contiene un manifiesto que tiene extensiones de Windows Vista. Al analizar el manifiesto incrustado, su memoria interna puede dañarse si se encuentra una sola etiqueta que tiene dos propiedades de esquema. Aquí está la etiqueta en el ejemplo anterior de este artículo, que tiene dos propiedades de esquema:
<ms_asmv3:trustInfo xmlns:ms_asmv3="urn:schemas-microsoft-com:asm.v3" xmlns="urn:schemas-microsoft-com:asm.v3">
Cuando Csrss.exe encuentra dicha etiqueta, los daños en la memoria produce una infracción de acceso en Csrss.exe. Esto hace que se reinicie Windows. Los usuarios finales pueden resolver esto mediante la obtención de la revisión que se menciona en este artículo. Los desarrolladores de software pueden evitar este problema asegurándose de que existe sólo un único esquema para todas las propiedades en un manifiesto. Para este ejemplo, la siguiente etiqueta podría evitar este problema.
<ms_asmv3:trustInfo xmlns:ms_asmv3="urn:schemas-microsoft-com:asm.v3">
Manifiestos que se crean mediante Visual Studio 2005 pueden presentar este comportamiento. Este problema se resolverá con un archivo actualizado de Mt.exe en Visual Studio 2005 Service Pack 1.

Solución

Información de la revisión

Está disponible en Microsoft una característica compatible que modifica el comportamiento predeterminado del producto. Sin embargo, esta característica está diseñada para modificar sólo el comportamiento que se describe en este artículo. Aplíquela sólo a sistemas que la requieran. Esta característica podría ser sometida a comprobaciones adicionales. Por lo tanto, si el sistema no se ve muy afectado por la falta de esta característica, le recomendamos que espere a la próxima actualización de software que contiene esta función.

Si la característica está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la característica.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califica para esta característica específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de revisión disponible" muestra los idiomas para los que la característica está disponible. Si no ve su idioma, es porque la característica no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener Windows XP Service Pack 2 o WEPOS instalado en el equipo.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Este hotfix no sustituye a otras revisiones.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Sxs.dll5.1.2600.2932713,21616-Jun-200623:45x86

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 921337 - Última revisión: 14 ene. 2017 - Revisión: 1

Comentarios