No se devuelven resultados al buscar elementos de correo electrónico después de habilitar la búsqueda instantánea de Outlook

Síntomas

Después de habilitar la característica Búsqueda instantánea en Microsoft Office Outlook, Windows Desktop Search no devuelve ningún resultado al buscar elementos de correo electrónico.

Causa

Este problema se produce si la herramienta de Administrador del sistema de Exchange está instalada en un equipo que también está ejecutando Outlook.

Para admitir el Administrador del sistema de Exchange, el programa de instalación de las herramientas de administración del sistema de Exchange copia los archivos DLL de MAPI en la carpeta %WINDIR%\system32. Se trata de la misma ubicación donde se encuentra el archivo SearchProtocolHost.exe del proveedor de búsqueda. En esta situación, cuando MAPI intenta cargar archivos DLL de proveedor, MAPI utiliza los archivos DLL relacionados con Exchange de Microsoft. Los archivos DLL relacionados con Exchange no tienen todas las características que son necesarios para indizar los mensajes de correo electrónico. Por lo tanto, Windows Desktop Search ya no busca mensajes de correo electrónico.

Solución

Para resolver este problema, utilice la herramienta Fixmapi.exe para cambiar el orden de búsqueda DLL de proveedor.

Nota: Si vuelve a instalar las herramientas de administración del sistema de Exchange después de instalar Outlook, debe volver a ejecutar la herramienta Fixmapi.exe. Para ejecutar la herramienta Fixmapi.exe, siga estos pasos:
  1. Haga clic en Inicio, haga clic en Ejecutar, escriba %windir%\system32\fixmapi.exey, a continuación, haga clic en Aceptar.
  2. Reinicie el equipo.
  3. Volver a generar catálogo del índice del equipo. Para ello, siga estos pasos:
    1. En el Panel de Control, haga doble clic en Opciones de indización.
    2. En el cuadro de diálogo Opciones de indización, haga clic en Opciones avanzadas.
    3. Haga clic en la ficha Configuración del índice y, a continuación, haga clic en reconstruir.
    4. Haga clic en Aceptar cuando se le pida volver a generar las ubicaciones indizadas en el equipo.
    5. Haga clic en Cerrar para cerrar el cuadro de diálogo Opciones de indización .

Solución alternativa

Para evitar este problema, quite las herramientas de administración del sistema de Exchange. A continuación, volver a generar catálogo del índice del equipo.
Propiedades

Id. de artículo: 927676 - Última revisión: 14 ene. 2017 - Revisión: 1

Comentarios