Después de instalar SMS 2003 SP3, el proceso Wmiprvse.exe puede generar elevado uso de CPU en los equipos cliente durante las operaciones de inventario de hardware

Síntomas

Imagine el siguiente escenario:
  • Instalar Microsoft Systems Management Server 2003 Service Pack 3 (SP3).
  • Asesor de activos de SMS 2003 SP3 realiza operaciones de inventario de hardware.
En este escenario, el proceso Wmiprvse.exe en equipos cliente de la organización puede generar el uso intensivo de la CPU. A veces, el uso de CPU puede llegue al 100%.

Causa

Este problema puede producirse si se cumplen las condiciones siguientes:
  • Un archivo que aparece en una de las ubicaciones de inicio en el equipo cliente contiene varios idiomas distintos del inglés. Por ejemplo, un archivo de programa que incluye idiomas mixtos se muestra en la siguiente ubicación de inicio en el equipo cliente:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
  • La configuración regional del usuario actual en el equipo cliente no coincide con ninguno de los idiomas que se utilizan en el archivo desde la ubicación de inicio (el archivo que se describe en el punto anterior).
  • La clase SMS_AutoStartSoftware está habilitada en el archivo Sms_def.mof.

    Nota: Para obtener más información acerca de cómo determinar si está habilitada esta clase, vea la sección "Solución".
La clase SMS_AutoStartSoftware no controla correctamente estas condiciones. En este escenario, la clase SMS_AutoStartSoftware entra en un bucle. Por lo tanto, la operación de inventario genera el elevado uso de CPU en el equipo cliente.

Nota: La clase SMS_AutoStartSoftware se incluye con SMS 2003 SP3.

Las tres clases siguientes también pueden ocasionar este problema cuando procesan un archivo que incluye varios idiomas distintos del inglés, y cuando la configuración regional del usuario actual no coincide con ninguno de los idiomas en el archivo:
  • SMS_BrowserHelperObject
  • SMS_InstalledSoftware
  • SMS_SoftwareShortcut

Solución

El siguiente archivo está disponible para su descarga desde el Centro de descarga de Microsoft:

Download Descargue ahora el paquete 937882.

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119591 cómo obtener archivos de soporte técnico de Microsoft desde los servicios en línea
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Instrucciones de instalación

Esta revisión sólo debe instalarse en los equipos cliente SMS afectados. Los servidores o los servidores que alojan una función de SMS, como un punto de localizador de servidor (SLP), un punto de acceso de cliente (CAP) o un punto de administración (MP), que no requieren esta revisión del sitio de SMS.

Para simplificar la distribución de esta revisión, el programa de instalación crea automáticamente un paquete y un programa que contiene el archivo SMS2003AC-SP3-KB937882-x86.msp. El archivo SMS2003-SP3-KB937882-X86-ENU.exe sólo crea el paquete y el programa. Antes de poder instalar correctamente el paquete de revisiones en clientes avanzados de SMS, debe crear un anuncio y el destino todos los clientes SMS 2003 SP3 avanzadas para su distribución. Para ello, siga estos pasos:
  1. Haga doble clic en el archivo SMS2003-SP3-KB937882-X86-ENU.exe y, a continuación, siga las instrucciones para crear el paquete y el programa.
  2. Haga clic en Inicio, seleccione Todos los programas, haga clic en Systems Management Servery, a continuación, haga clic en SMS Administrator Console.
  3. En la consola Administrador de SMS, expanda paquetes, haga KB937882 - Advanced Client Hotfix - 1C 1, seleccione Todas las tareasy, a continuación, haga clic en Distribuir Software.
  4. Siga las instrucciones en Distribute Software Wizard para anunciar e implementar el paquete de revisiones.

    Para obtener más información acerca de los métodos que puede utilizar para instalar este paquete de hotfix, consulte el cuadro de diálogo titulado aplicar revisiones a clientes avanzados de SMS en el Asistente para distribuir Software.
Nota: No es necesario realizar un sitio SMS restablecerá después de instalar este hotfix.

Si desea instalar manualmente la revisión en un equipo cliente de SMS, puede instalar el archivo SMS2003AC-SP3-KB937882-x86.msp desde la línea de comandos en el equipo cliente SMS, como sigue:

msiexec.exe /P SMS2003AC-KB891073-X86.msp /L*v %temp%\SMS2003AC-KB891073-X86.log /q REINSTALL=ALL REINSTALLMODE=mous

Nota:
El marcador de posición de % temp %es la ubicación del archivo de registro de instalación y el marcador de posición de SMS2003AC-KB891073-X86.log es el nombre del archivo de registro de instalación.

Esta revisión sólo se aplica a entornos que usan la versión de SMS 2003 SP3 en inglés de Estados Unidos. Esta revisión se incluye en SMS 2003 International cliente Pack 1 (ICP1) y en SMS 2003 International cliente Pack 2 (ICP2) en la versión internacional de SMS 2003 SP3.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

También puede experimentar este problema después de implementar la versión actualizada del archivo AssetAdvisor.dll que se incluye en esta revisión. Por ejemplo, considere el siguiente escenario:
  1. Implementar la versión actualizada del archivo AssetAdvisor.dll a los equipos cliente mediante SMS 2003. Por lo tanto, estos equipos cliente ya no experimentan el problema que se describe en la sección "Síntomas".
  2. Se une a un nuevo equipo cliente al dominio.
  3. El equipo cliente recibe la instalación de inserción de agente de cliente SMS.
En este escenario, el equipo cliente puede iniciar la operación de inventario de hardware antes de que el equipo cliente recibe el archivo AssetAdvisor.dll actualizado.

Nota: Por lo general, el inventario de hardware se inicia en aproximadamente 10 minutos de la instalación de cliente SMS. Sin embargo, se podría tardar aproximadamente un día para el equipo cliente recibir el archivo AssetAdvisor.dll actualizado de SMS 2003. Por ejemplo, podría tardar aproximadamente un día para el proceso de actualización de la colección, para la actualización de directiva de cliente y finalizar la operación de anuncio de ejecución.

Por lo tanto, si el equipo cliente contiene el software afectado, el equipo cliente puede experimentar el problema que se describe en la sección "Síntomas".

Más información

Información de archivo de registro

Cuando se produce este problema, se genera la siguiente información de archivo de registro durante la operación de recopilación de inventario de hardware:
<date and time> 1520 (0x05F0) Collection: Namespace = \\.\root\cimv2\sms; Query = SELECT __CLASS, __PATH, __RELPATH, BinFileVersion, BinProductVersion, 
Description, FileName, FilePropertiesHash, FilePropertiesHashEx, FileVersion,
Location, Product, ProductVersion, Publisher, StartupType, StartupValue FROM
SMS_AutoStartSoftware; Timeout = 600 secs. InventoryAgent
<date and time> 1520 (0x05F0) Unknown error encountered processing an instance
of class SMS_AutoStartSoftware: 800706BE InventoryAgent

Successfully Completed Inventory for SMS_InstalledSoftwareAssetAdvisor<date and time>2636 (0x0A4C)
Start Inventory for SMS_AutoStartSoftwareAssetAdvisor<date and time>2716 (0x0A9C)
Trying to collect data from CAA_Autostartsoftware classAssetAdvisor<date and time>2716 (0x0A9C)
Collecting AutostartSoftwares from HKEY_CURRENT_USERAssetAdvisor<date and time>2716 (0x0A9C)
Collecting AutostartSoftwares from HKEY_LOCAL_MACHINEAssetAdvisor<date and time>2716 (0x0A9C)
Start Inventory for SMS_SystemConsoleUserAssetAdvisor<date and time>2820 (0x0B04)
Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft



Cuando instala esta actualización, puede anotarse un mensaje de error similar al siguiente aparece en el archivo Execmgr.log:

Solicitud de estado de ejecución o informe se encuentra para el programa instalar SMS Advanced cliente SP3 Hotfix KB937882 paquete $PackageID$ execmgr 8/14/2007 1:36:23 P.M. 4024 (0x0FB8) servicio detenido mientras ejecuta el programa instalar SMS Advanced cliente SP3 Hotfix KB937882 execmgr 8/14/2007 1:36:23 PM error de OpenProcess 4024 (0x0FB8) para el proceso 2700, error 80070057 execmgr 8/14/2007 1:31:27 P.M. 1292 (0x050C) no se puede seguir supervisando el programa después de reinicio de servicio porque el proceso ha terminado. Suponga execmgr error 8/14/2007 1:31:27 P.M. 1292 (0x050C)
Puede ignorar este mensaje de error. El proceso de archivo de Execmgr.log crea un nuevo proceso de revisión y supervisa el estado del proceso de revisión secundaria. Sin embargo, el proceso de revisión secundario debe detener el proceso primario para instalar los archivos que se incluyen en la actualización. Una vez finalizado el proceso de revisión secundario, el proceso del archivo Execmgr.log se inicia de nuevo. El proceso del archivo Execmgr.log intenta reanudar el proceso primario original que inició el proceso de revisión. Sin embargo, este proceso primario ya ha finalizado. El proceso del archivo Execmgr.log devuelve el error porque no puede reanudar este proceso primario.
Propiedades

Id. de artículo: 937882 - Última revisión: 14 ene. 2017 - Revisión: 1

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