Cuando intenta validar una copia de Windows XP, recibe el siguiente mensaje de error: "0x80080201 no puede detectar el identificador de producto (PID)"

Se aplica a: Microsoft Windows XP ProfessionalMicrosoft Windows XP Home EditionMicrosoft Windows Genuine Advantage

Síntomas


Cuando intenta validar una copia de Microsoft Windows XP, recibirá el siguiente mensaje de error del programa de ventajas de Windows original (WGA):
0x80080201 no puede detectar el identificador de producto (PID)

Causa


Este problema se produce porque Windows XP está en un estado que impide que WGA accedan el identificador (PID) del producto. Este estado puede producirse por cualquiera de las siguientes razones:
  • El archivo %windir%\System32\Wpa.dbl falta o está dañado.
  • La configuración de seguridad o los valores de atributo para el archivo %windir%\System32\Wpa.dbl son incorrectos.
  • Algunas herramientas descargables han movido o modificado el identificador de producto.
  • El valor de ID de producto en el registro falta o está dañado.
  • Uno o más de los siguientes archivos pueden ser una versión incorrecta, o pueden ser no registrados:
    • Licdll.dll
    • Licwmi.dll
    • Legitcheckcontrol.dll

Solución


Para resolver este problema, siga estos pasos.

Paso 1: Compruebe que haya errores en la comprobación de validación

  1. Haga clic en Inicio, haga clic en Ejecutar, escriba oobe/msoobe /ay, a continuación, haga clic en Aceptar.

    Nota: Hay un espacio entre msoobe /a.
  2. Aparecerá el cuadro de diálogo Activar Windows . Siga las instrucciones que aparecen en pantalla para activar Windows XP. Si sigue recibiendo un mensaje de error, vaya al paso 2.

Paso 2: Descargar y, a continuación, registrar la versión más reciente del archivo Legitcheckcontrol.dll

  1. Para descargar el archivo LegitCheckControl.cab, visite el siguiente sitio Web de Microsoft:
  2. Extraiga el archivo LegitCheckControl.cab en un directorio temporal en su equipo.
  3. Copie el archivo Legitcheckcontrol.dll en el directorio temporal en el directorio %windir%\System32 .
  4. Haga clic en Inicio, haga clic en Ejecutar, escriba cmd y, a continuación, haga clic en Aceptar.
  5. Registre la nueva versión del archivo LegitcheckControl.dll escribiendo el comando siguiente en el símbolo del sistema:
    regsvr32 %windir%\system32\legitcheckcontrol.dll
  6. Reinicie el equipo.
  7. Una vez reiniciado el equipo, realizar el paso 1 para determinar si el problema persiste. Si sigue recibiendo el mensaje de error, vaya al paso 3.

Paso 3: Vuelva a registrar el archivo Licwmi.dll

  1. Haga clic en Inicio, haga clic en Ejecutar, escriba cmd y, a continuación, haga clic en Aceptar.
  2. En el símbolo del sistema, escriba el comando siguiente y, a continuación, presione ENTRAR:
    regsvr32 /u %windir%\system32\licwmi.dll
  3. Vuelva a realizar el paso 1. Si sigue recibiendo el mensaje de error, vaya al paso 4.

Paso 4: Vuelva a registrar el archivo Licdll.dll

  1. Haga clic en Inicio, haga clic en Ejecutar, escriba cmd y, a continuación, haga clic en Aceptar.
  2. En el símbolo del sistema, escriba los siguientes comandos. Presione ENTRAR después de cada comando.
    regsvr32 /u %windir%\system32\licdll.dll
    net stop winmgmt
  3. Cuando se detenga el servicio Winmgmt, escriba el comando siguiente en el símbolo del sistema y, a continuación, presione ENTRAR:
    Net start winmgmt
  4. Vuelva a realizar el paso 1. Si sigue recibiendo el mensaje de error, vaya al paso 5.

Paso 5: Comprobar el valor de ProductID en el registro

  1. Haga clic en Inicio, haga clic en Ejecutar, escriba regedit y, a continuación, haga clic en Aceptar.
  2. Busque y, a continuación, haga clic en el valor del registro siguiente:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProductID
  3. Compruebe que aparece el valor del registro en el formato siguiente:
    <12345-VER-1234567-89012>
  4. Si el valor aparece correctamente, reinicie el equipo y, a continuación, volver a realizar el paso 1.
  5. Si sigue recibiendo el mensaje de error, vaya al paso 6.

Paso 6: Asegúrese de que los atributos de los archivos Wpa.dbl no se establecen como de sólo lectura

  1. Haga clic en Inicio, haga clic en Ejecutar, escriba attrib - r %windir%\system32\wpa.dbly, a continuación, haga clic en Aceptar.
  2. Vuelva a realizar el paso 1. Si sigue recibiendo el mensaje de error, vaya al paso 7.

Paso 7: Compruebe la configuración de seguridad de los archivos Wpa.dbl

  1. En el Explorador de Windows, busque el archivo %windir%\System32\Wpa.dbl.
  2. Haga Wpa.dbly, a continuación, haga clic en Propiedades.
  3. En la ficha seguridad , haga clic en para seleccionar el grupo de sistema. Compruebe que está activada la casilla de verificación Permitir correspondiente a Control total . Si no está seleccionado el Control total para el grupo de sistema, selecciónelo y, a continuación, haga clic en Aceptar.
  4. Vuelva a realizar el paso 1. Si sigue recibiendo el mensaje de error, vaya al paso 8.
Nota: En Windows XP Home Edition, la ficha seguridad aparece sólo cuando el equipo se ejecuta en modo seguro. Además, en Windows XP Professional, la ficha seguridad sólo aparece cuando está desactivada la casilla de verificación utilizar el uso compartido simplificado (recomendado) en el cuadro de diálogo Opciones de carpeta .

Paso 8: Ejecutar la herramienta Microsoft Genuine Advantage diagnóstico (MGADIAG)

  1. Para ejecutar la herramienta, visite el siguiente sitio Web de Microsoft:
  2. En el cuadro de diálogo Descarga de archivos - advertencia de seguridad , haga clic en Ejecutar.
  3. En el cuadro de diálogo Internet Explorer - advertencia de seguridad , haga clic en Ejecutar.
  4. En el cuadro de diálogo Herramienta de diagnóstico de ventajas original Microsoft , haga clic en continuar.
  5. Cuando finalice la herramienta MGADIAG, haga clic en Copiar.
  6. Visite el foro en línea de problemas de validación de ventajas original de Windows XP en el siguiente sitio Web de Microsoft:Puede crear un subproceso nuevo en este sitio Web que incluya la información que copió desde la herramienta MGADIAG.

Estado


Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información


Para obtener más información acerca de WGA, visite el siguiente sitio Web de Microsoft:Para obtener más información, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:

892130 descripción de ventajas de Windows original (WGA)

916247 Windows Genuine Advantage no valida una copia de Windows XP

Para obtener más información acerca de cómo activar Windows XP, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

307890 cómo activar Windows XP