Puede recibir un mensaje de error cuando intenta cargar un informe personalizado en Microsoft Dynamics CRM 3.0 o SQL Server Reporting Services o al intentar modificar el informe en el Diseñador de informes de Visual Studio

La revisión que se describe en este artículo no está disponible para la versión china de Microsoft Dynamics CRM o para la versión japonesa de Microsoft Dynamics CRM.

Síntomas

Síntoma 1

Considere la situación siguiente en Microsoft Dynamics CRM 3.0. Descargue un informe personalizado que contiene código de Microsoft Dynamics CRM prefiltrado. A continuación, intenta cargar el informe en Microsoft Dynamics CRM 3.0. En este escenario, recibirá el siguiente mensaje de error:
Informe de errores de carga


Se produjo un error al intentar agregar el informe a Microsoft CRM. Intente volver a agregar el informe. Si el problema persiste, póngase en contacto con el administrador del sistema.

Es el error de la plataforma de CRM

Se produce la excepción de tipo Microsoft.Crm.CrmException. Descripción: Se ha producido una excepción no controlada durante la ejecución de la solicitud web actual. Revise el seguimiento de la pila para obtener más información acerca del error y dónde se originó en el código. Detalles de la excepción: Microsoft.Crm.CrmException: excepción de tipo Microsoft.Crm.CrmException se produjo.


Error de origen:
Se generó una excepción no controlada durante la ejecución de la solicitud web actual. Información sobre el origen y la ubicación de la excepción puede identificarse mediante el seguimiento de pila de excepciones más abajo.

Seguimiento de la pila:


[CrmException: excepción de tipo Microsoft.Crm.CrmException se produjo.]

Microsoft.Crm.Application.Platform.Report.InternalCreate(String xml) +721

Microsoft.Crm.Application.Platform.Entity.Create() + 109
Microsoft.Crm.Application.Forms.AppForm.RaiseDataEvent(FormEventId eventId) +406
Microsoft.Crm.Application.Forms.EndUserForm.Initialize(Entity entity) + 57

Microsoft.Crm.Application.Forms.EndUserForm.Execute(Entity entity) + 13
Microsoft.Crm.Web.Tools.ReportProperty.ReportPropertyPage.ConfigureForm() + 202

Microsoft.Crm.Application.Controls.AppPage.OnPreRender(EventArgs e) + 30

System.Web.UI.Control.PreRenderRecursiveInternal() + 62

System.Web.UI.Page.ProcessRequestMain() +1499

Este problema se produce si utiliza Microsoft SQL Server 2005 Reporting Services (SSRS) en Microsoft Dynamics CRM.

Síntoma 2

Considere la situación siguiente en Microsoft Dynamics CRM 3.0. Descargue un informe personalizado que contiene código de Microsoft Dynamics CRM prefiltrado. A continuación, intenta cargar el informe directamente en Reporting Services o intentar modificar el informe en Microsoft Visual Studio Report Designer. En este escenario, recibirá el siguiente mensaje de error:
Error de deserialización:
El elemento 'Informe' en el espacio de nombres 'http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition' tiene el elemento secundario no válido 'Custom' en el espacio de nombres 'http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition'. Lista de posibles elementos esperados: ' http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition:Description http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition:Author http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition:AutoRefresh http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition:DataSources http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition:DataSets http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition:Body http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition:ReportParameters http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition:Code http://schemas.microsoft.com/sqlserver/reporting/2005/... Línea 56, posición 2034.

Causa

Este problema se produce porque el informe descargado tenía el formato correcto. El informe contiene el código de Microsoft Dynamics CRM prefiltrado anexado para el esquema de Reporting Services de SQL Server 2003 o para el esquema de SQL Server 2000 Reporting Services. Los esquemas de Reporting Services de SQL Server 2003 y SQL Server 2000 Reporting Services utilizan la etiqueta < personalizado > para filtrado previo. El esquema de SQL 2005 Reporting Services contiene nuevas definiciones de esquema. Las nuevas definiciones de esquema utiliza la etiqueta < personalizado > al volver a cargar el informe. Por lo tanto, Microsoft Dynamics CRM no puede validar el código XML en el informe.

Solución

Este problema se corrigió en acumulativo de actualizaciones 3 para Microsoft Dynamics CRM 3.0.

Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:
935364 El paquete acumulativo de actualizaciones 3 está disponible para Microsoft Dynamics CRM 3.0
Para resolver este problema, modifique el informe para utilizar el formato correcto. Para ello, utilice el método apropiado:
  • Si no se ha reiniciado el servidor, se encuentra en el entorno original. Para resolver este problema, utilice el método 1.
  • Si se ha reiniciado el servidor, no está en el entorno original. Por lo tanto, no se puede aplicar el hotfix que se menciona en el método 1. En este caso, si el informe se debe cargar en el nuevo entorno, utilice el método 2 para resolver este problema.

    Nota: Por ejemplo, exportar el informe como parte de un plan de copia de seguridad. Más adelante, se bloqueó el equipo que está ejecutando Reporting Services. Después de que el equipo que está ejecutando Reporting Services se vuelve a crear, dejan en el entorno original. Por lo tanto, no se puede aplicar la revisión. Debe modificar el informe para utilizar las etiquetas de lenguaje RDL (Report Definition) 2005.

Método 1

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en el elemento de fecha y hora del Panel de Control.

Servidor de Microsoft Dynamics CRM 3.0
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Crmmsg.dll1.2.3297.12316,08829-Mar-200720:18x86
Microsoft.crm.reporting.dll3.0.5300.168670,67216-Oct-200706:49x86
Mscrmcustom.dll3.0.5300.1656181,09621-Aug-200712:47x86
Msvcr71.dll7.10.3052.4355,03229-Mar-200720:18x86
Pkgutil.cmdNo aplicable11329-Mar-200705:18No aplicable
Pkgutil.exe1.2.3297.10188,79229-Mar-200720:18x86
Microsoft.crm.reporting.dll3.0.5300.168670,67216-Oct-200706:50x86
Microsoft.crm.reporting.dll3.0.5300.164,26417-Nov-200504:38x86
Crmhotfix.cdfNo aplicable2.27216-Oct-200707:00No aplicable
Mscrmcustom.dll3.0.5300.1656181,09621-Aug-200712:47x86
Updspapi.dll6.1.22.0371,93629-Mar-200720:18x86
Cliente para equipo portátil Microsoft Dynamics CRM 3.0 para la actualización de compatibilidad de Microsoft Office Outlook
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Setup.xmlNo aplicable1,18916-Oct-200707:12No aplicable
V3cclientpatch30.mspNo aplicable51,71216-Oct-200707:35No aplicable
Microsoft.crm.reporting.dll3.0.5300.168670,67216-Oct-200706:50x86
Cliente para equipo portátil Microsoft Dynamics CRM 3.0 para Microsoft Office Outlook
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Crmmsg.dll1.2.3297.12316,08829-Mar-200720:18x86
Microsoft.crm.reporting.dll3.0.5300.168670,67216-Oct-200706:49x86
Mscrmcustom.dll3.0.5300.1656181,09621-Aug-200712:47x86
Msvcr71.dll7.10.3052.4355,03229-Mar-200720:18x86
Pkgutil.cmdNo aplicable11329-Mar-200705:18No aplicable
Pkgutil.exe1.2.3297.10188,79229-Mar-200720:18x86
Microsoft.crm.reporting.dll3.0.5300.164,28017-Nov-200504:42x86
Crmhotfix.cdfNo aplicable1.97816-Oct-200707:00No aplicable
Mscrmcustom.dll3.0.5300.1656181,09621-Aug-200712:47x86
Updspapi.dll6.1.22.0371,93629-Mar-200720:18x86
Después de aplicar la revisión para Microsoft Dynamics CRM, el informe se formateará correctamente.

Información sobre la instalación

Instale esta revisión en equipos que ejecutan el servidor de Microsoft Dynamics CRM 3.0 y el cliente de Microsoft Dynamics CRM 3.0 para Microsoft Office Outlook.

Requisitos previos

Debe tener el servidor de Microsoft Dynamics CRM 3.0 y el cliente de Microsoft Dynamics CRM 3.0 para Microsoft Office Outlook instalado para aplicar esta revisión.

Requisito de reinicio

Si se le pide, reinicie el equipo después de aplicar el hotfix.

Información de eliminación

Para quitar esta revisión de un equipo que ejecuta Windows Server 2003, Windows XP o Microsoft Windows 2000, utilice Agregar o quitar programas en Panel de Control. Los administradores del sistema pueden usar la herramienta Spuninst.exe para quitar esta revisión de un equipo que ejecuta Windows Server 2003, Windows XP o Microsoft Windows 2000.

La herramienta Spuninst.exe se encuentra en la carpeta %Windir%\$NTUninstallKB939867$\Spuninst.

Método 2

Para resolver este problema, modifique el informe para utilizar las etiquetas de RDL 2005 en lugar de las etiquetas de RDL 2003 en XML. Para ello, siga estos pasos:
  1. Abra el informe utilizando el Bloc de notas o mediante un editor de XML de texto enriquecido.
  2. Busque el CRM prefiltrado de sección en el informe. Reemplace el código existente con el código de reemplazo como sigue.

    Código existente
    <Custom><MSCRM xmlns="mscrm"><ReportFilter><ReportEntity paramname="P1"><
    fetch version="1.0" output-format="xml-platform" mapping="logical"
    distinct="false"><entity name="account"><all-attributes /><
    filter type="and"><condition attribute="modifiedon" operator="last-x-days"
    value="30" /></filter></entity></fetch></ReportEntity></ReportFilter></MSCRM>
    </Custom>


    Código de sustitución
    <CustomProperties> <CustomProperty> 
    <Name></Name>
    <Value></Value>
    <MSCRM xmlns="mscrm"><ReportFilter><ReportEntity paramname="P1"><
    fetch version="1.0" output-format="xml-platform" mapping="logical"
    distinct="false"><entity name="account"><all-attributes /><
    filter type="and"><condition attribute="modifiedon" operator="last-x-days"
    value="30" /></filter></entity></fetch></ReportEntity></ReportFilter></MSCRM>
    </CustomProperty>
    </CustomProperties>

    Notas:
    • En este código, se agregan las siguientes etiquetas. SQL Server 2005 Reporting Services requiere estas etiquetas.
      <Name></Name><Value></Value>

    • En este código, se modifican las siguientes etiquetas de Reporting Services de SQL Server 2003 para ser etiquetas de SQL Server 2005 Reporting Services.
      <Custom>...
      </Custom>

Más información

Para obtener más información acerca de la terminología de la actualización de software, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

887283 paquete de actualizaciones y revisiones de software de Microsoft Business Solutions CRM estándares de nomenclatura
Propiedades

Id. de artículo: 939867 - Última revisión: 13 ene. 2017 - Revisión: 1

Comentarios