El servicio de servidor Virtual puede dejar de responder cuando está iniciando el servicio si uno o más de las máquinas virtuales están configurados para iniciarse automáticamente cuando se inicia el servicio de servidor Virtual

Síntomas

En un equipo que tiene Microsoft Virtual Server 2005 R2 Service Pack 1 (SP1) instalado, el servicio de servidor Virtual puede dejar de responder cuando se inicia el servicio. Este problema puede producirse si uno o más de las máquinas virtuales están configurados para iniciarse automáticamente cuando se inicia el servicio de servidor Virtual.

Para recuperarse de este problema, tendrá que descartar el estado guardado de las máquinas virtuales. O bien, tendrá que eliminar manualmente los archivos de estado guardado (.vsv) correspondiente de las máquinas virtuales.

Además, recibirá el siguiente mensaje de error cuando intenta iniciar una máquina virtual:
Tiempo de espera CGI
La aplicación CGI especificada excedió el tiempo permitido para procesamiento. El servidor ha eliminado el proceso.
Además, la interfaz de servicios de Internet Information Server (IIS) (Vswebapp.exe) y servicios VMRC ya no funcionan y perderá el acceso a la vista de administración.

Causa

Si la máquina virtual se configura para iniciarse automáticamente cuando se inicia el servicio de servidor Virtual se puede detener inesperadamente una máquina virtual. Dado que la máquina virtual se detiene inesperadamente, la máquina virtual no libera todos los recursos. A continuación, el servicio de servidor Virtual deja de responder.

Solución

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar esta revisión, debe estar ejecutando Virtual Server 2005 R2 con Service Pack 1.

Requisito de reinicio

No es necesario que reinicie el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Este hotfix no sustituye a otras revisiones.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.
Virtual Server 2005 R2 con Service Pack 1, versiones basadas en x86
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Microsoft.virtualserver.interop.dll1.1.603.0206,22416-Aug-200704:45x86
Microsoft.vmrcclientcontrol.interop.dll1.1.603.037,30416-Aug-200704:45x86
Vhdmount.dll1.1.603.0150,92016-Aug-200704:45x86
Vhdmount.exe1.1.603.02,861,47216-Aug-200704:45x86
Virtualserverlogmessages.dll1.1.603.099,72016-Aug-200704:45x86
Virtualserverlogmessages.dll1.1.603.099,72016-Aug-200704:45x86
Vmh.exe1.1.603.0166,80816-Aug-200704:45x86
Vmm.sys1.1.603.0232,81616-Aug-200704:45x86
Vmrc.exe1.1.603.0448,40016-Aug-200704:45x86
Vssrvc.exe1.1.604.03,373,43216-Aug-200704:45x86
Vswebapp.exe1.1.603.01,788,80816-Aug-200704:45x86
Vswriter.dll1.1.603.0327,56016-Aug-200704:45x86
Virtual Server 2005 R2 con Service Pack 1, versiones basadas en x64
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Microsoft.virtualserver.interop.dll1.1.603.0206,22416-Aug-200704:46x86
Microsoft.vmrcclientcontrol.interop.dll1.1.603.037,30416-Aug-200704:46x86
Vhdmount.dll1.1.603.0150,92016-Aug-200704:46x86
Vhdmount.exe1.1.603.02,861,47216-Aug-200704:46x86
Virtualserverlogmessages.dll1.1.603.099,72016-Aug-200704:46x86
Virtualserverlogmessages.dll1.1.603.099,72016-Aug-200704:46x86
Vmh.exe1.1.603.0269,20816-Aug-200704:46x64
Vmm.sys1.1.603.0297,84016-Aug-200704:46x64
Vmrc.exe1.1.603.0649,10416-Aug-200704:46x64
Vssrvc.exe1.1.604.06,018,93616-Aug-200704:46x64
Vswebapp.exe1.1.603.03,238,79216-Aug-200704:46x64
Vswriter.dll1.1.603.0505,22416-Aug-200704:46x64

Solución alternativa

Para evitar este problema, utilice uno de los métodos siguientes.

Método 1

Activar las máquinas virtuales o apagar los sistemas operativos huéspedes, en lugar de guardar los Estados.

Método 2

  1. Crear una máquina virtual que tiene un disco duro virtual en blanco.
  2. La máquina virtual se conecte a la misma red virtual como las máquinas virtuales problemáticas.
  3. Encienda la máquina virtual que creó en el paso 1.
  4. Restaurar las máquinas virtuales problemáticas.

Método 3

Si las máquinas virtuales no tiene que tener las funciones de red, quite todos los adaptadores de red virtual que estén conectados a las máquinas virtuales.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 941125 - Última revisión: 14 ene. 2017 - Revisión: 1

Comentarios