Cuando seleccione "Todos los programas" en un equipo basado en Windows XP, la lista de programas no aparece o está vacía la lista de programas

Síntomas

En un equipo basado en Windows XP, pueden producirse los siguientes problemas relacionados con el menú Inicio:
  • Cuando haga clic en Inicioy, a continuación, seleccione Todos los programas, no aparece la lista de programas.
  • Si utiliza el menú Inicio clásico, una lista vacía aparece cuando hace clic en Inicioy, a continuación, seleccione programas.
Estos problemas se producen si no se puede tener acceso a la carpeta menú Inicio. Por ejemplo, estos problemas se producen si no tiene permiso de acceso a la carpeta menú Inicio.

Causa

Estos problemas se producen si el valor de la entrada de registro del menú de inicio común es inaccesible o si el valor no es válido. En este caso, Windows XP no puede inicializar el shell de programa.

Solución

Hay una revisión resolver este problema. Después de aplicar esta revisión, Windows XP omite todos los errores cuando Windows XP inicializa el shell de programa. Si el valor de la entrada de registro del menú de inicio común es inaccesible o si el valor no es válido, Windows XP carga un menú de inicio predeterminado.

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Debe tener instalado Windows XP Service Pack 2 (SP2).

Requisito de reinicio

Tendrá que reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de revisión


Este hotfix no sustituye a otras revisiones.

Información del registro


Para utilizar este hotfix, no es necesario realizar ningún cambio en el registro.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.
Windows XP con SP2, versiones de 32 bits
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataformaRequisito de SP
Shell32.dll6.0.2900.32018,459,26428-Aug-200710:45x86SP2
Xpsp3res.dll5.1.2600.3158350,72019-Jun-200704:31x86SP2

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

La ubicación del menú Inicio depende del valor de la entrada de registro del menú de inicio común que se encuentra bajo la siguiente subclave del registro:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
De forma predeterminada, el valor de esta entrada del registro es como sigue:
Menú %ALLUSERSPROFILE%\Start
De forma predeterminada, la carpeta menú Inicio se encuentra en "%systemdrive%\Document and Settings\All Users" carpeta.

La carpeta menú inicio será inaccesible si se cumple alguna de las condiciones siguientes:
  • La entrada de menú Inicio común del registro está dañada.
  • Una lista de control de acceso discrecional (DACL) impide que todos los usuarios lean la clave primaria de la entrada de registro del menú de inicio común.
  • La entrada de menú Inicio común del registro señala a una ubicación que no está accesible, como un recurso compartido de red.
  • La entrada de menú Inicio común del registro señala a una ubicación que los usuarios no tienen permiso de acceso.

Cómo cambiar el menú Inicio a la versión clásica

  1. Haga clic en Inicioy, a continuación, haga clic en Propiedades.
  2. En la ficha Menú Inicio , haga clic en menú Inicio clásico.
  3. Haga clic en Aceptar.
Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft
Propiedades

Id. de artículo: 941248 - Última revisión: 14 ene. 2017 - Revisión: 1

Microsoft Windows XP Home Edition, Microsoft Windows XP Professional

Comentarios