Un agente de equipo inesperadamente genera alertas de latido después de ponerlo en modo de mantenimiento en System Center Operations Manager

Síntomas

Considere el siguiente escenario. En Microsoft System Center Operations Manager, coloca a un agente del equipo en modo de mantenimiento. A continuación, la información siguiente aparece en el cuadro de diálogo Configuración de modo de mantenimiento :
Estas características se suspenden temporalmente para objetos en modo de mantenimiento:
  • Reglas y monitores
  • Notificaciones
  • Respuestas automáticas
  • Cambios de estado
  • Nuevas alertas
Sin embargo, el equipo que está ejecutando al agente inesperadamente continúa generar alertas de latido.

Nota: Para obtener más información acerca de cómo poner un agente en modo de mantenimiento, consulte la sección "Pasos para reproducir el comportamiento".

Causa

Este comportamiento se produce si no colocar en modo de mantenimiento de las siguientes características:
  • Servicio de salud
  • Monitor de servicios de salud
Por su diseño, System Center Operations Manager comprueba que el agente funciona correctamente incluso si no se está supervisando el equipo. Si la función de servicio de la salud y la función de Monitor de servicios de salud para el agente en particular no están en modo de mantenimiento, experimenta el comportamiento que se menciona en la sección "Síntomas".

Solución

Para resolver este comportamiento al colocar la función de servicio de la salud y la función de Monitor de servicios de salud en modo de mantenimiento, siga estos pasos:
  1. Si no se está ejecutando, inicie la consola de operaciones.
  2. Haga clic en supervisión, expanda el nodo supervisión y, a continuación, haga clic en equipos.
  3. Seleccione el equipo que desea poner en modo de mantenimiento y, a continuación, haga clic en Iniciar modo de mantenimiento en el panel acciones .
  4. En el cuadro de diálogo Configuración de modo de mantenimiento , haga clic en Aceptar.
  5. En el nodo supervisión , haga clic en Inventario descubierto.
  6. En el panel acciones , haga clic en Cambiar tipo de destino.
  7. En el cuadro de diálogo Seleccionar un tipo de destino , haga clic en Servicio de saludy, a continuación, haga clic en Aceptar.
  8. Haga clic en el agente para el que desea colocar el servicio de salud en modo de mantenimiento y, a continuación, haga clic en Iniciar modo de mantenimiento en el panel acciones .
  9. En el cuadro de diálogo Configuración de modo de mantenimiento , haga clic en Aceptar.
  10. En la vista de Inventario descubierto , haga clic en Cambiar tipo de destino en el panel de acción .
  11. En el cuadro de diálogo Seleccionar un tipo de destino , haga clic en Ver todos los destinos, haga clic en Monitor de servicio de saludy, a continuación, haga clic en Aceptar.
  12. Haga clic en el agente para el que desea colocar el Monitor de servicios de salud en modo de mantenimiento y, a continuación, haga clic en Iniciar modo de mantenimiento en el panel acciones .
  13. En el cuadro de diálogo Configuración de modo de mantenimiento , haga clic en Aceptar.

Estado

Este comportamiento es por diseño.

Más información

Los administradores que desee asegurarse de que el agente funciona incluso si no se está supervisando el equipo. Si el agente no se está supervisando, pueden producirse errores de relacionados con el agente ocultos que afectan a la supervisión general del equipo cuando el equipo ya no está en modo de mantenimiento. Por lo tanto, cuando un equipo se ponga en modo de mantenimiento, el servicio de mantenimiento de OpsMgr no se pondrá también en modo de mantenimiento.

Pasos para reproducir el comportamiento

  1. Inicie la consola de operaciones.
  2. Haga clic en supervisión, expanda el nodo supervisión y, a continuación, haga clic en equipos.
  3. En el panel de equipos , haga clic en un agente y, a continuación, haga clic en Iniciar modo de mantenimiento.
  4. En el cuadro de diálogo Configuración de modo de mantenimiento , haga clic en objetos seleccionados y todos sus objetos contenidos.

    Nota: Las entradas siguientes aparecen bajo estas características se suspenden temporalmente para objetos en modo de mantenimiento:
    • Reglas y monitores
    • Notificaciones
    • Respuestas automáticas
    • Cambios de estado
    • Nuevas alertas
  5. Haga clic en Aceptar.
  6. En el agente, detenga el servicio de mantenimiento de OpsMgr.
Observe que en aproximadamente tres minutos (si utiliza la configuración de latido predeterminado), recibirá una alerta de error de latido de servicios de salud para este agente en la vista Alertas activas . Además, se graba el suceso siguiente en el registro de Operations Manager:
Propiedades

Id. de artículo: 942866 - Última revisión: 14 ene. 2017 - Revisión: 1

Comentarios