Mensaje de error cuando intenta instalar, actualizar o configurar un cliente de Microsoft Dynamics CRM para el equipo de Outlook

Síntomas

Cuando intenta instalar o actualizar a un cliente de Microsoft Dynamics CRM para el equipo de Microsoft Office Outlook, recibirá el siguiente mensaje de error:
Error en la acción Microsoft.Crm.Config.Client.InstallAbpAction.

Acceso denegado. (Excepción de HRESULT: 0 x 80070005 (E_ACCESSDENIED))
Además, recibirá uno de los siguientes mensajes de error.
Mensaje de error 1
Cuando se instala un cliente de Microsoft Dynamics CRM 4.0 para el equipo de Outlook, recibirá el siguiente mensaje de error en el registro de configuración:
12:58:46 | Error | Excepción de configuración. System.Exception: Error en la acción Microsoft.Crm.Config.Client.InstallAbpAction. --->
System.UnauthorizedAccessException: Acceso denegado. (Excepción de HRESULT: 0 x 80070005 (E_ACCESSDENIED))

en System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal (Int32 errorCode, IntPtr errorInfo)

en Microsoft.Crm.Config.Client.InstallAbpAction.Do (parámetros IDictionary)

en Microsoft.Crm.Setup.Common.Action.ExecuteAction (acción de la acción, parámetros IDictionary, deshacer booleano)

---Fin del seguimiento de pila de excepción interna---

en Microsoft.Crm.Setup.Common.Action.ExecuteAction (acción de la acción, parámetros IDictionary, deshacer booleano)

en Microsoft.Crm.Setup.Common.Installer.Install (IDictionary stateSaver)

en Microsoft.Crm.Setup.Common.ComposedInstaller.InternalInstall (IDictionary stateSaver)

en Microsoft.Crm.Setup.Common.ComposedInstaller.Install (IDictionary stateSaver)

en Microsoft.Crm.Config.Client.ClientConfig.Install (IDictionary datos)

en Microsoft.Crm.Config.Client.ClientConfig.Run() 12:58:46 | Verbose | Error de configuración 12:58:46 | Info | No hemos podido configurar correctamente Microsoft Dynamics CRM para Outlook:



Error en la acción Microsoft.Crm.Config.Client.InstallAbpAction.

Acceso denegado. (Excepción de HRESULT: 0 x 80070005 (E_ACCESSDENIED))
Mensaje de error 2
Cuando se actualiza un cliente de Microsoft Dynamics CRM 3.0 para el equipo de Outlook, recibirá el siguiente mensaje de error en el registro de instalación:
UpgradeDatabase.Action

UpgradeDatabase.Started

Buscar archivos de base de datos

Mover archivos de base de datos

Base de datos termine de acciones

Asignar permisos para S-1-5-21-682003330-616249376-1801674531-1112

C:\Program Files\Microsoft CRM\sql\v3_msde_mscrm.mdf

en System.Security.AccessControl.NativeObjectSecurity.CreateInternal (ResourceType resourceType, isContainer Boolean, String nombre, identificador de SafeHandle, AccessControlSections includeSections, booleano createByName, ExceptionFromErrorCode exceptionFromErrorCode, exceptionContext objeto)

en System.Security.AccessControl.FileSystemSecurity.. ctor (Boolean isContainer, nombre cadena, AccessControlSections includeSections, isDirectory booleano)

en System.Security.AccessControl.FileSecurity.. ctor (String fileName, AccessControlSections includeSections)

en System.IO.FileInfo.GetAccessControl() en Microsoft.Crm.Setup.Client.DatabaseInstaller.Upgrade (sesión sesión)

en Microsoft.Crm.Setup.Client.ClientSetup.UpgradeDatabase (sesión sesión)

Acción terminó a las 10:33:09: InstallFinalize. Valor devuelto 3.
Cuando intenta configurar la versión de cliente de Outlook sin conexión de Microsoft Dynamics CRM 4.0, recibe constantemente el error siguiente en una ventana modal de Reintentar/Cancelar :
Error en la acción Microsoft.Crm.Config.Client.InstallPstAction. Error de LaunchOutlookInstallerProcess.

Causa

Este problema puede producirse si el archivo de datos de Microsoft Dynamics CRM no se quitó completamente y los contactos de proveedor (ABP) de Microsoft Dynamics CRM libreta de dirección no se quitaron totalmente.

Solución

Resolución 1

Para resolver este problema, utilice uno de los métodos siguientes y, a continuación, intentar instalar o actualizar a un cliente de Microsoft Dynamics CRM para el equipo de Outlook.

Método 1: Si tiene Microsoft Office Outlook 2007 instalado

  1. Inicie Outlook 2007.
  2. En el menú Herramientas, haga clic en Configuración de la cuenta.
  3. Haga clic en la ficha Archivos de datos .
  4. Haga clic en Microsoft CRMy, a continuación, haga clic en Quitar.
  5. Haga clic en la ficha Libretas de direcciones .
  6. Haga clic en Libreta de direcciones de Microsoft CRMy, a continuación, haga clic en Quitar.
  7. Salga de Outlook 2007.

Método 2: Si tiene Microsoft Office Outlook 2003 instalado

  1. Salga de Outlook 2003.
  2. Haga clic en Inicio, haga clic en Panel de Control, haga clic en Cuentas de usuarioy, a continuación, haga clic en correo.
  3. En el cuadro de diálogo Configuración de correo , haga clic en Archivos de datos.
  4. Haga clic en Microsoft CRM, haga clic en Quitary, a continuación, haga clic en Cerrar.
  5. En el cuadro de diálogo Configuración de correo , haga clic en Cuentas de correo electrónico.
  6. Haga clic en Ver o cambiar libretas de direcciones existentesy, a continuación, haga clic en siguiente.
  7. Haga clic en Libreta de direcciones de Microsoft CRMy, a continuación, haga clic en Quitar.
  8. Haga clic en Cerrar para cerrar el cuadro de diálogo Configuración de correo .

Resolución 2

Siga estos pasos:
  1. Inicie Outlook.
  2. En el menú Herramientas, haga clic en Opciones.
  3. En la ficha Configuración de correo , haga clic en Cuentas de correo electrónico.
  4. En la ficha Archivos de datos , seleccione Microsoft CRM y no está disponibley, a continuación, haga clic en Quitar.
Propiedades

Id. de artículo: 948312 - Última revisión: 14 ene. 2017 - Revisión: 1

Microsoft Dynamics CRM 4.0, Microsoft Dynamics CRM 4.0, Microsoft Dynamics CRM for Microsoft Office Outlook, Microsoft Dynamics CRM 4.0, Microsoft Dynamics CRM 4.0

Comentarios