Mensajes de error cuando intenta instalar Windows XP Service Pack 3: "no se completó la instalación del Service Pack 3" y "Error interno"

Síntomas

Cuando intenta instalar Windows XP Service Pack 3 (SP3), puede recibir el siguiente mensaje de error:
Se ha producido un error interno
Después de hacer clic en Aceptar en el mensaje de error, recibirá el siguiente mensaje de error:
No se completó la instalación del Service Pack 3
Además, puede ver los errores que se registran en el C: archivo \Windows\Svcpack.log:
165.672: An internal error occurred.165.672: Service Pack 3 installation did not complete.
165.672: Update.exe extended error code = 0x1ffe054f
165.672: Update.exe return code was masked to 0x643 for MSI custom action compliance

Nota: En este artículo, el C: carpeta \Windows representa la carpeta donde se instala Windows XP.

Causa

Los errores que se mencionan en la sección "Síntomas" pueden producirse debido a archivos que no son de confianza o claves del Registro dañadas. Puede comprobar la causa buscando entradas relacionadas en el archivo Svcpack.log. Entradas específicas identificará las causas concretas del problema, como se indica en las siguientes secciones "Causa".

Causa 1

Determinar si las siguientes entradas se registran en el archivo Svcpack.log:
142.391: CheckVLKForBlock: LIC.dll not trust verified142.578: Trying CheckVLKForBlock again
142.594: CheckVLKForBlock: LIC.dll not trust verified
142.594: Error: CheckVLKForBlock failed

Estas entradas indican que la causa del problema es el archivo Licdll.dll. El archivo Licdll.dll puede haberse alterado, está dañado o no es de confianza. El archivo Licdll.dll se encuentra en la carpeta siguiente:
C:\Windows\System32\

Causa 2

Determinar si las siguientes entradas se registran en el archivo Svcpack.log:
211.890: IsSPBetaKey:pLA->lpVtbl->GetProductID Failed: 0x80004005 213.125: Trying CheckVLKForBlock again
214.468: Error: CheckVLKForBlock failed

Estas entradas indican que la información de ID de producto incorrecta en el registro está causando el problema.

Causa 3

Determinar si las siguientes entradas se registran en el archivo Svcpack.log:
299.031: Trying CheckVLKForBlock again299.531: Error: CheckVLKForBlock failed

Estas entradas indican que las claves de registro dañado o alterado en programas preinstalados están causando el problema.

Nota: Un programa que se sabe que causan este problema es Micrografx - imagen Publisher Professional 10. Para evitar este problema, consulte la sección "Solución para la causa 3".

Solución

Para resolver o evitar estas causas, utilizar la resolución o la solución que corresponde a la causa.

Solución para la causa 1

Para resolver este problema, debe reemplazar la copia actual del archivo Licdll.dll utilizando una copia desde el medio original de Windows XP. Para ello, siga estos pasos:
  1. Inserte el CD de Windows XP en la unidad de CD.
  2. Tan pronto como se inicie, haga clic en Salir en el Asistente para la instalación .
  3. Haga clic en Inicio y, a continuación, haga clic en Ejecutar.
  4. Copie y, a continuación, pegue (o escriba) el comando siguiente en el cuadro Abrir y, a continuación, presione ENTRAR:
    Explorador
  5. Haga clic en Mi PC.
  6. Anote la letra de unidad que contiene el CD de Windows XP.
  7. Haga clic en Inicio y, a continuación, haga clic en Ejecutar.
  8. Copie y, a continuación, pegue (o escriba) el comando siguiente en el cuadro Abrir y, a continuación, presione ENTRAR:
    cmd
  9. Escriba o copie y pegue el texto siguiente en la ventana de símbolo del sistema y, a continuación, presione ENTRAR:
    Expanda letraDeUnidadDeCD: \i386\licdll.dl_ C: \Windows\system32\Licdll.dll
    Nota: En el comando en el paso 9, reemplace letraDeUnidadDeCD utilizando la letra de la unidad que anotó en el paso 6.
  10. Para instalar Windows XP SP3, visite el siguiente sitio Web de Microsoft Windows Update:

Solución para la causa 2

Para resolver este problema, debe reemplazar la entrada de registro de ID de producto incorrecta con el ID de producto correcto. Para ello, siga los pasos en la "Busque y observe el identificador del producto" y las secciones de "Identificar y cambiar la entrada de registro de ID de producto".

Busque y anote el identificador del producto

  1. Haga clic en Inicio y, a continuación, haga clic en Ejecutar.
  2. Copie y, a continuación, pegue (o escriba) el comando siguiente en el cuadro Abrir y, a continuación, presione ENTRAR:
    sysdm.cpl
  3. En la tablocate General el Id. El identificador de producto es el número de 20 dígitos que se encuentra bajo la sección registrado a .
  4. Nota El identificador del producto para su uso en la sección "Identificar y cambiar la entrada de registro de ID de producto".

Identificar y cambiar la entrada de registro de ID de producto

Importante: esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para una mayor protección, haga una copia de seguridad del registro antes de modificarlo. Entonces, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo hacer copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 cómo hacer copia de seguridad y restaurar el registro en Windows
  1. Haga clic en Inicio y, a continuación, haga clic en Ejecutar.
  2. Copie y, a continuación, pegue (o escriba) el comando siguiente en el cuadro Abrir y, a continuación, presione ENTRAR:
    Regedit
  3. Busque y, a continuación, haga clic en la subclave del Registro similar a la siguiente subclave del registro:
    HKEY_LOCAL_MACHINE\SYSTEM\WPA\Key-XXXXXXXXXXXXXXXXXXXXX
    Nota: La serie de Xs representa un marcador de posición para una cadena de 21 caracteres.
  4. Puede haber varias subclaves que asemejan el formato en el paso 3. Para determinar la subclave correcta, siga estos pasos:
    1. Haga clic en cada subclave en el panel de exploración.
    2. En el panel de detalles, comparar el valor de la cadena para la entrada de registro ProductID bajo la columna de datos para el número que anotó en el paso 4 en el "Busque y observe el identificador del producto" sección.
    3. La subclave del registro cuyo valor de la entrada ProductID del registro coincide con el número que anotó en la sección "Buscar el identificador del producto" es la subclave del registro que desee.
  5. En el panel de exploración, haga clic en la subclave del registro que identificó en el paso 4c y, a continuación, haga clic en Exportar.
  6. Guarde la subclave del registro en el escritorio como temp.reg.
  7. Haga clic en el archivo temp.reg en el escritorio y, a continuación, haga clic en Abrir con.
  8. Haga clic en Bloc de notasy, a continuación, haga clic en Aceptar.
  9. En el archivo abierto temp.reg , busque el texto siguiente:
    [HKEY_LOCAL_MACHINE\SYSTEM\WPA\Key-XXXXXXXXXXXXXXXXXXXXX]
  10. Reemplace el texto que se menciona en el paso 9 utilizando el texto siguiente:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion]
  11. Haga clic en archivo, haga clic en Guardary salga de Bloc de notas.
  12. Haga doble clic en el archivo temp.reg , haga clic en en el cuadro de diálogo cuando se le pida para agregar la información al registro y, a continuación, haga clic en Aceptar.
  13. Para instalar Windows XP SP3, visite el siguiente sitio Web de Microsoft Windows Update:

Solución para la causa 3

Para resolver este problema, debe eliminar la subclave InprocServer32. Para ello, siga estos pasos:
  1. Haga clic en Inicio y, a continuación, haga clic en Ejecutar.
  2. Copie y, a continuación, pegue (o escriba) el comando siguiente en el cuadro Abrir y, a continuación, presione ENTRAR:
    Regedit
  3. Busque y, a continuación, haga clic en la subclave del Registro similar a la siguiente subclave del registro:
    HKEY_CLASSES_ROOT\CLSID\{00020420-0000-0000-C000-000000000046}\InprocServer32
  4. Haga clic en InprocServer32. Un valor de cadena con el nombre InprocServer32 se muestra en el panel de detalles. Haga clic en este valor.


  5. En el menú Edición , haga clic en Eliminary, a continuación, haga clic en .
  6. Salga del Editor del Registro.
  7. Para instalar Windows XP SP3, visite el siguiente sitio Web de Microsoft Windows Update:

Solución para la causa 3

Un programa que se sabe que causa el problema que se menciona en 3 causar es Micrografx - imagen Publisher Professional 10. Para evitar este problema, desinstale temporalmente el programa Micrografx y, a continuación, instale Windows XP SP3. Una vez completada la instalación de Windows XP SP3, reinstale el programa Micrografx.

Los productos de terceros que se indican en este artículo están fabricados por compañías independientes de Microsoft. Microsoft no otorga ninguna garantía, implícita o de otro tipo, respecto al rendimiento o confiabilidad de estos productos.
Propiedades

Id. de artículo: 949384 - Última revisión: 14 ene. 2017 - Revisión: 1

Comentarios