El proceso de RunOnce.exe puede dejar de responder durante el proceso de instalación del controlador en un equipo basado en Windows XP

Síntomas

En un equipo basado en Windows XP, utiliza la utilidad Elevated Rights Deployment Tool (RunOnce.exe) para instalar a un controlador de terceros. Sin embargo, el proceso de RunOnce.exe puede dejar de responder (se bloquea) durante el proceso de instalación del controlador.

Causa

Este problema se produce debido a un interbloqueo en el archivo Shimeng.dll.

Solución

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, envíe una solicitud al servicio de atención al cliente y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Debe tener Windows XP Service Pack 2 o una versión posterior de service pack de Windows XP instalado en el equipo.

Requisito de reinicio

Tendrá que reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de revisión


Este hotfix no sustituye a otras revisiones publicadas anteriormente.

Información del registro


Para utilizar este hotfix, no es necesario realizar ningún cambio en el registro.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.
Windows XP con SP2, versiones basadas en x 86
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Shimeng.dll5.1.2600.332566,04804-Mar-200813:40x86
Windows XP con SP3, versiones basadas en x86
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Shimeng.dll5.1.2600.555566,04804-Mar-200816:09x86

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Este problema también afecta al proceso de Windows Installer (Msiexec.exe) y para hacer que las instalaciones de aplicación deje de responder (se bloquea). Puede experimentar este problema durante una implementación automatizada. Por ejemplo, este problema se produce cuando se utiliza una secuencia de tareas en System Center Configuration Manager 2007 para instalar una aplicación.

Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 949900 - Última revisión: 14 ene. 2017 - Revisión: 1

Comentarios