Experimenta un rendimiento deficiente al utilizar el protocolo SMB 2.0 para realizar operaciones relacionadas con la red, como la migración de ADMT, en equipos que ejecutan Windows Server 2008 o Windows Vista

Síntomas

Experimenta un rendimiento deficiente en un equipo que ejecuta Windows Server 2008 o Windows Vista cuando realiza operaciones relacionadas con la red. Estas operaciones relacionadas con la red incluyen al copiar un archivo compartido, mueva un archivo compartido, o utilizar la herramienta de migración para Active Directory (ADMT).

Por ejemplo, el controlador de dominio de origen o de destino está ejecutando Windows Server 2008. En este ejemplo, una migración de ADMT toma tres veces más larga que una migración entre dos controladores de dominio que ejecutan versiones anteriores de Windows versiones Server 2008.

En otro ejemplo, el origen y el destino controladores de dominio ejecutan Windows Server 2008. En este ejemplo, una migración de ADMT toma seis veces más larga que una migración entre dos controladores de dominio que están ejecutando ambas versiones anteriores a Windows versiones Server 2008.

Causa

Operaciones relacionadas con la red en Windows Vista y Windows Server 2008 se basan en Server Message Block (SMB) 2.0. Cuando un servidor SMB 2.0 recibe una solicitud que tardará mucho tiempo en procesar, el servidor procesa la solicitud de manera diferente. En este caso, el servidor envía una respuesta provisional al cliente y, a continuación, cambia el servidor al procesar la solicitud de forma asincrónica. Sin embargo, el servidor SMB 2.0 sincrónicamente espera TCP ofrecer esta respuesta provisional. Este comportamiento puede producir un retraso de 200 milisegundos por el intervalo de respuesta ACK de TCP. Por lo tanto, este retraso hace que el rendimiento deficiente mencionado en la sección "Síntomas".

Solución

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema es el se describe en este artículo. Aplicar este hotfix sólo a sistemas que experimenten el problema descrito en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.


Revisiones importantes de Windows Vista y Windows Server 2008 se incluyen en los mismos paquetes. Sin embargo, sólo uno de estos productos puede aparecer en la página "Solicitud de revisión". Para solicitar el paquete de revisiones que se aplica a Windows Vista y Windows Server 2008, seleccione el producto que aparece en la página.

Requisitos previos

Para aplicar este hotfix, el equipo debe estar ejecutando uno de los siguientes sistemas operativos:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Server 2008

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.

Para todas las versiones de x86 de Windows Vista y de Windows Server 2008
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataformaRequisito de SP
Srvnet.sys6.0.6001.2236698,81602-Feb-200903:16x86SP1
Srv2.sys6.0.6001.18206144,89602-Feb-200903:39x86SP1
Srv2.sys6.0.6001.22366144,89602-Feb-200903:16x86SP1
Para todas las versiones de x64 de Windows Vista y de Windows Server 2008
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataformaRequisito de SP
Srvnet.sys6.0.6001.22366141,31202-Feb-200903:44x64SP1
Srv2.sys6.0.6001.18206174,59202-Feb-200903:55x64SP1
Srv2.sys6.0.6001.22366174,59202-Feb-200903:44x64SP1
Para todas las versiones basadas en Itanium de Windows Server 2008
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataformaRequisito de SP
Srvnet.sys6.0.6001.22366286,20802-Feb-200902:20IA-64SP1
Srv2.sys6.0.6001.18206465,40802-Feb-200902:30IA-64SP1
Srv2.sys6.0.6001.22366465,92002-Feb-200902:20IA-64SP1

Solución alternativa

Para evitar este problema, deshabilite SMB 2.0. Para ello, siga estos pasos:

Importante: esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para una mayor protección, haga una copia de seguridad del registro antes de modificarlo. Entonces, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo hacer copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 cómo hacer copia de seguridad y restaurar el registro en Windows
  1. Haga clic en Inicio, escriba regedit en el cuadro Iniciar búsqueda y, a continuación, presione ENTRAR.
  2. Busque y, a continuación, haga clic en la subclave del registro siguiente:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
  3. En el menú Edición , seleccione Nuevo y, a continuación, haga clic en Valor DWORD.
  4. Escriba SMB2y, a continuación, presione ENTRAR.
  5. En el menú Edición , haga clic en Modificar.
  6. Escriba 0 (cero) y, a continuación, haga clic en Aceptar.
  7. Salga del Editor del Registro.
  8. Reinicie el equipo.

Nota: Si realiza el cambio del registro anterior, SMB2 basada en equipos que tenían una sesión con el servidor de archivos ya no podrá volver a establecer la sesión sobre SMB1 hasta que reinicie el equipo o reiniciar del servicio Estación de trabajo de SMB2 active.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Para obtener más información acerca de las nuevas características de red en Windows Server 2008 y Windows Vista, por ejemplo, SMB 2.0, visite el siguiente sitio Web de Microsoft:Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft


Propiedades

Id. de artículo: 950836 - Última revisión: 17 feb. 2017 - Revisión: 2

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