Un flujo de trabajo no reanuda automáticamente cuando se desencadena una actividad de retraso en Windows SharePoint Services 3.0

Síntomas

Un flujo de trabajo que se descarga cuando se desencadena una actividad delay no se reanuda automáticamente después de transcurrido el tiempo programado en Microsoft Windows SharePoint Services 3.0. El estado del flujo de trabajo que se muestra en la página de estado de flujo de trabajo de SharePoint Services sigue siendo "en"curso.

Causa

Este problema puede producirse debido a las siguientes causas:

Causa 1

La revisión que se describe en artículo de Microsoft Knowledge Base 932394 no está instalada en el equipo.

Causa 2

A veces, un flujo de trabajo descarga antes de un evento de temporizador está programado para reanudar el flujo de trabajo. Si no se ha programado un evento de temporizador, nunca se reanudará el flujo de trabajo.

Causa 3

Se produce un problema con el servicio de temporizador de SharePoint. El problema que puede comprobarse mediante otra funcionalidad del servicio de temporizador. Por ejemplo, comprobar el correo electrónico entrante para crear un elemento de lista.

Causa 4

El temporizador de SharePoint no está configurado para ejecutarse en el momento correcto. Actividad de retraso en los flujos de trabajo es procesada por el servicio de temporizador de SharePoint y reanudar flujos de trabajo según la programación del trabajo del temporizador de flujo de trabajo. De forma predeterminada, el trabajo del temporizador está configurado para ejecutarse cada 5 minutos. Por ejemplo, pueden reanudar flujos de trabajo que están configurados para reanudar en 5 minutos después de 9 minutos y 59 segundos.

Causa 5

Se sobrescribe el ensamblado de flujo de trabajo en la caché de ensamblados Global (GAC). Este problema se produce cuando se actualiza el ensamblado de flujo de trabajo, y sobrescribir un ensamblado de flujo de trabajo existente. En este caso, el proceso de temporizador utiliza la versión anterior de la definición de flujo de trabajo. No reanudar el flujo de trabajo porque se sobrescribe la versión anterior del ensamblado de flujo de trabajo y ya no existe.


Normalmente, el flujo de trabajo en la GAC se sobrescribe en las siguientes circunstancias:
  • Utilice la herramienta GACUtil para copiar el ensamblado.
  • Copie manualmente el ensamblado mediante el Explorador de Windows.
  • Utilizar Visual Studio Tools para la función de implementación de flujo de trabajo de Microsoft Office System (VSTO) que se incluye en Microsoft Visual Studio 2008.

Causa 6

El estado del flujo de trabajo que aparece en SharePoint Services sigue siendo "En curso" aunque no reanudar el flujo de trabajo.

Causa 7

  • Flujos de trabajo contienen bucles que nunca se detenga. Por ejemplo, los flujos de trabajo pueden contener bucles que no aumentan sus contadores While.
  • Actividades de Replicador en el flujo de trabajo no tienen la propiedad InitialChildData .

Solución

Solución para la causa 1

Para resolver este problema, siga estos pasos:
  1. Instale la revisión que se describe en el siguiente artículo de Microsoft Knowledge Base:
    932394 un temporizador no reanuda operación después de un flujo de trabajo se recarga en Microsoft Windows Workflow Foundation


    O bien, puede instalar Microsoft.NET Framework 3 Service Pack 1 (SP1) o la 3.5 de.NET Framework. Para obtener más información acerca del Service Pack 1 de.NET Framework 3, visite el siguiente sitio Web de Microsoft:Para obtener más información acerca de.NET Framework 3.5, visite el siguiente sitio Web de Microsoft:
  2. Restablecer Internet Information Services (IIS).
  3. Reinicie el servicio de temporizador de SharePoint.

Solución para la causa 2

Instalar la actualización de Windows SharePoint Services 3.0 que se describe en el siguiente artículo de Microsoft Knowledge Base:
953749 problemas corregidos en Windows SharePoint Services 3.0 mediante la actualización de la infraestructura de Windows SharePoint Services 3.0


La actualización de la infraestructura de Windows SharePoint Services 3.0 resuelve este problema mediante la programación de un evento de temporizador.

Solución para la causa 3

Puede utilizar los métodos siguientes para solucionar problemas relacionados con el servicio de temporizador:
  • Reinicie el servicio de temporizador de SharePoint.
  • Utilice el programa de supervisión (Taskmon.exe) de tareas para comprobar que se está ejecutando el servicio de temporizador de SharePoint (Owstimer.exe).
  • Compruebe que los archivos de registro del servicio de registro unificado (ULS) contienen entradas de error del servicio de temporizador y, a continuación, solucionarán el problema en consecuencia.
  • Asegúrese de que el programa antivirus no está causando los problemas del servicio de temporizador.

    Para obtener más información acerca de la exploración antivirus de Windows SharePoint Services 3.0 y Office SharePoint Server 2007, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

    952167 carpetas que tenga que ser excluido de la exploración antivirus cuando se utiliza un programa antivirus de nivel de archivo en Windows SharePoint Services 3.0 o en SharePoint Server 2007

Solución para la causa 4

Para evitar este problema, ejecute el siguiente comando para establecer el intervalo correcto para el trabajo del temporizador de flujo de trabajo y, a continuación, reinicie el servicio de temporizador de SharePoint:
Stsadm – o setproperty – pn trabajo workflow: pv intervalo para ejecutar el trabajo del temporizador de flujo de trabajo

Solución para la causa 5

Reinicie el servicio de temporizador de SharePoint.

Nota: Esta resolución aplica a recién sólo instancias de flujo de trabajo creado. No puede corregir las instancias de flujo de trabajo existente que ya se ven afectadas. Puede utilizar un número de versión para cada ensamblado que se crea para realizar un seguimiento de las instancias de flujo de trabajo nuevos y antiguos.

Solución para la causa 6

Compruebe los archivos de registro del servicio de registro unificado (ULS) mensajes de error y, a continuación, resuelve el problema en consecuencia. Normalmente, este problema se produce si el flujo de trabajo no controla una excepción y se bloquea.

Solución para la causa 7

Comprobar problemas de construcción de bucle en definiciones de flujo de trabajo. Asegúrese de que la propiedad InitialChildData en actividades de Replicator está enlazada a un objeto de datos.
Propiedades

Id. de artículo: 953630 - Última revisión: 14 ene. 2017 - Revisión: 1

Comentarios