La herramienta Administrador de servicios ConfigMgr en Configuration Manager 2007 Service Pack 1 no puede consultar el servicio SMS_SITE_SQL_BACKUP y recibirá un mensaje de error "Error de comunicación con el componente"

Síntomas

Imagine el siguiente escenario:
  • Instalar un sitio de Microsoft System Center Configuration Manager 2007 Service Pack 1 (SP1) que se utiliza una instalación de clúster de Microsoft SQL Server o una instalación de SQL Server remota.
  • Abra la herramienta Administrador de servicios ConfigMgr.
  • Haga el servicio SMS_SITE_SQL_BACKUP para consultar su estado.
En este escenario, no se puede consultar su estado, y recibirá el siguiente mensaje de error:
Error al comunicarse con el componente

Causa

Cuando SQL Server no está instalado en el servidor del sitio, el nombre de equipo del servidor del sitio se anexa al nombre del servicio de copia de seguridad de SQL Server. Por lo tanto, el nombre real del servicio es "SMS_SITE_SQL_BACKUP_The-name-of-the-Site-Server" en lugar de "SMS_SITE_SQL_BACKUP."

La herramienta Administrador de servicios ConfigMgr consulta el nombre del servicio mediante Windows Management Instrumentation (WMI). El proveedor de Component Manager (Cmprov.dll) devuelve SMS_SITE_SQL_BACKUP como nombre de servicio. Este nombre no coincide con el nombre real de copia de seguridad de servicio de SQL Server en el servidor de base de datos de sitio remoto.

Solución

Información de Service Pack

Para resolver este problema, obtenga el service pack más reciente para Microsoft System Center Configuration Manager 2007, disponible en este sitio web de Microsoft: http://www.microsoft.com/downloads/details.aspx?FamilyID=3318741a-c038-4ab1-852a-e9c13f8a8140
Para obtener una lista de problemas resueltos en este service pack, haga clic en el número de artículo siguiente en Microsoft Knowledgebase:
971348 lista de revisiones y actualizaciones contenidas en System Center Configuration Manager 2007 Service Pack 2

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Configuration Manager 2007 Service Pack 1 instalado para poder aplicar este hotfix debe tener.

Requisito de reinicio

No es necesario que reinicie el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Este hotfix no sustituye a otras revisiones.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Cmprov.dll4.0.6221.112567,58430-Nov-200821:00x86

Nota: Esta información de atributo de archivo se aplica a sistemas basados en x86, sistemas basados en x64, International cliente Pack 1 y 2 de paquete de cliente internacional.


Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Utilice el Administrador de servicios para servicios de control de Configuration Manager 2007. En el Administrador de servicios, puede ver el estado de todos los servicios de Configuration Manager 2007 o subprocesos que se ejecutan en cualquier sistema del sitio. (Estos servicios y subprocesos se conocen colectivamente como componentes de Configuration Manager 2007.) Los componentes se administran exactamente como administrar servicios de Windows. Puede iniciar, detener, pausar, reanudar o consultar componentes de Configuration Manager 2007.

Para abrir el Administrador de servicios de Configuration Manager, siga estos pasos:
  1. En la consola de Configuration Manager, expanda System Center Configuration Manager, expanda Site Database, expanda Herramientasy, a continuación, expanda ConfigMgr Service Manager.
  2. Haga clic en Administrador de servicios de Configuration Managery, a continuación, haga clic en Iniciar Administrador de servicios ConfigMgr.
Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 957879 - Última revisión: 14 ene. 2017 - Revisión: 1

Comentarios