El proceso de actualización de flujo de trabajo tarda mucho tiempo al actualizar Microsoft Dynamics CRM 3.0 a Microsoft Dynamics CRM 4.0

Síntomas

Al actualizar Microsoft Dynamics CRM 3.0 a Microsoft Dynamics CRM 4.0, el proceso de actualización tarda mucho tiempo en completarse.

Causa

Este problema se produce cuando la tabla WFProcessInstance contiene muchas instancias de flujo de trabajo.

Solución

Hay una actualización del programa de instalación de Microsoft. Cuando instala Microsoft Dynamics CRM 4.0, o cuando actualiza a Microsoft Dynamics CRM 4.0, puede comprobar las actualizaciones de instalación. Si selecciona la opción para comprobar si hay actualizaciones del programa de instalación, la aplicación descarga las nuevas actualizaciones de configuración y aplica las actualizaciones de instalación para la instalación mientras se ejecuta el proceso de instalación.

Información sobre la instalación

Para obtener esta revisión, utilice la opción actualizar archivos de instalación durante la instalación de Microsoft Dynamics CRM 4.0. Para obtener más información acerca de cómo utilizar la opción actualizar archivos de instalación o descargar manualmente la actualización de la instalación, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

948917 cómo obtener actualizaciones para Microsoft Dynamics CRM 4.0

Requisitos previos

No hay requisitos previos.

Información de eliminación

No se puede quitar la actualización de la instalación.

Solución alternativa

Para evitar este problema, actualice la instalación de Microsoft Dynamics CRM 4.0 mediante la funcionalidad de configuración de resolución automática de problemas. Antes de ejecutar la aplicación de actualización, cambiar las claves del registro siguientes en el registro del servidor de Microsoft Dynamics CRM 3.0.

Advertencia: pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o mediante cualquier otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar que estos problemas puedan resolverse. Modifique el registro bajo su propio riesgo.
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM\WorkflowUpgradeThreadCount

    Establezca el valor REG_DWORD en 1.

    Notas:
    • Puede introducir cualquier número decimal mayor o igual a 1 en esta entrada del registro.
    • El número máximo sugerido de subprocesos se debe calcular en función del número de procesadores en el servidor de Microsoft Dynamics CRM 3.0 horas 2. Por ejemplo, si el servidor de Microsoft Dynamics CRM tiene dos procesadores, el número máximo de subprocesos debe ser 4.
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM\WorkflowUpgradeTimeout

    Establezca el valor REG_DWORD a 15.

    Notas:
    • El valor de esta entrada del registro representa el intervalo de tiempo en minutos que un subproceso debe esperar antes de actualizar el flujo de trabajo.
    • Si el flujo de trabajo tarda más en Actualizar que el valor especificado en esta entrada del registro, se producirá un error en el flujo de trabajo y se procesará el siguiente flujo de trabajo.
    • Si el intervalo de tiempo en el que se establece en esta entrada del registro es demasiado corto, muchos flujos de trabajo no pueden actualizarse.
    • Si el valor en el campo WorkflowUpgradeTimeout es demasiado largo, los tiempos de espera se producirán con mayor frecuencia. El número de tiempos de espera puede variar en función de los recursos que están disponibles en el servidor de Microsoft Dynamics CRM. Estos recursos pueden ser ciclos de RAM o ciclos de CPU.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft
Para obtener más información acerca de terminología del paquete de revisión y actualización de software Microsoft Business Solutions CRM, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

887283 paquete de actualizaciones y revisiones de software de Microsoft Business Solutions CRM estándares de nomenclatura

Propiedades

Id. de artículo: 958039 - Última revisión: 14 ene. 2017 - Revisión: 1

Comentarios