Se produce un error en la autenticación de Kerberos junto con el código de error 0X80090302 o 0x8009030f en un equipo que ejecuta Windows Server 2008 o Windows Vista cuando se utiliza el algoritmo AES

Síntomas

Imagine el siguiente escenario:
  • Tiene dos equipos que ejecutan Windows Server 2008 o Windows Vista. Un equipo envía un mensaje de autenticación Kerberos al otro equipo.
  • La autenticación Kerberos utiliza el algoritmo estándar de cifrado avanzado (AES) para cifrar y descifrar los datos de autenticación.
En este escenario, se produce un error en la autenticación Kerberos junto con el código de error 0X80090302 o 0x8009030f y recibirá un mensaje de error. Sin embargo, el mensaje de error que aparece puede variar para diferentes aplicaciones. Por ejemplo, si intenta conectarse a SQL Server 2005 o SQL Server 2008 Analysis Services con Excel, recibirá uno de los siguientes mensajes de error:

Mensaje 1
No se admite la función solicitada
Mensaje 2
Se ha modificado el mensaje o firma proporcionados para comprobación

Causa

La función SpSealMessage y la función SpUnsealMessage no cifrar y descifrar los mensajes de autenticación correctamente cuando el tamaño del mensaje no es divisible por el tamaño del bloque esperado.

Solución

Información de la revisión

Importante: Al hacer clic en el vínculo "descargas de vista y la solicitud de revisión", Windows Vista será el único producto que se muestra. Sin embargo, la revisión para Windows Vista se aplica a Windows Vista y Windows Server 2008.

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.


Revisiones importantes de Windows Vista y Windows Server 2008 se incluyen en los mismos paquetes. Sin embargo, sólo uno de estos productos puede aparecer en la página "Solicitud de revisión". Para solicitar el paquete de revisiones que se aplica a Windows Vista y Windows Server 2008, seleccione el producto que aparece en la página.

Requisitos previos

Para aplicar este hotfix, el equipo debe estar ejecutando uno de los siguientes sistemas operativos:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Ámbito de la instalación de la revisión

La revisión debe instalarse en el cliente y el servidor de la conexión. Si muchos clientes están afectados, sería práctico para implementar la revisión en todos los sistemas de Server 2008 y Windows Vista en la empresa.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.

Para todas las versiones de x86 de Windows Vista y de Windows Server 2008
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Kerberos.dll6.0.6001.22435500,73618-May-200913:49x86
Kerberos.dll6.0.6002.22138500,73618-May-200913:44x86
Para todas las versiones de x64 de Windows Vista y de Windows Server 2008
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataformaRequisito de SPTipo de servicio
Kerberos.dll6.0.6001.22435657,92018-May-200914:04x64SP1No aplicable
Kerberos.dll6.0.6001.22435500,73618-May-200913:49x86SP1WOW
Kerberos.dll6.0.6002.22138657,92018-May-200913:45x64SP2No aplicable
Kerberos.dll6.0.6002.22138500,73618-May-200913:44x86SP2WOW

Solución alternativa

Para solucionar el problema, utilice la autenticación NTLM en lugar de la autenticación Kerberos.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Para obtener más información acerca de la función SpSealMessage , visite el siguiente sitio Web de Microsoft:Para obtener más información acerca de la función SpUnsealMessage , visite el siguiente sitio Web de Microsoft:Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft


Propiedades

Id. de artículo: 969083 - Última revisión: 13 ene. 2017 - Revisión: 1

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