No se puede imprimir o ver la vista preliminar de una página Web en Internet Explorer

Se aplica a: Windows 7 EnterpriseWindows Vista BusinessWindows Vista Business 64-bit edition Más

Síntomas


Cuando intenta imprimir o ver la vista preliminar de una página Web en Internet Explorer, la página Web puede no imprimir o vista preliminar correctamente y puede recibir un error de secuencia de comandos.

Causa


Este problema puede ocurrir por uno o varios de los siguientes escenarios:
Escenario 1: Su tarjeta de vídeo o el controlador de vídeo está dañado o anticuado. Nota: Controladores de impresora anticuados o dañados también pueden provocar errores de secuencia de comandos al imprimir desde Internet Explorer escenario 2: puede que no tenga permisos de impresora asignadosescenario 3: modo protegido está habilitado para la zona de seguridad de Internet de la web páginaescenario 4: hay un problema con carpetas temporales en su cuenta de usuario y se ha eliminado la carpeta en la ubicación % TEMP % baja

Resolución


Para resolver este problema, utilice los métodos siguientes en el orden en que se presentan. Si el método 1 no resuelve el problema, pase al método siguiente.

Método 1: Solucionar problemas con la impresora y actualice los controladores a la versión más reciente

Vaya el siguiente tutorial para ayudar a identificar y corregir problemas comunes de la impresora en Windows:Problemas de impresora en WindowsControladores de impresora anticuado puede provocar problemas al imprimir desde Internet Explorer, pruebe a actualizar en el controlador de impresora más reciente para su impresora, para ello, haga clic en el vínculo específico para su versión de Windows y siga los pasos en el que artículo:Buscar e instalar a controladores de impresora en Windows 7Buscar e instalar a controladores de impresora en Windows VistaImportante: en algunos casos, una versión actualizada del controlador no esté disponible a través de Windows Update. Puede ser necesario ir al sitio Web del fabricante y buscar, descargar e instalar al controlador de impresora más reciente para su impresora.Si actualizar el controlador de impresora no se soluciona el problema, pase al método 2.

Método 2: Intente imprimir una página Web que ejecuta Internet Explorer como administrador

Intente imprimir una página web cuando se ejecuta Internet Explorer como administrador; Esto puede ayudar a determinar si hay un problema de permisos.
Nota: Debe utilizar una cuenta que tenga permisos de administrador para cambiar el tipo de cuenta de estándar a Administor.Para iniciar Internet Explorer como administrador, siga estos pasos:
  1. Cierre todas las ventanas de Internet Explorer.
  2. Haga clic en Inicio, seleccione Todos los programas, haga clic en Internet Explorer y seleccione Ejecutar como administrador.
  3. Visita un sitio Web e inténtelo de prueba al imprimir una página mientras se está ejecutando como administrador.
Si imprime una página Web que ejecuta Internet Explorer como administrador no soluciona el problema, pase al método 3.

Método 3: Pruebe a imprimir después de deshabilitar modo protegido

Intente imprimir una página Web después de deshabilitar el modo protegido, para ello, siga estos pasos:
  1. Haga clic en el icono de Herramientas en Internet Explorer
  2. Haga clic en la ficha seguridad y desactive la casilla de verificación junto a Habilitar modo protegido (requiere reiniciar Internet Explorer)
  3. Haga clic en Aplicar y, a continuación, haga clic en Aceptar.
  4. Cierre todas las ventanas abiertas de Internet Explorer y, a continuación, reinicie Internet Explorer.
  5. Visita un sitio Web e inténtelo de prueba al imprimir una página mientras se está ejecutando como administrador.
Si al deshabilitar el modo protegido, no resuelve el problema, continúe con el método 4.
Si este método no resuelve el problema, vaya al método siguiente.
 

Más información

Para problemas de impresión específicos de fabricante de la impresora determinada, haga clic en el vínculo asociado con el fabricante:Este problema puede producirse con algunas impresoras Canon cuando haya un determinados controlador de impresora Canon instalado. Para obtener más información, visite el siguiente Website Microsoft:Para obtener ayuda con las impresoras Canon, visite el siguiente sitio Web de Canon:Tutorial de solución de problemas de impresora:Para que ver un tutorial paso a paso para ayudarle a identificar y corregir problemas comunes de impresora, visite el siguiente Website Microsoft:Para solucionar errores de secuencia de comandos al intentar imprimir una página Web en Internet Explorer, visite el siguiente Website Microsoft:Para analizar y corregir impresión problemas y errores de impresión automáticamente, visitan el siguiente Website Microsoft: