Un recurso de disco físico permanece en el estado de "Conexión pendiente", o la utilidad Chkdsk automáticamente comienza a ejecutarse en un servidor que ejecuta Windows Server 2008

Síntomas

Al poner en conexión un recurso de disco físico en un servidor que ejecuta Windows Server 2008, puede experimentar alguno de los síntomas siguientes:

Síntoma 1

Al ver el recurso de disco físico en el complemento Administración de clúster de conmutación por error, el recurso puede mostrar el estado de Conexión pendiente. Además, el mensaje de error siguiente se graba en el registro del sistema:
Nombre de registro: sistema

Fuente: Microsoft-Windows-FailoverClustering

Id. de suceso: 1066

Categoría de tarea: Recurso de disco físico de

Nivel: advertencia

Descripción:

Recurso de disco del clúster 'Disco de clúster 3' indica la corrupción del volumen ' \\?\Volume{ec2fa15d-b438-11de-88bc-00155dd99d36}'. Se ejecuta Chkdsk para reparar los problemas. El disco no estará disponible hasta que termine de Chkdsk. Salida de CHKDSK se registrarán en el archivo 'C:\Windows\Cluster\Reports\ChkDsk_ResCluster disco 3_Disk2Part1.log'.

Chkdsk también puede escribir información en el registro de sucesos de aplicación.
Además, el mensaje de error siguiente se graba en el registro de clúster:
Disco físico de ERR [RES] < disco de clúster 3 >: VerifyFS: error al abrir el archivo \\?\GLOBALROOT\Device\Harddisk2\Partition1\TextDocument.txt Error: 5.

Síntoma 2

Al ver el recurso de disco físico en la utilidad Administrador de clústeres de Microsoft, puede experimentar uno o varios de los síntomas siguientes:
  • El recurso no puede conectarse, o puede provenir en línea después de un breve retraso.
  • La utilidad Chkdsk junto con el modificador/f automáticamente comienza a ejecutarse en el disco duro compartido.
  • Id. de suceso 1066 que tenga una descripción similar a la siguiente aparece en el registro del sistema del Visor de sucesos:
    Recurso Y: de disco de clúster: está dañado. Ejecute ChkDsk /F para reparar problemas.

Causa

Estos problemas se producen por una de las razones siguientes.

Causa del síntoma 1

Este problema se produce porque un archivo de sólo lectura se encuentra en el directorio raíz del recurso. Cuando se conecta un recurso de disco físico compartido, el servicio de Cluster Server enumera los archivos del directorio raíz e intenta abrir cada archivo junto con acceso total. Este comportamiento se produce para asegurarse de que el sistema de archivos es coherente y que el volumen no está dañado. Si alguno de los archivos son de sólo lectura en el directorio raíz del recurso, se considera el volumen dañado y Chkdsk se ha iniciado. Para evitar este problema, utilice la solución que se menciona en la sección "Solución 1".

Causa del síntoma 2

Este problema se produce porque el indicador "sucio" del volumen está establecido. Cuando se conecta un recurso de disco físico compartido, el servicio de Cluster Server enumera los archivos del directorio raíz e intenta abrir cada archivo junto con acceso total. Este comportamiento se produce para asegurarse de que el sistema de archivos es coherente y que el volumen no está dañado. Si alguno de los archivos tienen la marca "sucia" establecida en el directorio raíz del recurso, se considera el volumen dañado y Chkdsk se ha iniciado. Para evitar este problema, utilice la solución que se menciona en la sección "Solución 2".

Solución alternativa

Solución 1

Para evitar este problema, siga uno de estos procedimientos:
  • Desactive el atributo de sólo lectura de los archivos mediante las propiedades del archivo o mediante el comando attrib - r en el símbolo.
  • Mueva los archivos que tienen el atributo de sólo lectura desde el directorio raíz del recurso a una subcarpeta adecuada.

Nota: Si no puede poner el disco en línea y realizar cualquier comprobación adicional en los archivos, establezca la propiedad privada del disco físico DiskRunChkDsk a una propiedad de 4 (ChkDskDontRun). Esto deshabilitará comprobaciones de montaje de volumen. Para obtener más información, consulte:

No se puede poner en línea el disco compartido de clúster de Windows Server 2008
http://support.microsoft.com/kb/2517696


Solución 2

Para evitar este problema, determine primero si se ha establecido el indicador "sucio" para el volumen especificado.

Para determinar si se ha establecido el indicador "sucio" para el volumen en Windows Server 2008, utilice la herramienta Chkntfs.

Para obtener más información acerca de la herramienta de Chkntfs, visite el siguiente sitio Web de Microsoft TechNet:Para determinar si se ha establecido el indicador "sucio" para el volumen en Windows Server 2008 R2, utilice el validar un asistente de configuración.

Para obtener más información acerca de la configuración del Asistente para validar una, visite el siguiente sitio Web de Microsoft TechNet:Si se establece el indicador "sucio" para el volumen, ejecute el programa Chkdsk junto con el modificador/f.

Para obtener más información acerca de la utilidad Chkdsk, visite el siguiente sitio Web de Microsoft TechNet:

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".
Propiedades

Id. de artículo: 977516 - Última revisión: 13 ene. 2017 - Revisión: 1

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