Mensaje de error cuando instala el paquete de actualización de base de datos de Office Communications Server 2007 R2 con fecha de julio de 2009: "Error 1722"

Síntomas

Cuando intenta instalar el paquete de actualización de la base de datos de Microsoft Office Communications Server 2007 R2 es decir con fecha de julio de 2009, se produce un error en la instalación. Además, recibirá el siguiente mensaje de error:

Producto: Microsoft Office Communications Server 2007 R2 (KB969834)--Error 1722. Hay un problema con este paquete de Windows Installer. Un programa ejecutado como parte de la instalación no ha finalizado como se esperaba. Póngase en contacto con el personal de soporte técnico para el proveedor de paquete. Acción CA_DBUpdateSE, ubicación: unidad: \Program Files\Common de programa\Microsoft Office Communications Server 2007 R2\DBSetupQfe\, comando: Drive:\Windows\SysWOW64\cscript.exe dbqfeupdate.wsf/role: se


El siguiente mensaje de error también se registra en el registro de QFE_DBSetup:

Actualizar base de datos de servidor SE los procedimientos almacenados. Esto le llevará un tiempo...
cscript dbsetup.wsf /SqlServer: (local) \rtc /Verbose/role: se

Microsoft (R) Windows Script Host versión 5.7
Copyright (C) Microsoft Corporation. Reservados todos los derechos.

Conectarse a SQL Server en (local) \rtc
SqlMajorVersion: 9
SqlMinorVersion: 00
SqlBuildNo: 3042
Validación de SQL: Reconfigure no encontró errores y versión SQL es aceptable: 9.00.3042.00
Abiertos de la base de datos rtc
Versión de esquema de base de datos es 37
Versión del procedimiento almacenado de base de datos es 70
Versión de DB qfe es 2
(Actualización importante de la base de datos necesario).

Esta base de datos contiene una versión más reciente de Qfe y, por tanto, no se puede volver a utilizarse. Debe quitarse y crea uno nuevo si es necesario.

Para conservar los datos, debe utilizar la solución de restauración e importación y exportación de copia de seguridad de este producto. Examine la documentación del producto para obtener instrucciones.


Además, se produce un error en el componente de servicios del usuario en el servidor font-end Office Communications Server 2007 R2 o en el servidor de Office Communications Server 2007 R2 Standard Edition que se conectan a la base de datos back-end. Cuando se produce este comportamiento, recibirá el siguiente mensaje de error:

Error de inicio de sesión para usuario 'Contoso\RTCService'. [Cliente: < local machine >]

------------------------

No se pudo conectar a la base de datos back-end. Office Communications Server continuamente intentará volver a conectar con el servidor back-end. Mientras esta condición persiste, los mensajes entrantes recibirá respuestas de error.

Back-end Server: base de datos (local) \rtc: la cadena de conexión rtc:
Driver = {SQL Native Client}; Trusted_Connection = yes; Traducir = no; server = (local) \rtc;database=rtc;network=dbmslpcn;

Causa: Posibles problemas con la base de datos back-end.
Solución:

Asegurarse de que funciona correctamente el back-end.

------------------------

No se pudo procesar las solicitudes de estado de conferencia. Este error podría retrasar la liberación de reunión PSTN ids en directorios de conferencia alojados en este grupo.

Código de error: 0x800407D0

Causa: Posible problemas con back-end o la salud de Office Communications Server.
Solución:
Asegúrese de que el servicio de Office Communications Server está en buenas condiciones.

Causa

Este problema se produce cuando se instala el paquete de actualización de base de datos de Office Communications Server 2007 R2 con fecha de enero de 2010, antes de instalar el paquete de actualización de base de datos de Office Communications Server 2007 R2 con fecha de julio de 2009.

Solución alternativa

Cuando se produce este problema, se establece el nivel de la configuración de Restringir el acceso de la base de datos RTC y de la base de datos de RTCDyn en RESTRICTED_USER. Cuando se establece el nivel RESTRICTED_USER, fallan las conexiones de base de datos. Para evitar este problema, siga estos pasos:
  • Conectarse a Microsoft SQL Server.
  • Cerrar todas las conexiones a bases de datos RTC y a bases de datos de RTCDyn.
  • Establecer el nivel de la opción de Restringir el acceso para las bases de datos RTC y para las bases de datos de RTCDyn a MULTI_USER.
  • Reinicie el proceso del servicio RTCSRV en el servidor front-end.
Propiedades

Id. de artículo: 978377 - Última revisión: 13 ene. 2017 - Revisión: 1

Comentarios