Conexiones TCP fallan intermitentemente cuando ambos extremos están en el mismo equipo en Windows Server 2003 SP2

Síntomas

Imagine el siguiente escenario:
  • Actualizar la versión del controlador Tcpip.sys para la 5.2.3790.4531 versión o una versión posterior en un equipo que ejecuta Windows Server 2003 Service Pack 2 (SP2).
  • Crear una conexión TCP en el equipo. Ambos extremos de esta conexión se encuentran en el mismo equipo. Por ejemplo, realizar una conexión TCP con el host local.

En este escenario, la aplicación o servicio que crea la conexión TCP que encuentre un fallo de la función u otra excepción intermitentemente. Además, al ejecutar el comando netstat-ano después de producirse el problema, el resultado de este comando indica que muchas conexiones permanecen en estado LAST_ACK , en el estado FIN_WAIT_2 o en estado de cierre hasta que se reinicie el equipo.

Causa

Este problema se produce debido a una condición de anticipación en el controlador de TCP/IP (Tcpip.sys). Cuando se produce la condición de carrera, no se envía la notificación de desconexión en el momento oportuno. Este comportamiento huérfanos algunas conexiones TCP. Por lo tanto, las aplicaciones o servicios que se basan en estas conexiones no. Además, estas conexiones permanecen en estado LAST_ACK , en el estado FIN_WAIT_2 o en estado de cierre .

Solución

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar esta revisión, el equipo debe ejecutar Windows Server 2003 Service Pack 2 (SP2).

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Esta revisión no sustituye a ninguna revisión publicada previamente.

Información de archivo

La versión en inglés (Estados Unidos) de esta revisión instala archivos que tienen los atributos enumerados en las tablas siguientes. Las fechas y las horas de estos archivos se muestran en la hora Universal coordinada (UTC). Las fechas y las horas de estos archivos en el equipo local se muestran en horario local junto con la diferencia de horario de verano (DST) actual. Además, las fechas y las horas pueden cambiar cuando realiza determinadas operaciones en los archivos.
Notas sobre la información de archivo de Windows Server 2003
  • Además de los archivos que se muestran en estas tablas, esta revisión también instala un archivo de catálogo de seguridad asociado (KBnúmero.cat) que está firmado con una firma digital de Microsoft.
Para todas las versiones basadas en x86 compatibles de Windows Server 2003
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataformaRequisito de SP
Tcpip.sys5.2.3790.4681400,89618-Mar-201017:57x86SP2
W03a3409.dll5.2.3790.459043,52016-Sep-200912:16x86SP2
Para todas las versiones basadas en x64 compatibles de Windows Server 2003
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataformaRequisito de SPTipo de servicio
Tcpip.sys5.2.3790.4681798,72018-Mar-201017:57x64SP2No aplicable
W03a3409.dll5.2.3790.459044,03218-Mar-201017:57x64SP2No aplicable
Ww03a3409.dll5.2.3790.459043,52018-Mar-201017:57x86SP2WOW
Para todas las versiones basadas en IA-64 compatibles de Windows Server 2003
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataformaRequisito de SPTipo de servicio
Tcpip.sys5.2.3790.46811,336,83218-Mar-201017:57IA-64SP2No aplicable
W03a3409.dll5.2.3790.459042,49618-Mar-201017:57IA-64SP2No aplicable
Ww03a3409.dll5.2.3790.459043,52018-Mar-201017:57x86SP2WOW

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

971383 la pérdida de datos se produce cuando la función de "recepción" de Winsock devuelve 0 bytes si el cliente y el servidor de aplicaciones se ejecutan en el mismo equipo que está ejecutando Windows Server 2003

Propiedades

Id. de artículo: 979230 - Última revisión: 13 ene. 2017 - Revisión: 1

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