Un servidor terminal server basado en Windows Server 2003 deja de responder después de muchos usuarios de sesión y registro de apagado de él

Síntomas

Tiene un servidor de terminal server que ejecuta Windows Server 2003. Muchos usuarios inicien sesión o cierre de sesión del servidor terminal Server con frecuencia. Una vez que se ejecuta en el servidor terminal server durante algún tiempo, todo terminal server deja de responder. Por lo tanto, no se puede crear una sesión de terminal server en el servidor terminal server ya. Además, puede anotarse el siguiente suceso en el registro de sistema: If que analizar el archivo de volcado de memoria que se captura cuando se produce el problema, verá que se ha agotado el recurso de grupo de bloque paginado del sistema. Además, encontrará que la mayoría de los bloques paginados pool es utilizado por el bloque de memoria que tiene la etiqueta "DrDr".

Causa

Este problema se produce debido a un problema de temporización en el redirector de dispositivos de protocolo de escritorio remoto (RDP) de Microsoft (Rdpdr.sys). Cuando se produce el problema de sincronización, un paquete de solicitud de E/S (IRP) se abandona incorrectamente el controlador Rdpdr.sys. Este comportamiento hace que algunos memoria asignada del bloque paginado no de liberarse. Después de un tiempo, se ha agotado el recurso de bloque paginado. Por lo tanto, experimenta el escenario que se menciona en la sección "Síntomas".

Solución

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar esta revisión, debe ejecutar Windows Server 2003 Service Pack 2 (SP2) en el equipo.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Esta revisión no sustituye a ninguna revisión publicada previamente.

Información de archivo

La versión global de (Estados Unidos) de esta revisión instala archivos que tienen los atributos enumerados en las tablas siguientes. Las fechas y las horas de estos archivos se muestran en la hora Universal coordinada (UTC). Las fechas y las horas de estos archivos en el equipo local se muestran en horario local junto con la diferencia de horario de verano (DST) actual. Además, las fechas y las horas pueden cambiar cuando realiza determinadas operaciones en los archivos.
Notas sobre la información de archivo de Windows Server 2003
  • Además de los archivos que se muestran en estas tablas, esta revisión también instala un archivo de catálogo de seguridad asociado (KBnúmero.cat) que está firmado con una firma digital de Microsoft.
Para todas las versiones basadas en x86 compatibles de Windows Server 2003
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Rdpdr.sys5.2.3790.4683201,21622-Mar-201015:21x86
Para todas las versiones basadas en x64 compatibles de Windows Server 2003
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Rdpdr.sys5.2.3790.4683333.31223-Mar-201004:32x64
Para todas las versiones basadas en IA-64 compatibles de Windows Server 2003
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Rdpdr.sys5.2.3790.4683641,53623-Mar-201004:32IA-64

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 979522 - Última revisión: 13 ene. 2017 - Revisión: 1

Comentarios