WD97: Qué hacer si tiene un Virus de Macro

IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.

Haga clic aquí para ver el artículo original (en inglés): 181079
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Síntomas
Se ha descubierto el primer virus de macro en el verano de 1995. Desde el tiempo, han aparecido otros virus de macro. En este artículo se describe qué a doif cree que puede que tenga un virus de macro de Word, o si desea garantizar sus documentos se infecten con uno.

Los siguientes son algunos de los síntomas de un virus de macro de Word que son conocido toaffect Word y documentos de Word:

  • Al intentar guardar un documento, Word sólo permite guardar el documento como una plantilla.
    - o -
  • El icono del archivo parece una plantilla en lugar de un documento.
    - o -
  • Al abrir un documento, aparece un cuadro de diálogo que muestra el número 1.
    - o -
  • Ya no se muestran los comandos de Macro y personalizar en el menú Herramientas.
    - o -
  • Aparecen nuevas macros en la lista de macros. También pueden aparecer las macros AutoOpen y FileSaveAs; Si ya tenía macros con estos nombres, su contenido puede cambiar por el virus de macro.
    - o -
  • Mensajes extraños o inesperados aparecen cuando se abre un documento de Word o plantilla.
Notas:

  • En Word 97, hay una opción de protección antivirus en macros (en el menú Herramientas, haga clic en Opciones y haga clic en la ficha General) diseñados para alertarle si abre un archivo que contiene macros, independientemente de lo que hagan las macros. Para una solución permanente, debe utilizar software antivirus que está diseñado específicamente para detectar y evitar virus de macro.

  • Word no busca ni quitar los virus de macro de documentos y plantillas existentes. Simplemente le avisará si el documento que está abriendo contiene macros. La advertencia le permite abrir el documento con las macros activas o abrirlo con las macros deshabilitadas. No debe abrir un documento con las macros activas a menos que esté absolutamente seguro de que el documento no contiene ningún virus de macros dañinos.
Para obtener una solución a largo plazo a los virus de macro, información de instalación antivirus está diseñado específicamente para detectar virus de macros. Para obtener información adicional acerca de otros proveedores de software antivirus, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
49500 Lista de proveedores de Software Antivirus
Solución
Utilice las siguientes soluciones como soluciones provisionales sólo.

Método 1: Presione la tecla MAYÚS cuando abre un archivo

Si no tiene alguno de los síntomas descritos en este artículo, pero no desee noes se vean afectados por un virus de macro, mantenga presionada la tecla MAYÚS de cuando abre un archivo que puede verse afectado por un virus de macro. Al presionar SHIFTwill impedir que las macros automáticas se ejecuta; Si hay un virus de macro, no se cargará.

Método 2: Eliminar la Macro y recuperar el documento

Si experimenta los síntomas descritos en este artículo, o Si sospechas que tiene un virus de macro que no se describen aquí, utilice los pasos siguientes para quitar las macros infectadas y affecteddocuments correcta. (Recuerde que esto es sólo una solución temporal, porque se crean newmacros, estos pasos no funcionen):

  1. Cierre Word y cambie el nombre del archivo Normal.dot a nombre.dot.
  2. Haga una copia de la copia de seguridad de un archivo infectado.
  3. Abra Word y en el menú archivo, haga clic en Abrir.
  4. Desplácese hasta la carpeta que contiene el archivo afectado.
  5. Haga clic para seleccionar el archivo infectado.
  6. Presione y mantenga presionada la tecla MAYÚS y haga clic en Abrir.

    Siga manteniendo la tecla MAYÚS hasta que el archivo infectado se abra en Word.

    Nota: mantenga la tecla MAYÚS mientras abre un archivo evita que cualquier macro automática de palabras ejecución.
  7. Para quitar virus sospechosos que contienen macros, siga este procedimiento:
    1. En el menú Herramientas, señale Macro y, a continuación, haga clic en Macros.
    2. En la lista Macros en, haga clic en todas las plantillas activas y documentos.
    3. Seleccione la macro sospechosa y haga clic en eliminar. Haga clic en Sí cuando se le pregunte si desea eliminar la macro.
    4. Repita el paso c para todas las macros sospechosas.
    5. Haga clic en Cancel o en x para cerrar el cuadro de diálogo Macros.
  8. Para recuperar el texto de un documento infectado:
    1. Seleccione todo el documento presionando CTRL+E, o haciendo clic en Seleccionar todo en el menú Edición.
    2. Eliminar última marca de párrafo del documento de la selección, presione Mayús + flecha izquierda.
    3. En el menú Edición, haga clic en copiar.
    4. En el menú archivo, haga clic en nuevo. Seleccione la plantilla que desee utilizar y haga clic en Aceptar.
    5. En el menú Edición, haga clic en Pegar.
    6. Repita el paso 7 para asegurarse de que no han replicado nuevo virus que contiene macros.
    7. Guarde el documento.
  9. Repita estos pasos para cualquier sospecha de documento de que contiene un virus de macro.
Nota: si este método no funciona, pruebe el método 3.

Método 3: Usar el Organizador para limpiar temporalmente los virus de macro

Utilice el Organizador para limpiar los virus de macro. Tenga en cuenta que si se han abierto otros archivos después del archivo infectado, más probable es que se infectado.

Para quitar el virus de la plantilla Normal:

  1. Cierre todos los documentos. Si un documento infectado está abierto, puede volver a infectar fácilmente Normal.dot.
  2. En el menú Herramientas, haga clic en plantillas y complementos y haga clic en el botón organizador.
  3. Seleccione la ficha elementos del proyecto Macro y cambiar el nombre o eliminar todas las macros siguientes:
    NewMacros
    Cierre automático
    AutoExec
    AutoOpen
    FileExit
    FileNew
    FileOpen
    (Save As)
    FileSaveAs
    Macros
    ToolsMacro
  4. Haga clic en Cerrar.
  5. Presione la tecla MAYÚS y, en el menú archivo, haga clic en Guardar todo para guardar la plantilla.
Para quitar el virus de los documentos infectados:

Si un archivo está infectado, utilice el mismo método que anteriormente, pero quitar el macrosfrom la plantilla Normal y también de la document(template) infectado en el organizador. Cuando haya terminado, presione MAYÚS y en el menú archivo y haga clic en Guardar todo y continuar con el siguiente archivo. Mantener inmind que cada vez que abra un archivo infectado, éste infectará su Normaltemplate, por lo que constantemente es necesario quitar las macros de la plantilla Normal.

Método 4: Insertar en un documento nuevo

Con este método, deberá cambiar el nombre de Normal.dot y, a continuación, en el menú theInsert, haga clic en archivo para quitar temporalmente las macros. Este isparticularly método útil con los virus de macro denominados "CAP", lo que elimina la macro personalizar en el menú Herramientas.

Nota: en esta situación, no puede funcionar el comando plantillas y complementos del menú Herramientas.

  1. Cierre Word y cambie el nombre del archivo Normal.dot a nombre.dot.
  2. Abra Word y compruebe que Macro y personalizar en el menú Herramientas.
  3. Abra un documento nuevo y en el menú Insertar, haga clic en el archivo.
  4. Desplácese hasta la carpeta que contiene el archivo afectado.
  5. Haga clic para seleccionar el archivo infectado.
  6. Presione y mantenga presionada la tecla MAYÚS y haga clic en Aceptar.

    Siga manteniendo la tecla MAYÚS hasta que el archivo infectado se abra en Word.

    Nota: mantenga la tecla MAYÚS mientras abre un archivo evita que cualquier macro automática de palabras ejecución.
  7. Para ver si hay alguna macro en el documento nuevo (no debería haber ninguna lista), elija Macro en el menú Herramientas y, a continuación, haga clic en Macros. En la lista Macros en, haga clic en "Todas las plantillas activas y documentos". En nombre de la Macro, no debe haber ninguna macro enumerado. Haga clic en Cancelar.
  8. Guarde el archivo con un nombre de archivo diferente.
  9. Eliminar el archivo infectado.
Más información
Un virus de macro es un programa escrito en el lenguaje de macros de un programa, como Word. Se propaga entre archivos de datos y puede dañar sus archivos o el sistema operativo de su equipo.

Los virus de macro de Word no viajan libremente por Internet o cualquier otro medio; sólo se pueden transferir cuando un usuario abre un documento o plantilla que contiene el virus de macro.

Ayudante de Internet de Microsoft y los documentos creados o lee no pueden infectarse con estas macros. El Ayudante de Internet, por su diseño, bloquea los mecanismos que distribuyen los virus de macro.

Los virus de macro no pueden transmitirse mediante WordMail a menos que un documentis afectado incrustado en el mensaje de correo electrónico y el destinatario abra el documento.
desinfectar proteger protección corporativa infectar Guardar Abrir saveas nucleares DMV broma concepto word97 word8

Propiedades

Id. de artículo: 181079 - Última revisión: 12/05/2015 08:23:41 - Revisión: 3.0

Microsoft Word 97 Standard Edition

  • kbnosurvey kbarchive kbinfo kbvirus kbmt KB181079 KbMtes
Comentarios