Estás trabajando sin conexión, espera a que vuelva la conexión a Internet

Macros de ejemplo de Visual Basic para trabajar con matrices en Excel

Ha finalizado el soporte técnico para Office 2003

Microsoft puso fin al soporte técnico para Office 2003 el 8 de abril de 2014. Este cambio ha afectado a las actualizaciones de software y las opciones de seguridad. Sepa qué significa esto en su caso y cómo puede mantenerse protegido.

Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Resumen
Este artículo contiene procedimientos de ejemplo de Microsoft Visual Basic para Aplicaciones que puede utilizar para trabajar con varios tipos de matrices.
Más información
Microsoft proporciona ejemplos de programación sólo como ilustración, sin ninguna garantía ya sea expresa o implícita. Esto incluye, entre otras, las garantías implícitas de comerciabilidad e idoneidad para un fin determinado. En este artículo se da por supuesto que ya conoce el lenguaje de programación que se muestra, así como las herramientas empleadas para crear y depurar procedimientos. Los ingenieros de soporte técnico de Microsoft pueden explicarle la funcionalidad de un determinado procedimiento, pero no modificarán estos ejemplos para ofrecer mayor funcionalidad ni crearán procedimientos adaptados a sus necesidades específicas.

Rellenar una matriz y copiarla en una hoja de cálculo

  1. Abra un libro nuevo.
  2. Presione Alt+F11 para ejecutar el Editor de Visual Basic.
  3. En el menú Insertar, haga clic en Módulo.
  4. Escriba el siguiente código en la hoja de módulo:
       Sub Sheet_Fill_Array()      Dim myarray As Variant      myarray = Array(1, 2, 3, 4, 5, 6, 7, 8, 9, 10)      Range("a1:a10").Value = Application.WorksheetFunction.Transpose(myarray)   End Sub					
  5. En el menú Archivo, haga clic en Cerrar y volver a Microsoft Excel.
  6. Seleccione Sheet1.
  7. En el menú Herramientas, seleccione Macro y, a continuación, haga clic en Macros.
  8. En el cuadro de diálogo Macro, haga clic en Sheet_Fill_Array y, a continuación, haga clic en Ejecutar.

Para tomar los valores de una hoja de cálculo y rellenar la matriz

  1. Abra un libro nuevo y escriba valores en las celdas A1:A10 de Sheet1.
  2. Presione Alt+F11 para ejecutar el Editor de Visual Basic.
  3. En el menú Insertar, haga clic en Módulo.
  4. Escriba el siguiente código en la hoja de módulo:
       Sub From_sheet_make_array()      Dim myarray As Variant      myarray = Range("a1:a10").Value      'Looping structure to look at array.      For i = 1 To UBound(myarray)      	MsgBox myarray(i, 1)      Next   End Sub				
  5. En el menú Archivo, haga clic en Cerrar y volver a Microsoft Excel.
  6. Seleccione Sheet1.
  7. En el menú Herramientas, seleccione Macro y, a continuación, haga clic en Macros.
  8. En el cuadro de diálogo Macro, haga clic en From_sheet_make_array y, a continuación, haga clic en Ejecutar.

Pasar y recibir una matriz

  1. Abra un libro nuevo.
  2. Presione Alt+F11 para ejecutar el Editor de Visual Basic.
  3. En el menú Insertar, haga clic en Módulo.
  4. Escriba el siguiente código en la hoja de módulo:
       Sub Pass_array()      Dim myarray As Variant      myarray = Range("a1:a10").Value      receive_array myarray   End Sub   Sub receive_array(thisarray)      For i = 1 To UBound(myarray)      	MsgBox myarray(i, 1)      Next   End Sub
  5. En el menú Archivo, haga clic en Cerrar y volver a Microsoft Excel.
  6. Seleccione Sheet1 y resalte el rango A1:A10.
  7. En el menú Herramientas, seleccione Macro y, a continuación, haga clic en Macros.
  8. En el cuadro de diálogo Macro, haga clic en Pass_array y, a continuación, haga clic en Ejecutar.
copy paste visual basic editor XL2000 XL97 XL98 XL2002 XL2003 XL2001 XLX XL2004
Propiedades

Id. de artículo: 213798 - Última revisión: 12/05/2015 12:20:01 - Revisión: 5.3

  • Microsoft Office Excel 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
  • Microsoft Excel 2004 for Mac
  • Microsoft Excel X para Macintosh
  • Microsoft Excel 2001 para Macintosh
  • Microsoft Excel 98 para Macintosh
  • kbnosurvey kbarchive kbdtacode kbhowto kbprogramming KB213798
Comentarios