GetHostByName() devuelve la dirección IP de interfaz de deshabilitado

IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.

216091
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Síntomas
En Windows NT 4.0, es posible configurar varios perfiles de hardware mediante la herramienta dispositivos en el panel de control. Según el perfil de se puede deshabilitar el dispositivo para la tarjeta de interfaz de red (NIC).

En un escenario, aplicaciones basadas en sockets que se ejecutan en Windows NT 4.0 Service Pack 4 pueden fallar inesperadamente. Este problema se ha observado en aplicaciones de NetShow y Microsoft Exchange. También puede producirse el problema en equipos multitarjeta que uno de las NIC está deshabilitado.
Causa
Este problema se produce porque la API GetHostByName() devuelve la dirección IP antigua anteriormente pertenece a la NIC deshabilitado.
Solución
Para resolver este problema, obtenga el último Service Pack para Windows NT 4.0 o la actualización de software correspondiente. Para obtener información acerca de cómo conseguir el último Service Pack, vaya a:
Para obtener información acerca de cómo obtener la actualización de software correspondiente, póngase en contacto con el Servicio de soporte técnico de Microsoft. Para ver una lista detallada de los números de teléfono de los Servicios de soporte técnico de Microsoft así como información de costos de soporte, visite la siguiente dirección Web: Se ha registrado esta revisión en la siguiente ubicación de Internet como Rnr-fixi.exe (x 86) y Rnr-fixa.exe (Alpha):

Estado
Microsoft ha confirmado que este es un problema en Windows NT 4.0 Service Pack 4. Este problema se corrigió en Windows NT versión 4.0 Service Pack 5.
sp4 4.00

Advertencia: este artículo se ha traducido automáticamente

Propiedades

Id. de artículo: 216091 - Última revisión: 01/10/2015 11:46:02 - Revisión: 2.5

  • Microsoft Windows NT 4.0 Service Pack 4
  • Microsoft Windows NT 4.0 Service Pack 4
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • kbnosurvey kbarchive kbmt kbhotfixserver kbqfe kbbug kbfix kbqfe KB216091 KbMtes
Comentarios