Error al intentar instalar la herramienta de sincronización de Azure Active Directory: el equipo debe estar unido a un dominio

Versión del producto original: Cloud Services (roles web/roles de trabajo), Microsoft Entra ID, Microsoft Intune, Azure Backup, Office 365 Identity Management
Número de KB original: 2419250

Síntomas

Al intentar instalar el Herramienta de sincronización de Microsoft Azure Active Directory, puede recibir el siguiente mensaje de error:

El equipo debe estar unido a un dominio.

Causa

Este problema puede producirse si el equipo no está unido a un dominio de Servicios de dominio de Active Directory (AD DS) o si el equipo no registra un registro de recursos de host (A) con su sistema de nombres de dominio (DNS).

Solución

Para resolver este problema, utilice uno de los métodos siguientes.

Método 1: El equipo no está unido a un dominio de AD DS

Unir el equipo a un dominio de AD DS. Para ello, siga estos pasos:

  1. En el equipo al que desea unirse a un dominio, seleccione Inicio, seleccione Panel de control y, a continuación, haga doble clic en Sistema.
  2. En Nombre del equipo, dominio y configuración del grupo de trabajo, seleccione Cambiar configuración.
  3. En la pestaña Nombre del equipo , seleccione Cambiar.
  4. En Miembro de, seleccione Dominio, escriba el nombre del dominio al que se unirá este equipo y, a continuación, seleccione Aceptar.
  5. Seleccione Aceptar y reinicie el equipo.

Método 2: El equipo ya está unido a un dominio de AD DS

Si el equipo ya está unido a un dominio de AD DS, asegúrese de que la configuración de DNS del equipo es correcta y de que un registro de recursos de host (A) para el equipo está registrado con DNS. Para ello, siga estos pasos:

  1. Abra Connections de red.

  2. Haga clic con el botón derecho en la conexión de red que desea configurar y, a continuación, seleccione Propiedades.

  3. Realice una de las siguientes acciones, según corresponda para la conexión que desea configurar:

    • Para una conexión de área local: en la pestaña General , seleccione Protocolo de Internet (TCP/IP) y, a continuación, seleccione Propiedades.
    • Para todas las demás conexiones: en la pestaña Redes, seleccione Protocolo de Internet (TCP/IP) y, después, Propiedades.
  4. Si desea obtener direcciones de servidor DNS de un servidor protocolo de configuración dinámica de host (DHCP), seleccione Obtener dirección del servidor DNS automáticamente.

  5. Si desea configurar manualmente las direcciones del servidor DNS, seleccione Usar las siguientes direcciones de servidor DNS. En el cuadro Servidor DNS preferido , escriba las direcciones IP del servidor DNS preferido. En el cuadro Servidor DNS alternativo , escriba las direcciones IP del servidor DNS alternativo.

  6. Seleccione Aceptar dos veces y, a continuación, cierre Connections de red.

  7. En un símbolo del sistema, escriba los comandos siguientes y presione ENTRAR después de cada comando:

    ipconfig /flushdns
    
    ipconfig /registerdns
    
  8. Si no se resuelve el problema, reinicie el equipo que tenga instalada la herramienta de sincronización de directorios.

  9. Si el problema sigue sin resolverse, asegúrese de que el equipo que tiene instalada la herramienta de sincronización de directorios puede comunicarse con el equipo que ejecuta AD DS.

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