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Solución de problemas de instalación del agente System Center Operations Manager

Síntomas
El agente System Center Operations Manager (SCOM) se puede implementar en equipos Windows a través de "inserción remota" desde un servidor de administración o se puede instalar manualmente en un equipo de destino mediante MomAgent.msi.Si la instalación del agente no se realiza correctamente, existen varios pasos de solución de problemas que se pueden usar en función de dónde se produzca el error y cómo se implemente el agente.
Solución

Comprobación de que el equipo de destino cumple la configuración admitida
El paso inicial para solucionar los problemas de instalación del agente Operations Manager en un equipo Windows es comprobar que el posible agente satisface la configuración admitida de hardware y software. En los siguientes artículos se indican los requisitos de un agente Operations Manager 2007 y 2012:

Configuraciones admitidas de Operations Manager 2007 R2

Configuraciones admitidas de Operations Manager 2012

Si el sistema de destino es un equipo de Unix/Linux, compruebe que la distribución y la versión sean compatibles. Tenga en cuenta que para la compatibilidad con algunas versiones de Operations Manager 2007 se requieren actualizaciones acumulativas posteriores a R2. El artículo siguiente incluye las versiones compatibles de Unix/Linux:

Paquetes de administración de supervisión entre plataformas de System Center Operations Manager 2007 R2

Versiones admitidas de los sistemas operativos Unix y Linux de System Center Operations Manager 2012

Solución de problemas de implementación del agente a través del Asistente para detectar de la consola de Operations Manager
Si el agente se va implementar mediante la detección desde la consola de Operations Manager, el agente se instalará desde el servidor de administración o desde el servidor de puerta de enlace especificados en el Asistente para detectar para administrar el agente, no en el servidor al que se conecta la consola de operaciones cuando se abre. Por lo tanto, todas las pruebas se deben realizar desde el servidor de administración o desde la puerta de enlace especificados cuando se ejecuta el asistente, o bien se debe especificar un servidor de administración o una puerta de enlace diferentes durante el asistente para ver si se produce el mismo error.

  • Problema:
    El asistente no muestra una lista de posibles agentes para instalar.

    Causa:
    Las credenciales especificadas en el asistente durante la detección inicial deben tener permiso para buscar en Active Directory posibles agentes de Operations Manager. Si esta cuenta no puede conectarse a Active Directory, el Asistente para detectar dará error.

    Entre los errores habituales que pueden aparecer están:
    • Código de error: 800706BA
      Descripción del error: el servidor RPC no está disponible.
    • Código de error: 80070079
      El servidor MOM no pudo realizar la operación especificada en el equipo "nombre". Ha terminado el intervalo de espera del semáforo.
    • Código de error: 80070643
      La instalación del agente Operations Manager no se realizó en el equipo remoto "nombre"

    Posibles soluciones:
    • Durante la detección, especifique una cuenta que tenga permisos de administrador y que sea miembro del grupo Administradores de Operations Manager.
    • Si se agota el tiempo de espera de la consulta LDAP, o no es capaz de resolver los posibles agentes de Active Directory, se puede realizar la detección mediante el shell de comandos de Operations Manager. Para obtener información adicional, consulte la sección "Solución de problemas de implementación del agente a través del shell de comandos de Operations Manager".

  • Problema:
    El equipo de destino no está en la lista de posibles agentes después de ejecutar la detección inicial.

    Causa:
    • El equipo ya se ha identificado en la base de datos como parte del grupo de administración.
    • El equipo aparece en la lista "Acciones pendientes" en la consola de Operations.

    Posibles soluciones:
    • Si el equipo de destino aparece en el nodo "Acciones pendientes" del espacio "Administración" de la consola de Operations, la acción existente se debe aprobar o rechazar antes de poderse realizar una nueva acción. Si la configuración de instalación existente es suficiente, apruebe la instalación pendiente de la consola. Si la configuración existente es incorrecta, rechace la acción pendiente y, a continuación, ejecute de nuevo el Asistente para detectar.

  • Problema:
    El Asistente para detectar encuentra uno de los siguientes errores al intentar instalar el agente:
    • Operación: instalación del agente
      Código de error: 800706D9
    • Descripción del error: error desconocido 0xC000296E
    • Descripción del error: error desconocido 0xC0002976
    • Código de error: 80070643
      Descripción del error: error grave durante la instalación.


    Causa:
    • La cuenta anteriormente especificada para realizar la instalación del agente en el Asistente para detectar deberá tener permisos para conectar de forma remota con el equipo de destino e instalar un servicio de Windows. Para ello se necesitan permisos de administrador local debido al requisito de escritura en el Registro.
    • Las restricciones de directiva de grupo en la cuenta de equipo del servidor de administración, o en la cuenta usada para la inserción del agente, pueden impedir que la instalación se realice correctamente. Los objetos de directiva de grupo de Active Directory que impiden que la cuenta de equipo del servidor de administración, o que la cuenta de usuario que utiliza el Asistente para detectar, accedan de forma remota a la carpeta, al Registro, a WMI o a los recursos compartidos administrativos de Windows en el equipo de destino, pueden impedir la implementación correcta del agente Operations Manager.
    • El Firewall de Windows bloquea los puertos entre el servidor de administración y el equipo de destino.
    • No se están ejecutando los servicios necesarios en el equipo de destino.


    Posibles soluciones:
    • Si las credenciales especificadas en el asistente no tienen permisos de administrador local, agregue la cuenta al grupo de seguridad Administradores en el equipo de destino, o bien utilice una cuenta que ya sea miembro de ese grupo.
    • Bloquee la herencia de directivas de grupo en el equipo de destino, o la cuenta de usuario que realiza la instalación.

    • Si la instalación de un agente da error cuando se utiliza una cuenta de dominio para insertar el agente desde un servidor de administración, el uso de las herramientas administrativas de Windows puede ayudar a identificar los posibles problemas. Inicie sesión en el servidor de administración con las credenciales en cuestión e intente las siguientes tareas. Si la cuenta no tiene permisos para iniciar sesión en el servidor de administración, las herramientas se pueden ejecutar con las credenciales que se van a probar desde un símbolo del sistema.
      • "RUNAS /user: compmgmt.msc". En el elemento de menú "Acción", seleccione "Conectarse a otro equipo". Examine o escriba el nombre del equipo remoto. Intente abrir el Visor de eventos y busque cualquiera de los registros de eventos.
      • "RUNAS /user:services.msc". En el elemento de menú "Acción", seleccione "Conectarse a otro equipo". Examine o escriba el nombre del equipo remoto. Intente iniciar o detener la cola de impresión o cualquier otro servicio en el equipo de destino.
      • "RUNAS /user: regedt32.exe". En el elemento de menú "Archivo", seleccione "Conectar al Registro de red". Examine o escriba el nombre del equipo remoto. Intente abrir "HKey_Local_Machine" en el equipo remoto.
      • "RUNAS /user:Explorer.exe". En la barra de direcciones, escriba lo siguiente: \\admin$

        Si alguna de estas tareas da error, intente utilizar una cuenta diferente para tener permisos de Administrador de dominio o Administrador local (en el equipo de destino). Además, intente las mismas tareas desde un servidor o una estación de trabajo miembros para ver si las tareas dan error desde varios equipos.
        El no poder conectarse al recurso compartido admin$ puede impedir que el servidor de administración copie los archivos de configuración en el destino. El no poder conectarse al Registro de Windows en el destino puede impedir que el servicio de estado se instale correctamente. El no poder conectarse al Administrador de control de servicios impedirá que el programa de instalación inicie el servicio.
    • Los siguientes puertos deben estar abiertos entre el servidor de administración y el equipo de destino:
      • Asignador de extremos de RPC Número de puerto: protocolo 135: TCP/UDP
      • *Puertos altos de RPC/DCOM (SO 2000/2003) Puertos 1024-5000 Protocolo: TCP/UDP
      • *Puertos altos de RPC/DCOM (SO 2008) Puertos 49152-65535 Protocolo: TCP/UDP
      • Nombre del servicio NetBIOS Número de puerto: protocolo 137: TCP/UDP
      • Servicio de sesión NetBIOS Número de puerto: protocolo 139: TCP/UDP
      • SMB sobre IP Número de puerto IP: protocolo 445: TCP
      • Canal MOM Número de puerto: protocolo 5723: TCP/UDP
    • Los siguientes servicios deben estar habilitados y en ejecución en el equipo de destino:
      • Netlogon
      • Registro remoto
      • Windows Installer
      • Actualizaciones automáticas

En los siguientes artículos se proporciona alguna información de contexto útil acerca de la implementación del agente Operations Manager mediante el uso de la detección desde el servidor de administración:

Como implementar el agente Operations Manager 2007 mediante el asistente para la instalación del agente
Cómo funciona la detección de equipos en OpsMgr 2007
Solución de problemas de detección e inserción del agente en OpsMgr 2007
Tabla de solución de problemas de implementación del agente basada en la consola
Administración de detección y agentes en SCOM 2012

Solución de problemas de implementación del agente a través del shell de comandos de Operations Manager
En algunas situaciones, la detección automática de posibles agentes puede agotar el tiempo de espera en el caso de entornos de Active Directory muy grandes o complejos. Otras situaciones pueden requerir que se ejecute la detección automática con una consulta de LDAP que es más limitada que la que está disponible en la interfaz de usuario. En estos casos, la detección automática de equipos y la instalación remota del agente Operations Manager es posible a través del shell de comandos de Operations Manager. La siguiente entrada de blog proporciona la sintaxis requerida para ello:

Detección de equipos de Windows a través de Powershell

Solución de problemas de implementación del agente a través del registro detallado de Windows Installer
Si la instalación del agente en un equipo remoto da error durante la instalación, se puede crear un registro detallado de Windows Installer en el servidor de administración en la siguiente ubicación predeterminada:

C:\Program Files\System Center Operations Manager \AgentManagement\AgentLogs

Donde es 2007 o 2012

El registro se puede usar para determinar si se ha encontrado un error específico y puede ser útil para solucionar posteriores problemas de instalación del agente de Operations Manager en el equipo de destino.

Busque la primera entrada con la cadena "Return Value 3" en el registro. Las líneas anteriores indicarán normalmente el error que ha encontrado Windows Installer. El formato será normalmente "función / descripción del error / código de retorno de error", y puede indicar problemas de permisos, archivos que faltan u otros valores que es necesario cambiar. Ejemplos:

  • Mensaje de error:
    ConvertStringSecurityDescriptorToSecurityDescriptor failed : 87

    Posible causa:
    La cuenta de instalación no tiene permisos para el registro de seguridad en el equipo de destino.

  • Mensaje de error:
    ModifyEventLogAccessForNetworkService(): No se pudo conceder acceso de lectura a SecurityLog: 0x00000057

    Posible causa:
    La cuenta de instalación no tiene permisos para el registro de seguridad en el equipo de destino

  • Mensaje de error:
    No se puede abrir el archivo de base de datos. Error del sistema 2147024629

    Posible causa:
    La cuenta de instalación no tiene permisos para la carpeta TEMP del sistema.

Hay muchos posibles errores que se pueden registrar aquí. Otros errores individuales se puede seguir investigando en TechNet o en la Online Knowledge Base.

Solución de problemas de instalación manual del agente Operations Manager
En aquellos casos en los que el agente Operations Manager no se pueda implementar en un equipo remoto a través del Asistente para detectar, se deberá instalar manualmente. Esta operación se puede realizar mediante la línea de comandos con el archivo MomAgent.msi. Las referencias siguientes describen los diversos modificadores y opciones de configuración disponibles para realizar una instalación manual:

Cómo implementar el agente de Operations Manager 2007 mediante MOMAgent.msi desde la línea de comandos
Casos de uso y comandos de MSI de instalación del agente de Windows
Instalaciones manuales de agentes de proceso en Operations Manager 2007

Cómo implementar al agente de Operations Manager 2012 mediante la línea de comandos

Instalaciones manuales de agentes de proceso en Operations Manager 2012

Ejemplos de uso del comando MOMAgent para administrar agentes en Operations Manager 2012

Si el agente se implementa mediante instalación manual, las futuras actualizaciones o actualizaciones acumulativas de Service Pack se deberán implementar también manualmente. El servicio System Center Configuration Manager no designará los equipos que se han instalado manualmente como administrables de forma remota, y la opción para actualizarlos no estará presente en la consola de operaciones.

Otros aspectos importantes que se deben tener en cuenta durante la instalación manual de los agentes:

  • Si la instalación se está realizando mediante un dominio o un usuario local, la cuenta deberá ser miembro del grupo de seguridad local Administradores en los sistemas operativos Vista o versiones posteriores. En los sistemas operativos anteriores a Vista, los usuarios que eran miembros del grupo de seguridad "Usuarios avanzados" tenían los permisos necesarios para instalar los servicios.
  • Si el agente se está implementando a través de Configuration Manager, la cuenta de servicio de Configuration Manager se deberá ejecutar como Localsystem (que es el valor predeterminado) o en el contexto de un administrador local.

En los registros de configuración de Windows Installer se pueden identificar los errores que impiden que los agentes se instalen manualmente. El siguiente comando se puede usar para habilitar el registro detallado de Windows Installer de la instalación del agente Operations Manager:
msiexec.exe /i "MOMAgent.msi" /l*v "C:\Agent\MOMAgent_install.log"

Como alternativa, en el siguiente artículo se describe cómo habilitar el registro detallado de Windows Installer de manera global en un equipo Windows:
Cómo habilitar el registro de Windows Installer

El registro se puede usar para determinar si se ha encontrado un error específico y puede ser útil para solucionar posteriores problemas de instalación del agente de Operations Manager en el equipo de destino.

Busque la primera entrada con la cadena "Return Value 3" en el registro. Las líneas anteriores indicarán normalmente el error que ha encontrado Windows Installer. El formato será normalmente "función / descripción del error / código de retorno de error", y puede indicar problemas de permisos, archivos que faltan u otros valores que es necesario cambiar.

Ejemplos:

  • Mensaje de error:
    ConvertStringSecurityDescriptorToSecurityDescriptor failed : 87

    Posible causa:
    La cuenta de instalación no tiene permisos para el registro de seguridad en el equipo de destino.

  • Mensaje de error:
    ModifyEventLogAccessForNetworkService(): No se pudo conceder acceso de lectura a SecurityLog: 0x00000057

    Posible causa:
    La cuenta de instalación no tiene permisos para el registro de seguridad en el equipo de destino

  • Mensaje de error:
    No se puede abrir el archivo de base de datos. Error del sistema 2147024629

    Posible causa:
    La cuenta de instalación no tiene permisos para la carpeta TEMP del sistema.

Hay muchos posibles errores que se pueden registrar aquí. Otros errores individuales se puede seguir investigando enTechNet o en la Online Knowledge Base.

Más información
Este artículo se aplica a todas las versiones de System Center Operations Manager 2007 (OpsMgr 2007) y a todas las versiones de System Center 2012 Operations Manager (OpsMgr 2012).
Nota: es un artículo de "PUBLICACIÓN RÁPIDA" creado directamente por la organización de soporte técnico de Microsoft. La información aquí contenida se proporciona como está, como respuesta a problemas que han surgido. Como consecuencia de la rapidez con la que lo hemos puesto disponible, los materiales podrían incluir errores tipográficos y pueden ser revisados en cualquier momento sin previo aviso. Vea las Condiciones de uso para otras consideraciones
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Id. de artículo: 2566152 - Última revisión: 10/06/2015 16:47:00 - Revisión: 1.0

Microsoft System Center Operations Manager 2007, Microsoft System Center Operations Manager 2007 R2, Microsoft System Center Operations Manager 2007 Service Pack 1, Microsoft System Center 2012 Operations Manager, Microsoft System Center 2012 Operations Manager Service Pack 1

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