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Cómo solucionar problemas de cuentas de usuario eliminadas en Office 365, Azure o Intune

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Haga clic aquí para ver el artículo original (en inglés): 2619308
PROBLEMA
Una cuenta de usuario se elimina por error de Microsoft Office 365, Microsoft Azure o Microsoft Intune y tiene que restaurarse.
CAUSA
Pueden eliminarse las cuentas de usuario 365 de Office en cualquiera de las siguientes maneras:
  • Pueden eliminar manualmente las cuentas de usuario mediante el portal de Office 365.
  • Pueden eliminar manualmente las cuentas de usuario mediante el portal de Azure.
  • Las cuentas de usuario pueden eliminarse manualmente o eliminar a través de una secuencia de comandos mediante Microsoft Azure Active Directory módulo para Windows PowerShell.
  • Pueden eliminar manualmente las cuentas de usuario mediante el centro de administración de Exchange en Exchange Online.
  • Pueden eliminarse las cuentas de usuario a través de una eliminación sincronizada si los cambios de filtrado de sincronización de directorio excluyen el objeto de usuario de Active Directory local del conjunto de sincronización. (Los cambios de filtrado de sincronización de directorio también se conocen como ámbito).
  • Pueden eliminarse las cuentas de usuario a través de una eliminación sincronizada si se ha eliminado el objeto de usuario local desde el esquema de Active Directory local.
  • Pueden eliminarse las cuentas de usuario mediante una API (por ejemplo, la API del gráfico).
SOLUCIÓN

Antes de empezar

Cuando se elimina un objeto de usuario, no inmediatamente y completamente quitarlo de Active Directory (AD Azure) de Azure. El objeto de usuario se coloca en estado eliminado y ya no aparece en la lista de usuarios. Sin embargo, se pueden recuperar de una organización dentro de 30 días. Para determinar si un objeto de usuario es elegible para recuperarse de un estado eliminado, siga estos pasos:
  1. En el portal de Office 365, busque las cuentas de usuario que se eliminaron a través del portal. Para ello, siga estos pasos:
    1. Iniciar sesión en el (portal de Office 365https://portal.Office.com) mediante el uso de credenciales administrativas.
    2. Haga clic en usuariosy, a continuación, haga clic en Eliminar usuarios.
    3. Busque el usuario que desea recuperar.
  2. Con el módulo Azure Active Directory para Windows PowerShell, siga estos pasos:
    1. Haga clic en Inicio, seleccione Todos los programas, haga clic en Active Directory de Windows Azurey, a continuación, haga clic en Windows Azure Active Directory módulo para Windows PowerShell.
    2. Escriba los comandos siguientes en el orden en que aparecen. Asegúrese de presionar ENTRAR después de escribir cada comando.
      • $cred = get-credential
        Nota: Cuando se le solicite, escriba sus credenciales de Office 365.
      • Connect-MSOLService -credential:$cred
      • Get-MsolUser –ReturnDeletedUsers

Solución 1: Utilizar el portal de Office 365 o el módulo Azure Active Directory para Windows PowerShell para recuperar una cuenta de usuario eliminada

Para recuperar una cuenta de usuario que se ha eliminado manualmente, utilice uno de los métodos siguientes:
  • Utilizar el portal de Office 365 para recuperar la cuenta de usuario. Para obtener más información acerca de cómo hacerlo, vea Eliminar o restaurar los usuarios.
  • Usar Azure Active Directory módulo para Windows PowerShell para recuperar la cuenta de usuario. Para ello, escriba uno de los comandos siguientes y presione ENTRAR:
    • Restore-MsolUser -ObjectId <Guid> -AutoReconcileProxyConflicts -NewUserPrincipalName <string>
    • Restore-MsolUser -UserPrincipalName <string> -AutoReconcileProxyConflicts -NewUserPrincipalName <string>


      En estos comandos, se utilizan las siguientes convenciones:
      • Los parámetros UserPrincipalName y ObjectID identifican de forma exclusiva el objeto de usuario para restaurar.
      • AutoReconcileProxyConflicts es un parámetro opcional y se utiliza en escenarios en los que se concede a otro objeto usuario la dirección de proxy del objeto de usuario de destino después de que haber eliminado la dirección.
      • Opcionalmente, el parámetro NewUserPrincipalNamese utiliza en escenarios en los que a otro objeto usuario se le concede el nombre principal de usuario (UPN) del objeto después que el UPN fuera eliminado.

Solución 2: Recuperar una cuenta de usuario que se ha eliminado porque los cambios del filtrado de sincronización de directorio (ámbito) excluyen el objeto de usuario de Active Directory local

Para recuperar cuentas de usuario eliminadas, asegúrese de que el filtrado de sincronización de directorios está establecido de tal manera que el ámbito incluye los objetos que desea recuperar. Para obtener más información, visite el siguiente sitio Web de Microsoft:

Solución 3: Recuperar una cuenta de usuario que se ha eliminado porque se eliminó el objeto de usuario local desde el esquema de Active Directory local

Para recuperar un elemento eliminado en el esquema de Active Directory local, siga estos pasos:
  1. Intente restaurar el elemento eliminado de la Papelera de reciclaje de Active Directory. Para obtener más información acerca de cómo hacerlo, visite el siguiente sitio Web de Microsoft:Notas:
    • La Papelera de reciclaje de Active Directory sólo está disponible con el nivel funcional de bosque Windows 2008 R2 o versiones posteriores.
    • Para que la Papelera de reciclaje de Active Directory sea útil en la recuperación de un elemento, debe ser habilitado antes de eliminar el elemento.
  2. Si Active Directory reciclaje bin no está disponible, o si el objeto en cuestión ya no está en la Papelera de reciclaje, intentar recuperar los elementos eliminados mediante la herramienta AdRestore. Para ello, siga estos pasos:
    1. Instale la herramienta AdRestore desde el siguiente sitio Web de Microsoft TechNet:
    2. Utilice AdRestore junto con un filtro de búsqueda para encontrar el objeto de usuario eliminado local.

      El siguiente es un ejemplo de cómo utilizar AdRestore para enumerar todos los objetos de usuario que tienen una cadena de "Usuario" en su nombre:
      C:\>adrestore.exe UserAAdRestore v1.1 by Mark RussinovichSysinternals - www.sysinternals.comEnumerating domain deleted objects:cn: MailboxADEL:3c45a0ae-ebc5-490d-a4b4-4b20d3e34a3fdistinguishedName: CN=UserA\0ADEL:3c45a0ae-ebc5-490d-a4b4-4b20d3e34a3f,CN=Deleted Objects,DC=Domain,DC=comlastKnownParent: OU=OnPremises,DC=Domain,DC=comFound 1 item matching search criteria.
    3. Uso AdRestore junto con el r - cambiar para restaurar el objeto de usuario.

      El siguiente es un ejemplo de cómo utilizar AdRestore para restaurar el objeto de usuario:
      C:\>adrestore.exe Usera –rAdRestore v1.1 by Mark RussinovichSysinternals - www.sysinternals.comEnumerating domain deleted objects:cn: UserADEL:3c45a0ae-ebc5-490d-a4b4-4b20d3e34a3fdistinguishedName: CN=MailboxA\0ADEL:3c45a0ae-ebc5-490d-a4b4-4b20d3e34a3f,CN=Deleted Objects,DC=Domain,DC=comlastKnownParent: OU=OnPremises,DC=Domain,DC=comDo you want to restore this object (y/n)? yRestore succeeded.Found 1 item matching search criteria.
    4. Habilitar el objeto de usuario en Active Directory. Cuando se restaura el objeto, lo está al principio. Por lo tanto, debe habilitarla. Si es necesario, en primer lugar restablecer contraseña del objeto de usuario y, a continuación, habilitar el objeto de usuario en usuarios y equipos de usuarios de Active Directory.

      Para habilitar el objeto usuario en Usuarios y Equipos de Active Directory, siga estos pasos:
      1. En usuarios y equipos, haga clic en el usuario y, a continuación, haga clic en Restablecer contraseña.
      2. Escriba una nueva contraseña en el nueva contraseña y Confirmar contraseña cuadros y, a continuación, haga clic en Aceptar.
      3. Haga clic en el usuario, haga clic en Habilitar cuentay, a continuación, haga clic en Aceptar.

        Captura de pantalla de habilitar cuenta en Active Directory
        Recibirá el siguiente mensaje de error. (Se espera que este mensaje de error).
        Windows no puede habilitar <MailboxName>porque:
        No se puede actualizar la contraseña. El valor proporcionado para la nueva contraseña no cumple la longitud, complejidad o requisitos de historial del dominio.</MailboxName>
        Después de recibir este mensaje de error, restablezca la contraseña del usuario en usuarios y equipos de usuarios de Active Directory.
    5. Configurar el nombre de inicio de sesión de usuario. No se configuró el nombre de inicio de sesión de usuario (también conocido como el nombre principal de usuario, o UPN) del objeto de usuario restaurado. Debe actualizar el nombre de inicio de sesión de usuario, especialmente si el usuario es una cuenta federada.

      Para configurar el nombre de inicio de sesión de usuario, siga estos pasos:
      1. En usuarios y equipos, haga clic en el usuario y, a continuación, haga clic en Propiedades.
      2. Haga clic en cuenta, escriba un nombre en el cuadro nombre de inicio de sesión de usuario y, a continuación, haga clic en Aceptar.
Por último, si no puede recuperar la cuenta de usuario eliminada a través de la Papelera de reciclaje de Active Directory o mediante la herramienta AdRestore, realizar una restauración autoritativa de los objetos de usuario eliminada en Active Directory.

Advertencia: Asegúrese de que sólo los objetos de usuario que desea restaurar están marcados como autoritativo. Los objetos de Active Directory que están marcados como autorizados en el proceso de restauración pueden causar muchos problemas de servicio de Active Directory.

Para obtener más información acerca de cómo realizar una restauración autoritativa de objetos de Active Directory, visite el sitio Web de Microsoft siguiente:
Advertencia Los objetos que se restauran con resolución 3 que no tenga los atributos del servicio (Exchange Online, Skype para los negocios en línea (anteriormente Lync Online) y así sucesivamente) vuelve a llenar automáticamente después de la acción de restauración. Use las herramientas de administración de servicio apropiadas para volver a llenar los atributos de objeto local antes de que el siguiente intervalo de sincronización de directorios propague la acción de restaurar al directorio en la nube.

Por ejemplo, para un objeto que antes era habilitados para correo en Exchange Online, puede usar los cmdlets de Windows PowerShell para volver a llenar los atributos de Exchange en línea. En el ejemplo siguiente, el objeto de Usuario1 se vuelve a llenar con los atributos de Exchange en línea para el arrendatario contoso.onmicrosoft.com:
Enable-RemoteMailbox -Identity User1 -RemoteRoutingAddress user1@contoso.mail.onmicrosoft.com
Si las siguientes condiciones se cumplen, no funcionará la solución 3:
  • Restauración del objeto mediante el uso de la Papelera de reciclaje de Active Directory no es una opción disponible.
  • Restauración del objeto con la herramienta AdRestore no es una opción disponible.
  • Restauración autoritativa de Active Directory, no es una opción disponible.
En esta situación, póngase en contacto con el soporte técnico de Office 365 para obtener ayuda.
MÁS INFORMACIÓN
Los cambios que realizados a un dominio o a un objeto usuario de Office 365 después de que la cuenta de usuario es eliminada y antes de que el usuario sea recuperado pueden afectar la experiencia del usuario después de la recuperación. Después de la eliminación del usuario y antes de la recuperación del usuario, pueden ocurrir los siguientes eventos:
  • Se crea un nuevo usuario que utiliza un valor de identificador de usuario único que anteriormente se ha asignado al usuario eliminado.
  • Se crea un nuevo usuario que utiliza un valor de dirección de correo electrónico exclusivo asignado al usuario eliminado anteriormente.
Cuando se producen estos conflictos, debe actualizarse atributos en conflicto para eliminar el conflicto antes de completar la recuperación del usuario. Si se produce un conflicto durante la recuperación del usuario, el usuario experimentará alguno de los siguientes síntomas cuando se intente la recuperación de un usuario:
  • Windows PowerShell devuelve uno de los siguientes mensajes de error:

    Mensaje de error 1
    MsolUser de restauración: No se puede restaurar la cuenta de usuario especificada debido al siguiente error: Error de tipo UserPrincipalName
    Mensaje de error 2
    MsolUser de restauración: No se puede restaurar la cuenta de usuario especificada debido al siguiente error: el tipo de Error proxyAddress
    Para restaurar los usuarios que están en este estado, puede corregir el conflicto con los siguientes parámetros al ejecutar el MSOLUser de restauración cmdlet:
    • AutoReconcileProxyConflicts
    • NewUserPrincipalName
    Nota: Cuando se utiliza el AutoReconcileProxyConflicts parámetro, en cualquier conflicto de direcciones de correo electrónico se quitan el usuario eliminado antes de continuar con el proceso de recuperación.
  • El portal de Office 365 muestra los mensajes de error equivalente en forma de los Estados de error de Windows PowerShell que se han mencionado anteriormente. Por ejemplo, verá lo siguiente:

    Captura de pantalla de página de los conflictos de nombre de usuario

    Para restaurar los usuarios que están en este estado, complete el formulario y asegúrese de que especifica cómo desea solucionar el conflicto.

¿Sigue necesitando ayuda? Vaya a la Comunidad de Office 365 sitio Web o el Foros de Azure de Active Directory .

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Propiedades

Id. de artículo: 2619308 - Última revisión: 08/12/2015 19:07:00 - Revisión: 22.0

Microsoft Office 365, Microsoft Intune, Microsoft Azure Cloud Services, Microsoft Azure Active Directory, Office 365 User and Domain Management

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