El usuario no puede ver la información de disponibilidad de un usuario remoto en una implementación híbrida de Exchange Server

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Nota:

Ya no se admite el Asistente para configuración híbrida que se incluye en el Consola de administración de Exchange de Microsoft Exchange Server 2010. Por lo tanto, ya no debe usar el asistente de configuración híbrida anterior. En su lugar, use el Asistente para configuración híbrida de Microsoft 365 que está disponible en https://aka.ms/HybridWizard. Para obtener más información, vea Asistente para configuración híbrida de Microsoft 365 para Exchange 2010.

Síntomas

Tiene una implementación híbrida de Microsoft Exchange Server locales y Microsoft Exchange Online en Microsoft 365 en la que el servidor híbrido se ejecuta Exchange Server 2010. Sin embargo, los usuarios no pueden ver la información de disponibilidad de un usuario remoto. Cuando un usuario intenta ver la información de disponibilidad de un usuario remoto, no se muestra la información de disponibilidad. En su lugar, el usuario puede experimentar uno o varios de los síntomas siguientes:

  • La información de disponibilidad del usuario remoto se muestra como caracteres de signo de número (#) en el calendario.

  • En Outlook Web App, se muestra el "error 5037".

  • Los archivos FileName>-fb.log y <FileName>-as.log de Microsoft Outlook <contienen un mensaje de error similar al siguiente:

    <FreeBusyResponse><ResponseMessage ResponseClass="Error"><MessageText>El autor de la llamada no tiene acceso a los datos de disponibilidad.<Error /MessageText><ResponseCode>ErrorNoFreeBusyAccess</ResponseCode><DescriptiveLinkKey>0</DescriptiveLinkKey><MessageXml><ExceptionType xmlns="http://schemas.microsoft.com/exchange/services/2006/errorsMicrosoft.Exchange.InfoWorker.Common.Availability.NoFreeBusyAccessException></ExceptionType><ExceptionCode xmlns=""http://schemas.microsoft.com/exchange/services/2006/errors">5037</ExceptionCode><ExceptionServerName xmlns="http://schemas.microsoft.com/exchange/services/2006/errors">ServerName</ExceptionServerName><ResponseSource xmlns=""http://schemas.microsoft.com/exchange/services/2006/errors<>https://\<Server>.outlook.com/EWS/Exchange.asmx/WSSecurity/ResponseSource></MessageXml></ResponseMessage><FreeBusyView><FreeBusyViewType xmlns="">http://schemas.microsoft.com/exchange/services/2006/typesNone</FreeBusyViewType></FreeBusyView></FreeBusyResponse>

Por ejemplo, un usuario de Microsoft 365 no puede ver la información de disponibilidad de un usuario local. Sin embargo, otros usuarios pueden ver la información de disponibilidad para ese mismo usuario local.

Causa

Este problema se produce si el nombre de dominio de la dirección del protocolo simple de transferencia de correo (SMTP) del usuario que intenta ver la información de disponibilidad no se incluye entre los nombres de dominio de la relación de la organización. Por ejemplo, al ejecutar el cmdlet Test-OrganizationRelationship, se muestra la siguiente salida:

RunspaceId : a6c3799f-2ecd-4d79-ae4b-6c470ddd1dee
Identidad:
Id: LocalFederatedDomainsAreMissingFromTheRemoteOrganizationRelationsipDomains
Estado: advertencia
Descripción: hay dominios federados localmente que no están presentes en la lista de dominios para el objeto de relación de la organización remota.
IsValid : True

Esto ocurre si el dominio SMTP no se agregó manualmente a la relación de la organización. Esto también puede ocurrir si se cumplen las condiciones siguientes:

  • La cuenta de usuario de Microsoft 365 se creó antes de actualizar el entorno local a Exchange Server 2010.
  • Ha usado el Asistente para configuración híbrida en Exchange Server 2010 en el entorno local para configurar la confianza de federación. Por ejemplo, el nombre de dominio del usuario de Microsoft 365 es contoso.com.

En este escenario, la cuenta de usuario de Microsoft 365 no tiene @contoso.mail.onmicrosoft.com como una de sus direcciones proxy. La solicitud al entorno local usa @contoso.com en lugar de para la cuenta de usuario de @contoso.mail.onmicrosoft.com Microsoft 365. La solicitud se rechaza porque la relación de la organización en el entorno local no se ha contoso.com agregado a ella.

Solución

Para resolver este problema, edite la relación de la organización en el entorno local para incluir el dominio SMTP del usuario que está experimentando el problema. Para ello, use uno de los métodos siguientes.

Método 1: Usar Consola de administración de Exchange

  1. En el servidor exchange local, abra Consola de administración de Exchange y, a continuación, seleccione Configuración de la organización en Microsoft Exchange Local.
  2. Seleccione la pestaña Relaciones de la organización y, a continuación, vea las propiedades de la relación de la organización.
  3. Seleccione la pestaña Organización externa , escriba el nombre de dominio federado en el cuadro Dominios federados de la organización externa de Exchange y, a continuación, seleccione Agregar.
  4. Repita el paso 3 para cada dominio que quiera agregar.
  5. Seleccione Aceptar.

Método 2: Uso del Shell de administración de Exchange

  1. En el servidor local, abra el Shell de administración de Exchange.

  2. Configure la relación de la organización como una variable. Por ejemplo, ejecute el comando siguiente:

    $OrgRel = Get-OrganizationRelationship Contoso
    
  3. Agregue los nombres de dominio adicionales que desea a la variable. Por ejemplo, ejecute el comando siguiente:

    $OrgRel.DomainNames += "contoso.com"
    
  4. Actualice la relación de la organización mediante el nuevo valor de nombres de dominio. Por ejemplo, ejecute el comando siguiente:

    Set-OrganizationRelationship $OrgRel.Name -DomainName $OrgRel.DomainNames
    

Más información

Para ayudar a identificar el problema en Microsoft 365, siga estos pasos:

  1. Conéctese a Exchange Online mediante PowerShell remoto. Para obtener más información sobre cómo hacerlo, consulte Conexión a Exchange Online PowerShell.

  2. Compare la dirección SMTP del usuario con la relación de la organización. Para comprobarlo, ejecute el siguiente comando:

    if ( (Get-OrganizationRelationship).DomainNames -contains (Get-Mailbox user).PrimarySmtpAddress.Split("@")[1]) { write-host "The domain was found" -ForegroundColor Green } else { write-host (Get-Mailbox user).PrimarySmtpAddress.Split("@")[1] "was not found" -ForegroundColor Yellow}
    

    Nota:

    También puede comparar cada dominio que aparece en los dominios aceptados con los nombres de dominio que se encuentran en la relación de la organización. Para comprobarlo, ejecute el siguiente comando:

    Get-AcceptedDomain | ForEach-Object { if ( (Get-OrganizationRelationship).DomainNames -contains $_.DomainName) { write-host $_.DomainName "was found" -ForegroundColor Green } else { write-host $_.DomainName "was not found" -ForegroundColor Yellow} }
    

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