Rendimiento lento al anclar vistas en Microsoft Dynamics CRM

Este artículo le ayuda a resolver el problema que se produce al anclar vistas en Microsoft Dynamics CRM Cliente para Microsoft Office Outlook.

Se aplica a: Microsoft Dynamics CRM 2011
Número de KB original: 2741514

Síntomas

Microsoft Dynamics CRM Cliente para Microsoft Office Outlook puede funcionar lentamente al anclar vistas.

Causa

Cuando se ancla una vista, los registros de la vista se bajan a la base de datos SQL CE local en {orgid.sdf} y se almacenan en caché. Cuando se anclan las vistas, se presentan a un usuario en la vista de lista y no en las vistas paginadas. Cada vez que se accede a una vista anclada, devuelve los resultados de los archivos .sdf locales.

Estos datos se actualizan periódicamente como un proceso en segundo plano. Si un usuario tiene varias vistas ancladas o en máquinas que no tienen muchos recursos, esto puede provocar problemas de rendimiento y carga lentos.

Resolución

Para evitar que las vistas ancladas quiten información a las memorias caché de SQL CE locales, se puede establecer una clave del Registro en los clientes de Outlook de Microsoft Dynamics CRM 2011. Esto también puede ayudar a reducir el tráfico de red general enviado desde un servidor Microsoft Dynamics CRM 2011 a un equipo cliente de Outlook Microsoft Dynamics CRM 2011.

Cuando este valor se establece en 1, los usuarios todavía tienen la capacidad de anclar las vistas; sin embargo, la consulta se envía al servidor CRM para recuperar los resultados en lugar de desde la caché local.

Importante

Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. En consecuencia, asegúrese de seguir estos pasos cuidadosamente. Para mayor protección, cree una copia de seguridad del registro antes de modificarlo. Después, puede restaurar el registro si se produce un problema. Para obtener más información sobre cómo hacer una copia de seguridad del Registro y cómo restaurarlo, consulte Cómo realizar una copia de seguridad del Registro y restaurarlo en Windows.

Para solucionar este problema, siga estos pasos:

  1. Inicie sesión en las máquinas cliente de Outlook de Microsoft Dynamics CRM 2011 como un usuario que haya instalado el cliente de Outlook de Microsoft Dynamics CRM 2011.
  2. Haga clic en Inicio, haga clic en Ejecutar, escriba regedit y, a continuación, haga clic en Aceptar. Vaya a la clave del Registro, HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient. En el menú Editar, seleccione Nuevo y, a continuación, haga clic en Valor DWORD (32 bits).
  3. Escriba DisableMapiCaching y, a continuación, presione ENTRAR.
  4. Haga clic con el botón derecho en DisableMapiCaching, seleccione Nuevoy, a continuación, haga clic en Valor DWORD.
  5. Haga clic con el botón derecho en DisableMapiCachingy, a continuación, haga clic en Modificar.
  6. En el cuadro Datos de valor , escriba 1 y, a continuación, haga clic en Aceptar.
  7. Salga del Editor del Registro.

Más información

El paquete acumulativo de actualizaciones 6 o posterior debe instalarse para que la clave del Registro DisableMapiCaching funcione. Para obtener más información sobre el paquete acumulativo de actualizaciones 6, consulte KB Microsoft Dynamics CRM paquete acumulativo de actualizaciones 2011 6.

Nota:

Esta clave del Registro no es válida después de aplicar el paquete acumulativo de actualizaciones 14. Esto tendrá que actualizarse mediante la herramienta OrgDbOrgSettings.

Herramienta OrgDBOrgSettings para Microsoft Dynamics CRM 2011