Sysprep se produce un error después de quitar o actualizar aplicaciones de Windows Store que incluyan imágenes integradas de Windows

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Resumen
Este artículo describe un problema que se produce cuando se elimina o se actualiza una aplicación de Windows Store con provisioning mediante el almacén de Windows y, a continuación, ejecute sysprep en el equipo.

Sysprep es una herramienta para administradores de TI que desean para preparar una instalación de Windows para la duplicación, auditoría y entrega al cliente. Las instrucciones de este artículo están destinada a agentes de asistencia y los profesionales de TI. Si eres un usuario doméstico que está encontrando problemas al utilizar aplicaciones de almacén de Windows, consulte los siguientes sitios Web de Windows:
Introducción
Varias aplicaciones de almacén de Windows incluyen imágenes integradas de Windows 10 y Windows 8. Éstos incluyen las aplicaciones de correo, mapas, mensajería, Bing, viajes y noticias, entre otros. Éstos se conocen como aplicaciones de provisioning . Provisioning de aplicaciones se almacenan provisionalmente en la imagen y se programan para ser instalado para todos los usuarios de la imagen de Windows durante el primer inicio. Además de las aplicaciones integradas, se puede cargas laterales en su propia línea de negocios Windows Store apps en la imagen de Windows sin necesidad de publicarlos en el almacén de Windows. Usted puede carga lateral Appx paquetes mediante en línea o comandos que están disponibles en DISM.exe o a través del módulo de PowerShell de DISM de mantenimiento sin conexión.
Síntomas
Considere los escenarios siguientes.

Escenario 1
  • Va a crear un equipo de referencia 10 de Windows o Windows 8 personalizado que desea que la captura y sysprep.
  • Que desee quitar algunas de las aplicaciones de Windows Store (paquetes Appx) con provisioning desde este equipo de referencia.
  • Ejecutar DISM-/ PackageName /Remove-ProvisionedAppxPackage en línea:<packagename></packagename> para dar de baja los paquetes Appx.
Cuando se ejecuta la operación de sysprep en este escenario, la operación puede fallar con el siguiente error:

Herramienta de preparación del sistema 3.14
Error irrecuperable al intentar ejecutar sysprep en el equipo


Escenario 2
  • Tiene una imagen de Windows existente y varias aplicaciones de almacén de Windows están cargado de lado en la imagen.
  • Desea quitar algunos de los paquetes Appx cargado por el lado de la imagen y personalizarlo aún más.
  • Arranque en el equipo de referencia y ejecutar uno de los siguientes comandos de PowerShell para quitar el provisioning del paquete Appx:
    • PackageName: quitar AppxProvisionedPackage<PackageName></PackageName>
    • PackageName: quitar ProvisionedAppxPackage<PackageName></PackageName>
Cuando se ejecuta la operación de sysprep en este escenario, la operación puede fallar con el siguiente error:

Herramienta de preparación del sistema 3.14
Error irrecuperable al intentar ejecutar sysprep en el equipo


Escenario 3
  • Está creando una imagen de referencia 10 de Windows o Windows 8.
  • Se conecta al almacén de Windows 8 o 10 de Windows y, a continuación, actualizar las aplicaciones de Windows Store integradas utilizando el almacén de Windows.
Cuando se ejecuta la operación de sysprep en este escenario, la operación puede fallar con el siguiente error:

Herramienta de preparación del sistema 3.14
Error irrecuperable al intentar ejecutar sysprep en el equipo


Además, en el SetupErr.log, observará las siguientes entradas de error:

<Date><Time>, Error SYSPRP <PackageFullName>el paquete fue instalado para un usuario, pero no está configurado para todos los usuarios. Este paquete no funcionará correctamente en la imagen de sysprep.
<Date><Time>, Error SYSPRP no se pudo quitar aplicaciones para el usuario actual: 0x80073cf2.
<Date><Time>, Código de salida de SYSPRP de error del subproceso de RemoveAllApps es 0x3cf2.
<Date><Time>, Error [0x0f0082] SYSPRP ActionPlatform::LaunchModule: error al ejecutar 'SysprepGeneralize' de C:\Windows\System32\AppxSysprep.dll; dwRet = 0x3cf2
<Date><Time>, Error SYSPRP ActionPlatform::ExecuteAction: Error al ejecutar acción; dwRet = 0x3cf2
<Date><Time>, Error SYSPRP ActionPlatform::ExecuteActionList: Error al ejecutar acciones; dwRet = 0x3cf2
<Date><Time>, Error SYSPRP SysprepSession::Execute: Error al ejecutar acciones de C:\Windows\System32\Sysprep\ActionFiles\Generalize.xml; dwRet = 0x3cf2
<Date><Time>, Error SYSPRP RunPlatformActions: error al ejecutar acciones SysprepSession; dwRet = 0x3cf2
<Date><Time>, Error [0x0f0070] SYSPRP RunExternalDlls: error al ejecutar sysprep del registro dll, detener sysprep ejecución. dwRet = 0x3cf2
<Date><Time>, Error [0x0f00a8] SYSPRP WinMain:Hit error mientras procesamiento sysprep generalize proveedores internos; hr = 0x80073cf2</Time></Date></Time></Date></Time></Date></Time></Date></Time></Date></Time></Date></Time></Date></Time></Date></Time></Date></PackageFullName></Time></Date>
Causa
Sysprep presenta un proveedor adicional que se agrega en Windows 10 y Windows 8 para limpiar los paquetes Appx y generalizar la imagen. El proveedor sólo funciona si el paquete Appx es un paquete de por usuario o un paquete con provisioning de todos los usuarios.
  • Paquete por usuario significa que el paquete Appx está instalado para una cuenta de usuario en particular y no está disponible para otros usuarios del equipo.
  • Paquete de todos los usuarios significa que se haya aprovisionado el Appx en la imagen para que todos los usuarios que usen esta imagen pueden tener acceso a la aplicación.

Si un paquete de todos los usuarios que se aprovisiona en la imagen se desactivan manualmente desde la imagen pero no se quitan de un usuario determinado, el proveedor produce un error al limpiar este paquete durante sysprep. El proveedor también se producirá un error si se actualizó un paquete de todos los usuarios que se aprovisiona en la imagen en uno de los usuarios en este equipo de referencia.
Solución
Para resolver este problema, quite el paquete para el usuario que está ejecutando sysprep y también quitar el provisioning. Para ello, siga estos pasos.

Nota: Para impedir que el almacén de Windows actualizar aplicaciones, desconecte la conexión a Internet o desactivar las actualizaciones automáticas en el modo auditoría antes de crear la imagen.
  1. Ejecute el cmdlet de PowerShell Import-Module Appx .
  2. Ejecutar Dism Import-Module.
  3. Ejecutar Get-AppxPackage - AllUser | Donde PublisherId - eq 8wekyb3d8bbwe | Format-List-propiedad PackageFullName, PackageUserInformation.

    Notas:
    • En la salida de este último cmdlet, compruebe los usuarios para que el paquete aparece como instalado. Eliminar estas cuentas de usuario desde el equipo de referencia, o inicie sesión en el equipo mediante estas cuentas de usuario. A continuación, ejecute el cmdlet en el paso 4 para quitar el paquete Appx.
    • Este comando muestra todos los paquetes que fueron publicados por Microsoft e instalados por cualquier usuario de dicho equipo de referencia. Dado que el equipo va a ser ejecutado Sysprep, suponemos que estos perfiles de usuario ya no necesitan el paquete.
    • Si ha suministrado manualmente aplicaciones que pertenecen a otros editores, ejecute el siguiente comando para que se muestren:

      Get-AppxPackage - AllUser | Format-List-propiedad PackageFullName, PackageUserInformation
  4. Ejecutar Quitar AppxPackage-paquete <packagefullname> </packagefullname> .
  5. Quitar el aprovisionamiento ejecutando el siguiente cmdlet:

    Quitar AppxProvisionedPackage-en línea - PackageName<packagefullname></packagefullname>
Si intenta recuperarse de un problema de actualización, puede aprovisionar la aplicación después de seguir estos pasos.

Nota: El problema no se produce si está manteniendo una imagen sin conexión. En ese caso, el provisioning se borra automáticamente para todos los usuarios. Esto incluye el usuario que ejecuta el comando.
Más información
Para obtener más información acerca de cómo agregar y quitar aplicaciones, consulte los siguientes recursos de TechNet:

Para obtener más información acerca de los cmdlets Appx:

Para obtener más información acerca de Dism Appx mantenimiento cmdlets:


Advertencia: este artículo se tradujo automáticamente

Propiedades

Id. de artículo: 2769827 - Última revisión: 11/06/2015 17:31:00 - Revisión: 3.0

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