No se puede utilizar el controlador ODBC de Access o el proveedor OLEDB fuera de aplicaciones de hacer clic y ejecutar de Office

IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.

Haga clic aquí para ver el artículo original (en inglés): 2874601
Síntomas
Cuando intenta crear un DSN de ODBC para controladores proporcionados por el Administrador de ODBC de orígenes de datos de Microsoft Access, se produce un error en el intento. Este problema se produce si está utilizando una instalación de hacer clic en ejecutar (C2R) de Office. Según la versión de Office, puede aparecer cualquiera de los siguientes problemas cuando intente esta operación:
  • Los controladores ODBC proporcionados por ACEODBC. DLL no se muestran en el cuadro de diálogo Seleccionar un controlador.
  • Recibe un error "el sistema operativo no está actualmente configurado para ejecutar esta aplicación" mensaje.
  • Aparece "No se puede cargar odbcji32.dll" mensaje de error.

Conductores afectados:

  • Controlador de Microsoft Access (*.mdb, *.accdb)
  • Microsoft Access Driver de texto (*.txt, *.csv)
  • Controlador de Microsoft Excel (*.xls, *.xlsx, *.xlsm, *.xlsb)

Además, si intenta definir una conexión OLEDB desde una aplicación externa (uno que se ejecuta fuera de oficina) mediante el proveedor OLEDB de Microsoft.ACE.OLEDB.12.0, encuentra un error "No se encontró el proveedor" cuando intenta conectar con el proveedor.
Causa
Hacer clic para ejecutar instalaciones de Office se ejecutan en un entorno virtual aislado en el sistema operativo local. Algunas aplicaciones fuera de Office pueden no ser conscientes de dónde buscar la instalación en el entorno aislado.

Información general sobre hacer clic y ejecutar para la arquitectura de instalación de Office 365
http://technet.Microsoft.com/en-us/library/jj219420.aspx
Solución
Conexiones ODBC que se utilizará en las aplicaciones de Office

Puede solucionar el problema mediante la creación de un DSN desde dentro de una aplicación de Office, como Access, en lugar de utilizar el Administrador de ODBC. Para crear un nuevo DSN de Access, siga estos pasos:
  1. En la cinta de opciones, seleccione Datos externos > Base de datos ODBC.
  2. SeleccioneImportar o vinculary, a continuación, haga clic en Aceptar.
  3. Seleccione la ficha correspondiente al tipo de DSN que desee crear (Origen de datos de archivoo Machine Data Source) y, a continuación, haga clic ennuevo.
  4. Seleccione el adecuado driveralong con cualquier información necesaria para completar la entrada.
  5. Se crea Afterthe DSN, haga clic en Cancelar para salir de los pasos restantes de importar o vincular.
  6. El DSN debería aparecer ahora en el Administrador de ODBC, y puede utilizarlo en cualquier aplicación de Office.
ODBC u OLEDB Microsoft.ACE.OLEDB.12.0 las conexiones del proveedor que se va a utilizar fuera de la oficina

Debe instalar una instalación de MSI de motor de base de datos de Microsoft Access desde uno de los siguientes orígenes para que puedan encontrar la aplicación que llama el controlador y el proveedor.

Base de datos de Microsoft Access redistribuible del motor de 2010
https://www.Microsoft.com/en-us/download/details.aspx?ID=13255

En tiempo de ejecución de Microsoft Access de 2013
http://www.Microsoft.com/en-us/download/details.aspx?ID=39358

Nota: es un artículo de "PUBLICACIÓN RÁPIDA" creado directamente por la organización de soporte técnico de Microsoft. La información aquí contenida se proporciona como está, como respuesta a problemas que han surgido. Como consecuencia de la rapidez con la que lo hemos puesto disponible, los materiales podrían incluir errores tipográficos y pueden ser revisados en cualquier momento sin previo aviso. Vea las Condiciones de uso para otras consideraciones

Advertencia: este artículo se tradujo automáticamente

Propiedades

Id. de artículo: 2874601 - Última revisión: 06/27/2016 21:21:00 - Revisión: 2.0

Access 2016, Microsoft Access 2013, Microsoft Access for Office 365

  • kbmt KB2874601 KbMtes
Comentarios