Secuencia de tareas se produce un error en el Administrador de configuración si las actualizaciones de software requieren varios reinicios

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Síntomas
Supongamos que una secuencia de tareas de Microsoft System Center Configuration Manager que usa el paso "Instalar Software Updates" instala una actualización de software que activa reiniciarlo varias veces después de la secuencia de tareas funciona correctamente la tarea de instalar actualizaciones de Software. En esta situación, la secuencia de tareas puede fallar y generar el mensaje de error siguiente:

Entorno de secuencia de tareas que no se encuentra

Nota: Puede evitar este problema en System Center 2012 configuración Manager Service Pack 2 y Service Pack 1 de System Center 2012 R2 configuración Manager utilizando la nueva opción de reintento en el paso de secuencia de tareas de Instalar actualizaciones . Para obtener más información, consulte la Instalar actualizaciones de Software documentación en el sitio Web de Microsoft TechNet.
Causa
El primer reinicio iniciados por la actualización de software está controlado por la secuencia de tareas. Sin embargo, la segunda solicitud de reinicio es iniciada por un componente de Windows (normalmente, modelo de servicio basado en componentes) y no se controla mediante la secuencia de tareas. Por lo tanto, el estado de ejecución de la secuencia de tareas no se guarda antes del reinicio, ya que en el segundo reinicio no está controlado por la secuencia de tareas. Cuando la secuencia de tareas se reanuda después del segundo reinicio, ningún estado es disponible para continuar correctamente.
Solución
Para resolver este problema, recomendamos que aplique las actualizaciones que requieren reinicios duales mediante la característica habitual de las actualizaciones de Software de Configuration Manager en lugar de utilizar las secuencias de tareas. Las actualizaciones de software siguientes se comunicaron a requerir varios reinicios.

Nota: En este artículo seguirá actualizarse por medio de mayo de 2016. A continuación, los niveles de Configuration Manager Service Pack que se mencionan en la sección "Se aplica a" caen fuera del periodo de soporte técnico. Para obtener más información, consulte la Directiva de ciclo de vida de soporte técnico de Microsoft.

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Más información
Dado que este segundo reinicio no está controlado por la secuencia de tareas, se guarda el estado de ejecución antes del reinicio. Cuando la secuencia de tareas se reanuda después del reinicio, ningún estado es disponible para continuar correctamente. Además, puede anotarse el mensaje siguiente en el archivo Smsts.log cuando experimenta este problema:

! sVolumeID.empty(), HRESULT = 80004005
! sTSMDataPath.empty(), HRESULT = 80070002
TS::Utility::GetTSMDataPath (sDataDir), HRESULT = 80070002
No se pudo establecer el directorio de registro. Se pueden perder algunos historial de ejecución.
El sistema no puede encontrar el archivo especificado. (Error: 80070002; Código fuente: Ventanas)
Ejecutar la secuencia de tareas
! sVolumeID.empty(), HRESULT = 80004005
! sTSMDataPath.empty(), HRESULT = 80070002
Entorno de secuencia de tareas que no se encuentra

Además, los clientes que ejecutan versiones anteriores a Service Pack 1 de Microsoft System Center 2012 configuración Manager pueden contener la siguiente entrada del registro:

Secuencia de tareas que completar en Windows PE.

Nota: El equipo cliente también puede bloquearse en el modo de aprovisionamiento cuando se produce un error en la secuencia de tareas. Para determinar si el equipo está en modo de aprovisionamiento, compruebe la siguiente subclave del registro:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\CCM\CcmExec


ProvisioningMode debe establecerse en false. Si se establece en true, utilice uno de los métodos siguientes para que al cliente del modo de aprovisionamiento:
  • Utilice el método de Instrumental de administración de Windows (WMI) SetClientProvisioningMode para que al cliente del provisioning modo correctamente. La forma más sencilla de hacerlo es ejecutar el siguiente comando de Windows PowerShell:
    Invoke-WmiMethod -Namespace root\CCM -Class SMS_Client -Name SetClientProvisioningMode -ArgumentList $false
    O bien, ejecute el comando siguiente en un símbolo del sistema con privilegios elevados:

    powershell Invoke-WmiMethod -Namespace root\CCM -Class SMS_Client -Name SetClientProvisioningMode -ArgumentList $false
  • Vuelva a instalar al cliente.
Importante: No intente reparar al cliente cambiando el valor de ProvisioningMode en false. Esta acción no tendrá totalmente el cliente del modo de aprovisionamiento.

Advertencia: este artículo se tradujo automáticamente

Propiedades

Id. de artículo: 2894518 - Última revisión: 02/12/2016 00:00:00 - Revisión: 9.0

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