Excel: Cómo solucionar los mensajes de error "Se produjo un error al enviar los comandos al programa"

IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.

Haga clic aquí para ver el artículo original (en inglés): 3001579
Síntomas
En Microsoft Excel, una de las siguientes condiciones es verdadera:
  • El libro de Excel intenta obtener acceso a datos desde otra aplicación que todavía está activo.
  • Demasiados complementos de Excel se han agregado al programa o está dañado uno de los complementos.
  • Tome una de las siguientes acciones:
    • Activar un botón que se crea mediante un complemento de terceros o una aplicación
    • Intentar abrir un objeto incrustado
    • Guardar o abrir un archivo
    • Intentar utilizar el envío como opción de conexión
    • Llamar a otra aplicación desde el libro de Excel
En este escenario, recibirá el siguiente mensaje de error:

Se produjo un error al enviar los comandos al programa
Causa
Este error indica que algún proceso que se ejecuta dentro de Excel no permitirá cerrar Excel. Hay muchas razones posibles que se produce este error. Debe comprender su entorno para determinar cuál de los métodos en la sección "Resolución" funcionará mejor para usted.
Solución
Para resolver este problema, pruebe los métodos siguientes, según corresponda, en el orden especificado.

Método 1: Omitir DDE

Este problema puede producirse si está activada la casilla de verificación Omitir otras aplicaciones que utilizan intercambio dinámico de datos (DDE) en Opciones de Excel.

Cuando hace doble clic en un libro de Excel en el Explorador de Windows, un mensaje de intercambio dinámico de datos (DDE) se envía a Excel. Este mensaje indica a Excel que abra el libro en el que hizo doble clic.

Si selecciona la opción "Omitir", Excel omite los mensajes DDE que otros programas le envían. Por lo tanto, se omite el mensaje DDE que el Explorador de Windows envía a Excel y Excel no abre el libro en el que hizo doble clic.

Para corregir esta configuración, siga estos pasos:
  1. En el menú Herramientas, haga clic en Opciones.
  2. Haga clic en la ficha General.
  3. Desactive el Omitir otras aplicaciones que utilizan intercambio dinámico de datos (DDE) casilla de verificacióny, a continuación, haga clic en Aceptar.
Nota: para obtener más información acerca de cómo desactivar la opción DDE, consulte el siguiente artículo de Microsoft Knowledge Base:

Si estos pasos no resuelven el problema, vaya al método 2.

Método 2: Reparar la virtualización de la experiencia de usuario (UE-V)

Si está ejecutando la virtualización de experiencia de usuario de actualización (UE-V), instale la revisión 2927019. Para ello, consulte el siguiente artículo de Microsoft Knowledge Base:

Si no está seguro de si se está ejecutando la UE V, examine la lista de programas el elemento Programas y características en el Panel de Control. Una entrada para el "Centro de configuración de compañía" indica que se está ejecutando UE-V.

Si estos pasos no resuelven el problema, vaya al método 3.

Método 3: Restablecer asociaciones de archivo

Para comprobar si las asociaciones de archivos en el sistema se están realizando correctamente, restablezca las asociaciones de archivo de Excel a su configuration predeterminada. Para ello, siga los pasos para su sistema operativo.
Windows 8
  1. En la pantalla de inicio, escriba Panel de control.
  2. Haga clic o puntee en Panel de Control.
  3. Haga clic en Programas predeterminados y, a continuación, haga clic en establecer programas predeterminados.
  4. Haga clic en Excel y, a continuación, haga clic en elegir predeterminado para este programa.
  5. En la pantalla Establecer asociaciones de programa , haga clic en Seleccionar todo y, a continuación, haga clic en Guardar.
Windows 7
  1. Haga clic en Inicio y a continuación haga clic en Panel de control.
  2. Haga clic en Programas predeterminados.
  3. Haga clic en Asociar un tipo de archivo o protocolo con un programa específico.
  4. Seleccione Hoja de cálculo de Microsoft Excel y, a continuación, haga clic en Cambiar programa.
  5. En Programas recomendados, haga clic en Microsoft Excel.
  6. Si Excel no aparece en esta lista, haga clic en Examinar, busque la carpeta de instalación de Excel, Excel.exe y, a continuación, haga clic en Excel.
Si estos pasos no resuelven el problema, vaya al método 4.

Método 4: Reparar Office

Intente reparar los programas de Office. Para ello, siga los pasos para su sistema operativo y el tipo de instalación.
Para una instalación de hacer clic y ejecutar de Office 365
Windows 8
  1. En la pantalla de inicio, escriba Panel de control.
  2. Haga clic o puntee en Panel de Control.
  3. En Programas, haga clic o puntee en desinstalar un programa.
  4. Haga clic o puntee en Microsoft Office 365y haga clic o puntee en Cambiar.
  5. Haga clic o puntee En línea de reparación, haga clic en o puntee en Reparación. Tendrá que reiniciar el equipo después de que termine el proceso de reparación.
Windows 7
  1. Haga clic en Inicio y a continuación haga clic en Panel de control.
  2. Haga doble clic en Programas y características.
  3. Haga clic en Microsoft Office 365 y, a continuación, haga clic en Cambiar.
  4. Seleccione Reparar en línea y, a continuación, haga clic en Reparar.

    Nota: tendrá que reiniciar el equipo una vez completado el proceso reparación.

    Reparación de Office
Para una oficina de 2016 2013, Office 2010 o instalación de Office 2007
Para reparar Office 2013, Office 2010 o 2007 Office, siga los pasos descritos en el siguiente tema del sitio Web de Office:

Si estos pasos no resuelven el problema, vaya al método 5.

Método 5: Desactivar complementos

Complementos de programas de Excel y COM también pueden provocar este problema. Estos dos tipos de complementos se encuentran en carpetas diferentes. Para pruebas, deshabilite y aisle el conflicto desactivando cada complemento de uno en uno. Para ello, siga estos pasos:
  1. En el menú Archivo , haga clic en Opciones y, a continuación, haga clic en Complementos.
  2. En la lista Administrar , en la parte inferior de la pantalla, seleccione elemento de Complementos COM y, a continuación, haga clic en Ir.
  3. Borre uno de los complementos en la lista y, a continuación, haga clic en Aceptar.
  4. Reinicie Excel haciendo doble clic en el icono o nombre de archivo del libro que está intentando abrir.
  5. Si el problema persiste, repita los pasos 1 a 4, pero seleccione un complemento diferente en el paso 3.
  6. Si el problema persiste después de desactivar todos los complementos COM, repita los pasos 1 a 4, pero seleccione Complementos de Excel en el paso 2 e inténtelo de cada uno de los complementos de Excel uno a la vez en el paso 3.
Si Excel carga el archivo, el último complemento desactivado es el que está causando el problema. Si éste es el caso, le recomendamos que visite el sitio Web del fabricante para saber si está disponible una versión actualizada del complemento. Si no está disponible una versión más reciente del complemento, o si usted no tiene que utilizar el complemento, puede dejarla desactivada.

Si Excel no abre el archivo después de desactivar todos los complementos, el problema tiene una causa diferente.

Si estos pasos no resuelven el problema, vaya al método 6.

Método 6: Deshabilite la aceleración de hardware

Para evitar este problema, deshabilite la aceleración de hardware hasta que se publique una revisión por el fabricante de la tarjeta de vídeo. Asegúrese de que compruebe periódicamente si hay actualizaciones para el controlador de la tarjeta de vídeo.

Para deshabilitar la aceleración de hardware, siga estos pasos:
  1. Inicie cualquier programa de Office de 2013.
  2. En la ficha Archivo, haga clic en Opciones.
  3. En el cuadro de diálogo Opciones, haga clic en Opciones avanzadas.
  4. En la lista de opciones disponibles, seleccione la casilla de verificación Deshabilitar la aceleración de gráficos de hardware.

    Captura de pantalla siguiente muestra esta opción en Excel.

    deshabilitar la aceleración de hardware
  5. Haga clic en Aceptar.
Nota: Para obtener más información sobre la aceleración de hardware, consulte el siguiente artículo de Microsoft Knowledge Base:

Si estos pasos no resuelven el problema, vaya al método 6.

Método 7: Comprobar o instalar las actualizaciones más recientes

Tendrá que configurar Windows Update para descargar e instalar las actualizaciones recomendadas automáticamente. Instalar las actualizaciones importantes, recomendadas y opcionales con frecuencia puede corregir problemas por el reemplazo de archivos no actualizados y repara vulnerabilidades.

Para obtener más información acerca de las actualizaciones de Office, haga clic en el número de artículo siguiente para ir al artículo de Microsoft Knowledge Base:

Si sigue experimentando este problema después de haber intentado todos estos métodos, póngase en contacto con Soporte técnico de Microsoft Para obtener ayuda adicional para solucionar problemas.
Más información
Para obtener más información acerca de este problema y los pasos adicionales de solución de problemas, consulte los siguientes artículos de Microsoft Knowledge Base:

Espacio en blanco de Excel abierto haga doble clic en DDE XL UE-V problema al enviar el comando al programa espera ole Microsoft Excel está esperando que otra aplicación complete una errmsg de mensaje de error OLE acción Office

Advertencia: este artículo se tradujo automáticamente

Properties

Article ID: 3001579 - Last Review: 11/10/2016 22:01:00 - Revision: 13.0

Microsoft Excel 2013, Microsoft Excel 2010, Microsoft Office Excel 2007, Excel 2016

  • kbsurveynew kbprb kbexpertiseinter kberrmsg kbmt KB3001579 KbMtes
Feedback