Estás trabajando sin conexión, espera a que vuelva la conexión a Internet

CÓMO: Crear, modificar y ejecutar procedimientos almacenados en Visual InterDev

Este artículo se publicó anteriormente con el número E301072
Resumen
En este artículo se muestra cómo crear, modificar y ejecutar procedimientos almacenados en SQL Server mediante Visual InterDev 6.0.

Tenga en cuenta que puede utilizar la ventana DataView en Visual InterDev si no dispone del Administrador empresarial de SQL Server para modificar los procedimientos almacenados.

volver al principio

Requisitos

    • Visual InterDev 6.0 Enterprise Edition
    • SQL Server 7 o posterior
volver al principio

Crear un proyecto nuevo en Visual InterDev

  1. En el menú Archivo de Visual InterDev, haga clic en Proyecto.
  2. En la ventana Explorador de proyectos, haga clic con el botón secundario del mouse (ratón) en el archivo Global.asa y, después, haga clic en Agregar conexión de datos.
  3. En el cuadro de diálogo Propiedades del vínculo de datos, indique la información de conexión del servidor SQL Server y haga clic en Probar conexión.
  4. En el menú Ver, haga clic en Otras ventanas y, después, haga clic en Vista de datos.
  5. En la ventana Vista de datos, expanda la base de datos y, después, expanda Procedimientos almacenados.
volver al principio

Agregar un nuevo procedimiento almacenado

  1. En la ventana Vista de datos, haga clic con el botón secundario del mouse (ratón) en Procedimientos almacenados y, después, haga clic en Nuevo procedimiento almacenado en el menú contextual.
  2. Cree un procedimiento almacenado mediante la plantilla incluida en la ventana.NOTA: en su lugar, puede utilizar el Generador de consultas para crear la instrucción SQL para un procedimiento almacenado si hace clic con el botón secundario del mouse (ratón) en la ventana y selecciona Insertar SQL.

    • Para agregar tablas al Generador de consultas, arrastre tablas desde la ventana Vista de datos hasta el panel superior de la ventana Generador de consultas.
    • Para probar los procedimientos almacenados en la ventana Generador de consultas, en el menú Consulta, haga clic en Ejecutar.
  3. : en su lugar, puede utilizar el Generador de consultas para crear la instrucción SQL para un procedimiento almacenado si hace clic con el botón secundario del En el menú Archivo, haga clic en Guardar<nombre del procedimiento almacenado>.
volver al principio

Modificar un procedimiento almacenado

  1. Expanda Procedimientos almacenados en la ventana Vista de datos.
  2. Haga clic con el botón secundario del mouse (ratón) en el procedimiento almacenado que desee modificar y, después, haga clic en Abrir en el menú contextual. Haga los cambios necesarios.

    NOTA: en su lugar, puede invocar el Generador de consultas para modificar un procedimiento almacenado si selecciona la consulta en Procedimientos almacenados en la ventana Vista de datos y hace clic en Modificar SQL.
  3. En el menú Archivo, haga clic en Guardar<nombre del procedimiento almacenado>.
volver al principio

Ejecutar un procedimiento almacenado

  1. Expanda Procedimientos almacenados en la ventana Vista de datos.
  2. Haga clic con el botón secundario del mouse (ratón) en un procedimiento almacenado y, después, haga clic en Ejecutar en el menú contextual.

    Si el procedimiento almacenado requiere parámetros de entrada, escríbalos en el cuadro de diálogo Ejecutar que aparecerá.Los resultados del procedimiento almacenado se mostrarán en la ventana de resultados.
NOTA: en su lugar, puede utilizar la ventana Generador de consultas para ejecutar el procedimiento almacenado. Para ello, abra el Generador de consultas y, después, en el menú Consulta, haga clic en Ejecutar.

volver al principio
Propiedades

Id. de artículo: 301072 - Última revisión: 03/11/2004 22:53:55 - Revisión: 3.1

  • Microsoft SQL Server 2000 Standard Edition
  • Microsoft SQL Server 7.0 Standard Edition
  • Microsoft Visual InterDev 6.0 Standard Edition
  • kbgrpdsvbdb kbhowtomaster KB301072
Comentarios