Se produce el error "No se puede comunicar con el servicio Active Directory de Windows Azure" en el Asistente para sincronización de DAA

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Síntomas
Si su entorno incluye un servidor proxy no autenticado, el Asistente de Microsoft Azure servicios Active Directory Sync (sincronización de DAA) muestra el siguiente mensaje de error de configuración:

Listo para configurar.

Se ha recopilado información suficiente para configurar la sincronización de AD de Azure y va a crear una configuración predeterminada.

No se pudo incluso después de 5 intentos. Acción: PingProvisioningServiceEndPoint, excepción: no se puede comunicar con el servicio Active Directory de Windows Azure. Id. de seguimiento: 01601250-7951-469c-8973-34e2a8e1ca10 ver el registro de sucesos para obtener más detalles...

La siguiente captura de pantalla muestra el mensaje de error.

La captura de pantalla del mensaje de error

Además, una traza de Monitor de red (Netmon.exe) indica que el Asistente de inicio de sesión de Microsoft Online Services utiliza al servidor proxy y tiene acceso a login.microsoftonline.com.

Cuando se produce este problema, se registra una entrada de 906 de Error similar al siguiente en el registro de AADSync. Esta entrada indica que DAA sincronización intenta realizar una conexión directa a Internet.

AzureActiveDirectoryDirectorySyncTool Error: 906: System.Management.Automation.CmdletInvocationException: error incluso después de 5 intentos. Acción: PingProvisioningServiceEndPoint, excepción: no se puede comunicar con el servicio Active Directory de Windows Azure. Id. de seguimiento: 90edf657-f63e-46cc-94ec-df88817f4c73 ver el registro de sucesos para obtener más detalles... ---> Microsoft.IdentityManagement.PowerShell.ObjectModel.SynchronizationConfigurationValidationException: error incluso después de 5 intentos. Acción: PingProvisioningServiceEndPoint, excepción: no se puede comunicar con el servicio Active Directory de Windows Azure. Id. de seguimiento: 90edf657-f63e-46cc-94ec-df88817f4c73 ver el registro de sucesos para obtener más detalles...
Causa
Este problema se produce porque el 4.5 de.NET Framework en el que se basa la DAA Sync no reconoce la configuración de proxy de cliente.
Solución
Para resolver el problema, cambie el siguiente archivo:
C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config\machine.config
Para ello, agregue el texto siguiente:

<system.net>    <defaultProxy>      <proxy        usesystemdefault="true"        proxyaddress="http://<PROXYIP>:80"        bypassonlocal="true"      />    </defaultProxy>  </system.net>
Notas:
  • Este texto debe escribirse en la parte inferior del archivo.
  • En este código, <PROXYIP></PROXYIP> representa la dirección IP de proxy real. Para obtener más información acerca de la configuración de proxy, vea Element (Network Settings).

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Propiedades

Id. de artículo: 3013032 - Última revisión: 08/31/2015 21:36:00 - Revisión: 3.0

Microsoft Azure Active Directory

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