Error "Acceso denegado" al intentar acceder a una carpeta compartida

Síntomas

Imagine la siguiente situación:

  • Tiene un sitio de SharePoint o OneDrive.
  • El sitio tiene activada la característica de recopilación de sitios del modo de bloqueo de usuario de acceso limitado .
  • Puede compartir una carpeta específica con otro usuario.
  • El otro usuario intenta acceder a la carpeta compartida.

En este scanario, el otro usuario recibe uno de los siguientes mensajes de error:

  • Acceso denegado
  • Necesita permiso para acceder a este recurso.

Causa

Al compartir una carpeta con un usuario que no puede acceder a la carpeta primaria o al sitio, SharePoint asigna al usuario acceso limitado a los elementos primarios. En concreto, SharePoint permite al usuario tener acceso a la carpeta sin obtener permiso para acceder a la carpeta principal y otros elementos (aparte del acceso limitado). Sin embargo, cuando está habilitado el modo de bloqueo de permisos de usuario de acceso limitado , el usuario no tiene acceso a la carpeta porque el permiso de acceso limitado necesario para otros elementos ya no funciona correctamente.

Solución alternativa

Para solucionar este problema, use una de las siguientes opciones, según corresponda para su situación:

  • Compartir archivos individuales, pero no carpetas.

  • Compartir toda una colección de sitios o un subsitio.

  • Si el sitio no requiere el modo de bloqueo de permisos de usuario de acceso limitado, deshabilite esta característica de recopilación de sitios.

    Nota: Otras características, como la publicación, pueden requerir que esta característica funcione correctamente.