Errores del servicio de acceso de clientes RPC y 4999 de evento se registra en Exchange Server 2013

IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.

Haga clic aquí para ver el artículo original (en inglés): 3061079
Síntomas
Cuando se tiene acceso a determinados mensajes de correo electrónico con Microsoft Outlook en modo en línea, el servicio de acceso de cliente de RPC se bloquea o se reinicia inesperadamente. Cuando esto ocurre, se registran los siguientes errores en el registro de sucesos.

Nota: A veces, el servicio no se bloquea incluso aunque todavía se registra una entrada para el evento.

Nombre de registro: aplicación
Origen: común de MSExchange
Fecha: [hora de ocurrencia]
ID. de suceso: 4999
Categoría de tarea: General
Nivel: Error
Palabras clave: clásico
Usuario: N/D
Equipo: [NombreEquipo]
Descripción:
Informe de Watson va a enviar para el id de proceso: 1852, con parámetros: E12IIS, c-RTL-AMD64, 15.00.1076.009, M.E.RpcClientAccess.Service, desconocido, M.E.D.T.I.F.F.TextStore.AddText, System.IndexOutOfRangeException, 5453, desconocido.
ErrorReportingEnabled: False

Lo siguiente se graba en los registros RCA que se guardan en la ubicación siguiente:

Acceso de cliente de C:\Program programa\Microsoft\Exchange Server\V15\Logging\RPC

2015-04-23T19:05:35.961Z,3,603,/o=<id>/ou=exchange administrative group(fydibohf23spdlt)/cn=recipients/cn=5dd9b1444df54688b0d2367fbc5e47aa-crashmbx,,OUTLOOK.EXE,15.0.4711.1000,Classic,,,,ncacn_http,Client=MSExchangeRPC,,,,fault,00:00:00.2970000,,"Watson: [IndexOutOfRangeException] Index was outside the bounds of the array. at M.E.D.TextConverters.Internal.Format.FormatStore.TextStore.AddText(TextRunType runType, Char[] textBuffer, Int32 offset, Int32 count) at M.E.D.TextConverters.Internal.Format.FormatStore.AddMarkupText(Char[] textBuffer, Int32 offset, Int32 count) at M.E.D.TextConverters.Internal.Html.HtmlFormatConverterWithEncapsulation.OutputEncapsulatedMarkup() at M.E.D.TextConverters.Internal.Html.HtmlFormatConverterWithEncapsulation.Process(HtmlTokenId tokenId) at M.E.D.TextConverters.ConverterStream.Read(Byte[] buffer, Int32 offset, Int32 count) at M.E.D.TextConverters.Internal.RtfCompressed.RtfCompressCommon.ReadMoreData() at M.E.D.TextConverters.Internal.RtfCompressed.RtfCompressConverter.Run() at M.E.D.TextConverters.ConverterStream.Read(Byte[] buffer, Int32 offset, Int32 count) at M.E.D.S.BodyReadStream.<>c__DisplayClassb.<Read>b__a() at M.E.D.S.ConvertUtils.<>c__DisplayClass1`1.&lt;CallCtsWithReturnValue>b__0() at M.E.D.S.ConvertUtils.CallCts(Trace tracer, String methodName, LocalizedString exceptionString, CtsCall ctsCall) at M.E.D.S.ConvertUtils.CallCtsWithReturnValue[T](Trace tracer, String methodName, LocalizedString exceptionString, CtsCallWithReturnValue`1 ctsCall) at M.E.D.S.BodyReadStream.Read(Byte[] buffer, Int32 offset, Int32 count) at M.E.D.S.Util.StreamHandler.CopyStreamData(Stream readStream, Stream writeStream, Nullable`1 numBytes, Int32 t",,,.in,
Causa
El problema se debe a un error lógico que se produce en la clase TextConvertercuando TextConverter realiza una operación de copia de búfer.
Solución
Para evitar este problema, identificar el buzón que ha causado que el servicio vertizby con los registros de RCA. A continuación, le recomendamos que tiene el usuario changetheir Outlook configuración de buzón en modo en línea a modo de caché.

Además, asegúrese de que el usuario no copiar o mover mensajes de correo electrónico específicos a una carpeta local, o .pst directamente o mediante una regla de Outlook. Para determinar el mensaje que está causando el problema, copiar o mover todos los mensajes al archivo .pst uno a la vez. El mensaje no moveis en el una es causa del problema. Este problemcauses una pérdida de servicio de acceso de cliente de pérdida o causestheRPC de conectividad con el bloqueo.
Estado
Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Advertencia: este artículo se tradujo automáticamente

Propiedades

Id. de artículo: 3061079 - Última revisión: 08/10/2015 17:33:00 - Revisión: 2.0

Microsoft Exchange Server 2013 Standard, Microsoft Exchange Server 2013 Enterprise

  • kbqfe kbsurveynew kbmt KB3061079 KbMtes
Comentarios