Los archivos están dañados en desduplicados volúmenes que se crearon como compresión NTFS

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Síntomas
Los usuarios ya no pueden abrir archivos en un volumen habilitado para desduplicación creado por tener la compresión NTFS está habilitada en la raíz del volumen. Además, el trabajo de limpieza de desduplicación de datos puede registrar un suceso en el registro de sucesos a la corrupción de informe sobre el volumen de los archivos no se puede reparar.
Causa
Este problema se produce porque los metadatos de desduplicación que se almacenan en la raíz del volumen comprimido queda dañado cuando un proceso escribe en el lugar a un archivo en el volumen deduplicado. Los metadatos de desduplicación que se almacenan en la raíz del volumen comprimido se encuentran en la carpeta información de volumen del sistema (SVI).

No se admite la duplicación en los volúmenes que tienen compresión habilitada en la raíz cuando se crea el volumen. Sin embargo, la deduplicación en carpetas comprimidas es compatible y funciona como se esperaba.
Solución
Para resolver este problema, no habilite la desduplicación de datos en un volumen NTFS que tiene habilitada la compresión de nivel de volumen.

Desafortunadamente, nosotros no podemos restaurar datos ya está dañados en volúmenes comprimidos existentes que tengan habilitada la deduplicación. Los archivos que ya se han dañado deben restaurarse desde copias de seguridad, si están disponibles.

Para descomprimir la carpeta de metadatos de desduplicación para que las acciones de escritura a archivos deduplicados en este volumen ya no están dañadas, siga estos pasos.

Nota: En los comandos de ejemplo <X></X> es un volumen que se ha creado como comprimido y que tenga habilitada la desduplicación de datos.
  1. Descargar la herramienta PsExec desde el siguiente sitio Web de Windows Sysinternals:

    Nota: La herramienta PsExec permite a los usuarios ejecutar procesos por tener derechos de usuario "Sistema". Esto es necesario para tener acceso a la carpeta de metadatos de desduplicación de datos protegida que se encuentra en la carpeta System Volume Information.
  2. Bloquear el acceso a los datos de los usuarios en el volumen afectado. Para ello, ejecute el siguiente de Windows PowerShell deshabilitar dedupvolume comando:

    disable-dedupvolume X: -dataaccess
    Notas:
    • Este comando se desmonta y, a continuación, vuelve a montar el volumen sin el filtro de desduplicación de datos adjuntado. Esto impide que los usuarios tengan acceso a los archivos deduplicados.
    • La acción de desmontar invalida los identificadores de archivo abiertos en este volumen.
  3. Utilizar PsExec para ejecutar Cmd.exe como usuario "Sistema". Para ello, ejecute el siguiente comando:

    Psexec.exe –i –s cmd
    Nota: Ahora se abrirá la ventana de símbolo del sistema al tener asignados derechos de usuario "Sistema".

    Precaución La cuenta "SYSTEM" es una cuenta de usuario que tiene un nivel mucho mayor de acceso a una cuenta de administrador. Los usuarios deben tener cuidados realizar los pasos que se mencionan en el artículo mientras se ejecutan en la cuenta "SYSTEM". Los usuarios deben ser especialmente cuidados de no cambiar las ACL o tomar posesión de la carpeta System Volume Information.
  4. En la ventana de símbolo del sistema de PsExec, busque la carpeta System Volume Information del volumen afectado.
  5. Compruebe que la carpeta de metadatos de desduplicación del volumen se comprime actualmente.
  6. Descomprimir la carpeta de metadatos de desduplicación del volumen.
  7. En la ventana de símbolo del sistema de PsExec, ejecute el comando siguiente:

    X:\System Volume Information>compact /s:Dedup

    El resultado incluye el siguiente mensaje de resumen:

    De los archivos en directorios de N M

    <X>se comprimen y <Y>no se comprimen.</Y></X>

    If <X></X>es mayor que cero (0), vaya al paso 8. De lo contrario, vaya al paso 11 porque la carpeta de metadatos de deduplicación no está comprimida.
  8. En la ventana de símbolo del sistema de PsExec, ejecute el comando siguiente:

    X:\System Volume Information>compact /u /s:Dedup
  9. Espere a que la carpeta de metadatos de desduplicación ser descomprimido. El proceso funciona en un archivo a la vez y puede ser muy lento.

    Nota: El tiempo que requiere este proceso es proporcional a la cantidad de datos que se encuentra en el volumen. Para los volúmenes que contienen terabytes de datos, este proceso puede tardar varias horas en Finalizar. Al finalizar, el comando sale y genera el siguiente mensaje de estado:

    Archivos de N en M directorios han sido descomprimidos.
  10. En la ventana de símbolo del sistema de PsExec, ejecute el siguiente comando para comprobar que no hay ningún archivo comprimido en la carpeta de metadatos de desduplicación de datos "Mostrar estado de compresión".

    X:\System Volume Information>compact /s:Dedup
  11. Cierre la ventana de símbolo del sistema de PsExec.
  12. Vuelva a habilitar el acceso a los datos de los usuarios en el volumen afectado. Para ello, ejecute el siguiente comando:

    Enable-DedupVolume X: -DataAccess
    Notas:
    • Este comando se desmonta y, a continuación, vuelve a montar el volumen con el filtro de desduplicación de datos adjuntado. Ahora, los usuarios podrán acceder a los archivos deduplicados.
    • La acción de desmontar invalida los identificadores de archivo abiertos en este volumen.
    Para obtener más información acerca de este comando de Windows PowerShell, visite el siguiente sitio Web de MSDN:

Nota: Para evitar daños similares se produzca, realice este procedimiento en todos los volúmenes habilitado de desduplicación que se crearon como comprimido.

Advertencia: este artículo se tradujo automáticamente

Propiedades

Id. de artículo: 3066174 - Última revisión: 07/26/2015 08:28:00 - Revisión: 3.0

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