Estás trabajando sin conexión, espera a que vuelva la conexión a Internet

No puede enviar datos adjuntos grandes mediante el cliente EWS

IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.

Haga clic aquí para ver el artículo original (en inglés): 3107326
Síntomas
Considere el siguiente escenario:
  • Un usuario se conecta a su buzón mediante un cliente de Exchange Web Services (EWS).
  • El buzón del usuario se encuentra en el sitio B.
  • El cliente se conecte a un servidor de Microsoft Exchange en el sitio A.
  • El servidor de Exchange en los servidores proxy de sitio A la solicitud a un servidor de Exchange en el sitio B.

En este escenario, el usuario no puede enviar un correo electrónico que incluye datos adjuntos grandes. Cuando utiliza Outlook para el cliente de Mac, mueve el mensaje a la carpeta de borradores y devuelve el error siguiente:

An unknown error has occurred. Connection to the server failed or was dropped. Outlook cannot send the message, because the message size exceed the maximum limit set on the server


EWS inicia por sitio una presentación con un estado de error HTTP 500 con un error genérico que se parece al siguiente:

ReportException_Message=Exchange Web Services are not currently available for this request because none of the Client Access Servers in the destination site could process the request.;ReportException_StackTrace= at Microsoft.Exchange.Services.Wcf.EWSService.GetServiceAsyncResult[TSoapResponseBody](IAsyncResult result) at Microsoft.Exchange.Services.Wcf.EWSService.CreateSoapResponse[TSoapResponse;TSoapResponseBody](IAsyncResult result; Func`2 createSoapResponseCallback) at AsyncInvokeEndEndCreateItem(Object ; Object[] ; IAsyncResult ) at System.ServiceModel.Dispatcher.AsyncMethodInvoker.InvokeEnd(Object instance; Object[]& outputs; IAsyncResult result) at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeEnd(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage7(MessageRpc& rpc) at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet);

Los registros de EWS para el sitio B muestran un estado de error HTTP 500 con un error genérico que se parece al siguiente:

ReportException_Message=The remote host closed the connection. The error code is 0x80070057.;ReportException_StackTrace= at System.ServiceModel.Channels.HttpOutput.HostedRequestHttpOutput.HostedResponseOutputStream.CheckWrapThrow(Exception e) at System.ServiceModel.Channels.HttpOutput.HostedRequestHttpOutput.HostedResponseOutputStream.Write(Byte[] buffer; Int32 offset; Int32 count) at System.IO.BufferedStream.FlushWrite() at System.IO.BufferedStream.Flush() at System.Xml.XmlStreamNodeWriter.Flush() at Microsoft.Exchange.Services.Wcf.SoapWcfResponseRenderer.Render(Message message; Stream stream) at Microsoft.Exchange.Services.Wcf.MessageEncoderWithXmlDeclaration.WriteMessage(Message message; Stream stream) at System.ServiceModel.Channels.HttpOutput.WriteStreamedMessage(TimeSpan timeout) at System.ServiceModel.Channels.HttpOutput.Send(TimeSpan timeout) at System.ServiceModel.Channels.HttpRequestContext.OnReply(Message message; TimeSpan timeout) at System.ServiceModel.Channels.RequestContextBase.Reply(Message message; TimeSpan timeout) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.Reply(MessageRpc& rpc);

Causa
La conexión entre los servidores de Exchange en los dos sitios para esta solicitud es droppedbecause de una configuración de ProxyTimeout.


Solución
Para resolver este problema, aumente el valor de ProxyTimeout en el servidor de entidades emisoras de certificados editando el archivo web.config para EWS. Para ello, siga estos pasos:

  1. Busque el archivo web.config y, a continuación, abra el archivo en el Bloc de notas o en otro programa de edición de texto. La ubicación predeterminada es%ExchangeInstallPath%\ClientAccess\exchweb\ews.
  2. En el archivo, desplácese hasta para encontrar la siguiente instrucción:<AppSettings></AppSettings>
  3. Agregue la línea siguiente en la sección <AppSettings>para aumentar el valor de tiempo de espera:
    </AppSettings>
    <add key="ProxyTimeout" value="120000" />
  4. Reinicie el grupo de aplicaciones de MSExchangeServicesAppPool.

Nota: El valor predeterminado de ProxyTimeoutes el valor de 59000.This debe aumentarse gradualmente hasta que se resuelva el problema. Por ejemplo, comenzar por aumentar el tiempo de espera de 120000. Si el problema persiste, aumente el valor a 210000.
Más información
Para obtener más información, vea Iniciar o detener un grupo de aplicaciones.
EWS, Outlook para MAC, datos adjuntos grandes, ProxyTimeout, entre sitios Proxy

Advertencia: este artículo se tradujo automáticamente

Propiedades

Id. de artículo: 3107326 - Última revisión: 12/11/2015 01:51:00 - Revisión: 1.0

Microsoft Exchange Server 2010 Enterprise, Microsoft Exchange Server 2010 Standard, Microsoft Outlook 2016 for Mac, Microsoft Outlook 2011 for Mac

  • kbsurveynew kbmt KB3107326 KbMtes
Comentarios