Trabajos de almacén de datos producirá un error y se registra el Id. de suceso 33502

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Síntoma
Los trabajos de almacén de datos producirá un error en el Administrador de servicios de Microsoft System Center 2012. Cuando se produce este problema, el suceso siguiente se registra en el registro de sucesos de Operations Manager en el servidor de almacén de datos:

Nombre de registro: Operations Manager
Origen: Almacén de datos
Id. de suceso: 33502
Nivel: Error
Descripción:
Error en la ejecución del módulo de ETL:
Tipo de proceso ETL: transformar
ID de lote: ###
Nombre del módulo: TransformEntityRelatesToEntityFact
Mensaje: Tiempo de espera caducado. El tiempo de espera caducó antes de completar la operación o el servidor no responde.


Cuando ejecuta determinados cmdlets relacionados con el almacén de datos, youfrequently Consulte también un error de tiempo de espera registrado para el móduloTransformEntityRelatesToEntityFact similar al siguiente:

Transform.common de - nombreDeTrabajo de Get-SCDWJobModule
. . .
Error de TransformEntityRelatesToEntityFact de 1952
. . .
Causa
Este problema puede producirse si el volumen de datos de transformación supere la cantidad que pueda ser procesada por los módulos de transformación dentro del período de tiempo de espera. Esto suele ocurrir después de los trabajos de almacén de datos se deshabilitaron durante algún tiempo porque se convierten en puede acumulado rápidamente el volumen de datos que se van a transformar. De forma predeterminada, los trabajos de transformación de almacén de datos tienen un tiempo de espera de 60 minutos codificados.
Solución
Para solucionar este problema, utilice uno de los métodos siguientes.

Método 1

Si cree que se trata de un problema a corto plazo y aislado, procese los trabajos de transformado registrados para la operación de volver a un estado de funcionamiento. Para ello, espere a que el estado de todos los trabajos de almacén de datos para mostrarse comoNo iniciado o errory, a continuación, siga estos pasos:

  1. En el servidor de almacén de fecha, detener el serviciosen HealthService un símbolo del sistema con privilegios elevados. Para ello, ejecute el siguiente comando:

    Net Stop HealthService

    Nota: Dependiendo de la versión de Service Manager, el nombre de este servicio podría mostrarse comoagente de supervisión de Microsoft o System Center Management.
  2. Actualice la siguiente consulta de SQL Server para reflejar el valor NombreMódulodel módulo en el trabajo de Transform.Common que no funciona. Este ejemplo utilizaTransformEntityRelatesToEntityFact.

    Nota: La forma más sencilla de ver el valor NombreMódulopara el módulo que falla es abrir la consola de administrador de servicios, haga clic en elAlmacén de datos, haga clic de nuevo en El almacén de datos , haga clic en trabajos de almacén de datosy, a continuación, haga clic en Transform.Common. En el panel inferior central, puede ver una lista de los módulos y el estado actual. Después de realizar los cambios, ejecute la consulta.

    Use DWStagingAndConfig  declare  @mybatchid INT,  @mysourceid INT,  @outXML XML,  @myProcessCategoryName NVARCHAR(100),  @myProcessName NVARCHAR(100),  @myModuleName NVARCHAR(100),  @sqlString NVARCHAR(150),  @paramDef NVARCHAR(100)  set @myProcessCategoryName = N'Transform'  set @myProcessName = N'Transform.Common'  set @myModuleName = N'TransformEntityRelatesToEntityFact'  USE DWStagingAndConfig  create table #MyTempTable (  ProcessCategoryName NVARCHAR(150),  ProcessName NVARCHAR(150),  BatchId INT,  BatchStatus NVARCHAR(150),  WorkItemStatus NVARCHAR(150),  WorkItems INT  )  insert #MyTempTable  exec Infra.GetBatchDetails @ProcessCategoryName=@myProcessCategoryName, @ProcessName=@myProcessName  select @mybatchid = BatchId from #MyTempTable  select @mysourceid = sourceid from etl.source where SourceName='SCDW'  create table #MyTempTable2 (  myWaterMark XML  )  insert #MyTempTable2  exec etl.GetWaterMark @BatchId=@mybatchid, @ModuleName=@myModuleName, @ProcessName=@myProcessCategoryName, @SourceId=@mysourceid  select @outXML = myWaterMark from #MyTempTable2  create table #MyTempTable3 (  myWaterMark XML,  BatchId INT,  UpdatedRowCount INT,  InsertedRowCount INT  )  USE DWRepository  set @paramDef = N'@ioutXML XML'  set @sqlString = 'insert #MyTempTable3 exec ' + @myModuleName + 'Proc @WaterMark=@ioutXML'  exec sp_executesql @sqlString, @paramDef, @ioutXML=@outXML  select @mybatchid = BatchId, @outXML = myWaterMark from #MyTempTable3  USE DWStagingAndConfig  exec etl.SetWaterMark @BatchId=@mybatchid, @ModuleName=@myModuleName, @ProcessName=@myProcessCategoryName, @SourceId=@mysourceid, @WaterMark=@outXML  drop table #MyTempTable  drop table #MyTempTable2  drop table #MyTempTable3
  3. Reinicie el servicio HealthService en un símbolo del sistema con privilegios elevados. Para ello, ejecute el siguiente comando:

    Net Start HealthService
Nota: Deberá repetir estos pasos varias veces o en varios módulos.

Método 2

Si está utilizando Administrador de identificar de Forefront (FIM), este problema puede reaparecer debido al flujo de datos que llega a Administrador de servicios. Para repartir la carga de trabajo para estos datos, cambiar la programación deFIM_ScheduleReportingIncrementalSynchronizationJob el valor predeterminado de cada 8 horas para cada 2 horas. Para ello, siga estos pasos:

  1. En SQL Server Management Studio, conectarse a la base de datos FIM, expanda Agente de SQL Servery, a continuación, haga clic en trabajos.
  2. Haga clic en FIM_ScheduleReportingIncrementalSynchronizationJob, haga clic en Propiedadesy, a continuación, haga clic en programaciones.
  3. Cambiar el tiene lugar cada valor para FIM_UpdateReportingIncrementalSynchronizationJobSchedule_1 a 2 horas.

Método 3

Para obtener una solución más a largo plazo, actualice a Microsoft System Center 2012 R2 Service Manager acumulativo de actualizaciones 4 (UR4) o una versión posterior. A partir de acumulativo de actualizaciones 4, Service Manager tiene una configuración de tiempo de espera ajustable. Además, el tiempo de espera predeterminado Data Warehouse transformación trabajo cambiará de 60 minutos a 180 minutos. Si no lo suficiente para que el móduloTransform.Common terminar de tres horas, puede aumentar el valor, cambie el valor del registro siguiente:

HKLM\SOFTWARE\Microsoft\System Center\2010\Common\DAL

SqlCommandTimeout = (DWord de 32 bits en segundo)

Nota: Si está utilizando Forefront Identity Manager, debe actualizar a Microsoft Identity Manager 2012 R2 para obtener soporte técnico para Service Manager 2012 R2.

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Propiedades

Id. de artículo: 3137611 - Última revisión: 03/28/2016 17:54:00 - Revisión: 2.0

Microsoft System Center 2012 Service Manager Service Pack 1, Microsoft System Center 2012 R2 Service Manager

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