La aplicación Lync SDK un error "E_NOINTERFACE" cuando se ejecuta con Skype para negocios de 2016

IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.

Haga clic aquí para ver el artículo original (en inglés): 3186696
Síntomas
Tienes Skype para 2016 de negocio instalado e intenta ejecutar una aplicación que utiliza el kit de desarrollo de software (SDK) de 2013 de Lync. Sin embargo, la aplicación produce un error y devuelve el error siguiente:

No se puede convertir el objeto COM del tipo 'Microsoft.Office.Uc.ISignInConfiguration2' de tipo 'Microsoft.Office.Uc.SignInConfigurationClass' para la interfaz. La operación falló debido a un error de la llamada de QueryInterface en el componente COM para la interfaz con IID '{61CE9972-C619-4A88-A5D1-D2DFBCD4D2A1}' debido al siguiente error: interfaz No compatible (excepción de HRESULT: 0 x 80004002 (E_NOINTERFACE)).
Causa
Este problema se produce cuando hay una entrada de registro de COM que faltan para Microsoft.Office.Uc.ISignInConfiguration2.
Solución
Advertencia pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o mediante cualquier otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar que estos problemas puedan resolverse. Modifique el registro bajo su propio riesgo.

Para resolver este problema, cree las siguientes claves del registro del sistema:

HKEY_CLASSES_ROOT\Interface\ {61CE9972-C619-4A88-A5D1-D2DFBCD4D2A1}
@= "ISignInConfiguration2"

HKEY_CLASSES_ROOT\Interface\ {61CE9972-C619-4A88-A5D1-D2DFBCD4D2A1} \ProxyStubClsid32
@= "{00020424-0000-0000-C000-000000000046}"

HKEY_CLASSES_ROOT\Interface\ {61CE9972-C619-4A88-A5D1-D2DFBCD4D2A1} \TypeLib
@= "{B9AA1F11-F480-4054-A84E-B5D9277E40A8}"
"Version" = "1.0"

HKEY_CLASSES_ROOT\Wow6432Node\Interface\ {61CE9972-C619-4A88-A5D1-D2DFBCD4D2A1}
@= "ISignInConfiguration2"

HKEY_CLASSES_ROOT\Wow6432Node\Interface\ {61CE9972-C619-4A88-A5D1-D2DFBCD4D2A1} \ProxyStubClsid32
@= "{00020424-0000-0000-C000-000000000046}"

HKEY_CLASSES_ROOT\Wow6432Node\Interface\ {61CE9972-C619-4A88-A5D1-D2DFBCD4D2A1} \TypeLib
@= "{B9AA1F11-F480-4054-A84E-B5D9277E40A8}"
"Version" = "1.0"

Advertencia: este artículo se tradujo automáticamente

Propiedades

Id. de artículo: 3186696 - Última revisión: 08/27/2016 01:56:00 - Revisión: 2.0

Skype for Business 2016

  • kbmt KB3186696 KbMtes
Comentarios