WD2000: Documento con un objeto incrustado sigue solicitar guardar incluso después establecer guardada propiedad

IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.

325619
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Síntomas
Si la propiedad Saved en el objeto Document se establece en true en Microsoft Word, puede evitar que Word le pide que guarde el documento al cerrar el documento. Esto ocurre incluso si modificar el documento. Sin embargo, si el documento contiene objetos incrustados (objetos estándar de OLE o controles ActiveX), el cuadro de diálogo Guardar aparece incluso si establece la propiedad Saved en true .
Causa
Este comportamiento se produce cuando se modifique el objeto incrustado, pero no guarde el objeto incrustado. Los datos persistentes del objeto no se guardan en el documento. Este indicador "sucio" no se restablece en false cuando se utiliza la propiedad Document.Saved de Word.
Solución
Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Si no aparece en esta sección, enviar una solicitud al servicio de cliente de Microsoft y soporte para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web: Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.Después de instalar el hotfix, la versión en inglés de esta revisión tiene los atributos de archivo enumerados en la tabla siguiente u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
   Date         Time   Size       File name   ------------------------------------------------    23-Nov-2002  14:50      1,804  Hotfix.txt    07-Nov-2002  19:20      2,962  Readme.txt    07-Nov-2002  19:05  3,667,096  Winword.msp    07-Nov-2002  19:41  4,684,436  Winword_admin.msp 				
La versión en inglés de esta revisión debe tener los atributos de archivo siguientes o posteriores:
   Date         Time   Version     Size       File name   ------------------------------------------------------   02-Nov-2002  07:15  9.0.0.7031  8,826,932  Winword.exe				

Nota : los cambios del Registro siguientes deben realizarse para habilitar esta funcionalidad. Para realizar los cambios del registro, siga estos pasos:
  1. Inicie el Editor del Registro.
  2. Busque y haga clic en la siguiente clave del Registro:
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Options
  3. En el menú Edición , haga clic en Agregar valor y agregue el siguiente valor del registro:
    Nombre del valor: EnableSubDocPutSaved
    Tipo de datos: DWORD
    Datos de valor: 0 x 00000001 (habilitar) o 0 x 00000000 (deshabilitar)
  4. Salga del Editor del Registro.
Advertencia : si utiliza incorrectamente el Editor del registro, pueden surgir problemas graves que conlleven la reinstalación del sistema operativo. Microsoft no garantiza que pueda solucionar los problemas resultantes del uso incorrecto del Editor del Registro. Utilice el Editor del Registro bajo su responsabilidad.

Estado
Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:" de este artículo.
Más información

Pasos para reproducir el comportamiento

  1. Inicie Microsoft Word.
  2. Escriba una línea de texto y, a continuación, presione ENTRAR dos veces.
  3. En el menú Insertar , haga clic en objeto .
  4. En la ficha Crear nuevo , haga clic en Hoja de cálculo de Microsoft Excel en la lista de tipos de objeto.
  5. Haga clic en Aceptar para insertar el objeto.
  6. Escriba un valor en la celda A1 de la hoja de cálculo incrustada y, a continuación, haga clic fuera la hoja de cálculo para desactivar Excel.
  7. Presione ALT+F11 para tener acceso a Visual Basic para aplicaciones (VBA) de editor.
  8. En el menú Insertar , haga clic en módulo para insertar un nuevo módulo.
  9. Pegue el código siguiente en el nuevo módulo:
    Sub SetSaved()  Application.ActiveDocument.Saved = TrueEnd Sub					
  10. Cierre el editor de VBA.
  11. En el menú archivo , haga clic en Guardar .
  12. Guarde el archivo como C:\Test.doc .
  13. En el menú archivo , haga clic en Cerrar para cerrar el documento.
  14. En el menú archivo , haga clic en Abrir para volver a abrir el documento.
  15. Haga doble clic en la hoja de cálculo y, a continuación, coloque un valor en la celda B1.
  16. Haga clic fuera de la hoja de cálculo para desactivarla.
  17. En el menú Herramientas , haga clic en macro y, a continuación, haga clic en macros... .
  18. Haga clic para seleccionar SetSaved y, a continuación, haga clic en Ejecutar para ejecutar la macro.
  19. En el menú archivo , haga clic en Cerrar para cerrar el documento.

    Observe que le pedirá que guarde el documento.

Advertencia: este artículo se ha traducido automáticamente

Propiedades

Id. de artículo: 325619 - Última revisión: 02/09/2014 04:25:41 - Revisión: 3.2

  • Microsoft Word 2000 Standard Edition
  • kbnosurvey kbarchive kbmt kbautohotfix kbqfe kbhotfixserver kbbug kbfix KB325619 KbMtes
Comentarios