Localización de referencias circulares

Este artículo se publicó anteriormente con el número E10265
Renuncia a responsabilidad de los contenidos de la KB sobre productos a los que ya no se ofrece asistencia alguna
El presente artículo se escribió para productos para los que Microsoft ya no ofrece soporte técnico. Por tanto, el presente artículo se ofrece "tal cual" y no será actualizado.
Resumen
Una referencia circular existe cuando hay fórmulas que se refieren a otras y estas dependen unas de otras. Por ejemplo, si la celda A1 contiene la formula "=B1" y la celda B1 contiene la formula "=A1", se ha generado una referencia circular ya que ambas fórmulas dependen la una de la otra para su respuesta.

Si crea una referencia circular en Microsoft Excel, recibe el siguiente mensaje de error:
"No se pueden resolver Referencias Circulares"
al aceptar la fórmula. En la barra de estado aparece el siguiente mensaje, donde ref_celda es parte de la referencia circular:
Circular: ref_celda
NOTA: Si esta usando Microsoft Excel 7.0, la barra de estadovisualizará "Calcular: ref_celda" o "Calcular" en lugar de"Circular: ref_celda" o "Circular."

Si dispone de más de un libro abierto y la barra de estado sólo visualiza "Circular" (sin las comillas), entonces una de las restantes hojas o libros de trabajo contiene una referencia circular. Necesita ir activando el resto de las hojas, una a una, hasta que la barra de estado visualice el mensaje "Circular: ref_celda".
Solución
Para encontrar todas las celdas implicadas en una referencia circular siga los siguientes pasos:

MICROSOFT EXCEL VERSION 5.0 Y POSTERIOR

  1. Método por menús.
    1. Seleccionar la celda que haga referencia en la barra de estado.
    2. Del menú Edición, seleccionar Ir A, y después seleccionar el botón Especial.
    3. Seleccionar la opción Precedentes, después activar la opción Todos los Niveles, y pulsar en Aceptar.
    Todas las celdas de esta referencia circular son remarcadas en la hoja. Continuar con dicho procedimiento hasta que todas las referencias circulares hayan sido encontradas.
  2. Método por Barra de herramientas.
    1. Seleccionar la celda que haga referencia en la barra de estado.
    2. Del menú Ver, elegir Barras de Herramientas.
    3. De la lista de barras, seleccionar Auditoria, y pulsar Aceptar.
    4. De la barra de herramientas de Auditoria, seleccionar el botón Rastrear Precedentes, click en dicho botón hasta que el sistema emita un sonido, indicando que no existen más precedentes.
    Cada vez que pulsa el botón de Rastrear Precedentes, el sistema dibuja una flecha apuntando al nivel o celda precedente.
  3. Método Visual Basic.
    1. En un módulo nuevo, introduzca el siguiente código Visual Basic:
      Proced Ejemplo()
      HojaActiva.ReferenciaCircular.Seleccionar
      CeldaActiva.CeldasPrecedentes.Seleccionar
      Fin Proced
    2. Seleccione la pestaña de la hoja que contiene la referencia circular, y ejecute la macro Ejemplo.
    Todas las celdas para esta referencia circular son resaltadas en la hoja activa.
PRECAUCIÓN: CUALQUIER UTILIZACIÓN POR SU PARTE DEL CÓDIGO INCLUIDO EN ESTE ARTÍCULO SE HARÁ A SU CUENTA Y RIESGO. Microsoft facilita estecódigo "tal cual" sin garantía de ningún tipo, ya sea explícita oimplícita, incluyendo expresamente en tal exención de responsabilidady, a efectos meramente enunciativos y no limitativos, las garantíaslegales mercantiles implícitas y/o la adecuación a un propósito ofinalidad en particular.
Más información
Por defecto, en las versiones de Microsoft Excel 2.2, 3.0, 4.0, 5.0, la barra de estado esta activada. En caso contrario, para activarla, seleccionar Barra de Estado del Menú Ver. En Microsoft Excel 4.0 o anteriores, elegir Area de Trabajo, del menú Opciones, seleccionar Barra de Estado y pulsar Aceptar.
Propiedades

Id. de artículo: 550264 - Última revisión: 04/21/2005 00:02:18 - Revisión: 1.3

Microsoft Excel 95 Standard Edition, Microsoft Excel para Windows NT, versión 5.0, Microsoft Excel 2.1 Standard Edition, Microsoft Excel 2.10c, Microsoft Excel 2.10d, Microsoft Excel 2.01, Microsoft Excel 2.0 Standard Edition, Microsoft Excel 3.0 Standard Edition, Microsoft Excel 3.0a, Microsoft Excel 4.0 Standard Edition, Microsoft Excel 4.0a, Microsoft Excel 4.0c, Microsoft Excel 5.0 Standard Edition, Microsoft Excel 5.0c, Microsoft Excel para Windows, versiones 2.x, 3.x, 4.x, 5.0, 5.0c, Microsoft Excel 2004 for Mac

  • borrar circular error excel97 fórmula referencia KB550264
Comentarios