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PRB: La función Restaurar sistema de Windows no supervisa los archivos de revisiones de Windows Installer (.msp)

Ha finalizado el soporte técnico para Windows XP

Microsoft puso fin al soporte técnico para Windows XP el 8 de abril de 2014. Este cambio ha afectado a las actualizaciones de software y las opciones de seguridad. Sepa qué significa esto en su caso y cómo puede mantenerse protegido.

Síntomas
Al intentar restaurar un equipo con Windows XP hasta un punto de restauración anterior a la aplicación de una revisión o un Service Pack, es posible que la aplicación a la que aplicó la revisión ya no pueda seguir usándose. Al intentar reparar, instalar, reinstalar o quitar la aplicación, puede aparecer el mensaje de error siguiente:
"No se pudo abrir el paquete de revisión. Compruebe que dicho paquete existe y que tiene acceso al mismo, o póngase en contacto con el proveedor de la aplicación para comprobar que se trata de un paquete de revisión de Windows Installer válido".
Causa
Este problema se produce porque Restaurar sistema de Windows XP no supervisa los archivos de revisión de Windows Installer (.msp). Al instalar los archivos de revisión, la ruta de acceso de la caché no se restaura en la carpeta carpetaDeWindows\Installer. Además, el Service Pack 2 (SP2) es acumulativo. Contiene los archivos de Ingeniería de corrección rápida (QFE). Después de instalar el SP2, los archivos QFE individuales que instaló se quedan obsoletos. Windows Installer quita los datos de configuración para las revisiones QFE incluidas en las claves del Registro.

Puesto que al usar Restaurar sistema la revisión no está ya almacenada en caché, Windows Installer intenta almacenar de nuevo la ruta de acceso desde la ubicación de origen registrada de la revisión. Sin embargo, la ubicación de origen registrada para muchas revisiones de aplicaciones es la carpeta Temp. Esta carpeta es temporal. Normalmente, los archivos de la carpeta Temp se eliminan después de usarse. Por tanto, es posible que no se encuentren los archivos que Windows Installer intenta buscar en la ubicación de origen temporal. El error se produce porque Windows Installer no puede encontrar los archivos de revisión de Windows Installer (.msp).
Solución
Para solucionar temporalmente este problema, vuelva a aplicar las revisiones que falten. Cuando la ubicación de una revisión sea un recurso compartido multimedia o de red que esté disponible, es posible que pueda encontrarla y aplicarla desde allí. También puede instalar la revisión más reciente de Service Pack para la aplicación ya que contiene los QFE anteriores. La revisión acumulativa aplica a la aplicación las revisiones que faltan y hace que éstas se vuelvan obsoletas.
Estado
Este comportamiento es una característica del diseño de la aplicación.
Más información
Pasos para reproducir este comportamiento
  1. Instale una aplicación (por ejemplo, Office XP) en el equipo. De forma predeterminada se crea un punto de restauración. Este punto de restauración almacena el estado del sistema anterior a la instalación de la nueva aplicación.

    Nota
    Cuando instala una aplicación nueva, el sistema operativo crea automáticamente un punto de restauración.
  2. Instale un Service Pack para la aplicación que instaló en el paso 1. Por ejemplo, instale Service Pack 1 para Office XP.
  3. Instale algunas revisiones QFE para la aplicación. Por ejemplo, instale dos QFE para Office XP.
  4. Cree un punto de restauración.

    Pasos para crear un punto de restauración en Windows XP
    1. Haga clic en Inicio, seleccione Programas, Accesorios, Herramientas del sistema y, a continuación, haga clic en Restaurar sistema.
    2. Haga clic para seleccionar Crear un punto de restauración y, a continuación, haga clic en Siguiente.
    3. Escriba Antes del punto de restauración del SP2 en el cuadro de texto Descripción de punto de restauración.
    4. Haga clic en Crear.
  5. Instale el Service Pack 2 para la aplicación. Por ejemplo, instale el SP2 para Office XP.
    Nota
    El SP2 contiene los QFE anteriores. Con este paso, los QFE individuales que instaló en el paso 3 se quedan obsoletos. Windows Installer quita los datos de configuración para las revisiones QFE, incluidas las claves del Registro y los archivos almacenados en caché.
  6. Compruebe que los archivos de origen de los Service Pack y los QFE no son accesibles a través del equipo. Por ejemplo, quite el recurso compartido de red para el QFE.
  7. Restaure el sistema al estado anterior a la instalación del Service Pack 2.

    Pasos para restaurar el sistema en Windows XP
    1. Haga clic en Inicio, seleccione Programas, Accesorios, Herramientas del sistema y, a continuación, haga clic en Restaurar sistema.
    2. Haga clic para seleccionar en Restaurar mi equipo a un estado anterior y, a continuación, haga clic en Siguiente.
    3. Seleccione la fecha en que realizó el paso 4 y, después, seleccione Antes del punto de restauración del SP2 en la lista de puntos de restauración.
    4. Haga clic en Siguiente.
  8. Intente reparar o quitar la aplicación, o pruebe a instalar de nuevo la aplicación. Puede recibir el mensaje de error mencionado en la sección "Síntomas".
Referencias
Para obtener información adicional al respecto, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
302796 Cómo solucionar problemas de la herramienta Restaurar sistema en Windows XP
303354 Mensaje de error: Restaurar sistema no pudo crear un punto de restauración
310405 Cómo activar y desactivar Restaurar sistema en Windows XP
306084 CÓMO: Restaurar el sistema operativo Windows XP a un estado anterior
Propiedades

Id. de artículo: 814833 - Última revisión: 01/24/2007 16:33:04 - Revisión: 3.0

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • kbupgrade kbsetup kbappsetup kbpreinstall kbprb KB814833
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